summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-07-15 00:26:35 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-07-15 00:26:35 +0000
commit5f532468bcf6e6ae16abaef03e48f1139bba9daf (patch)
tree25b58e7c4e876eadf8800bd6b53647fbb0aa2e56 /dev-db
parentProvide sane default values for the SERVER_URI if it is not set. (diff)
downloadgentoo-2-5f532468bcf6e6ae16abaef03e48f1139bba9daf.tar.gz
gentoo-2-5f532468bcf6e6ae16abaef03e48f1139bba9daf.tar.bz2
gentoo-2-5f532468bcf6e6ae16abaef03e48f1139bba9daf.zip
Cleanup of src_test code so that the enterprise and community ebuilds can be very similar. Note that upstream has changed the testing procedures such that they will always fail if you use FEATURES=-userpriv.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/ChangeLog10
-rw-r--r--dev-db/mysql/files/digest-mysql-5.0.44-r16
-rw-r--r--dev-db/mysql/mysql-5.0.44-r1.ebuild64
3 files changed, 79 insertions, 1 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index 7bf3f5558f86..a3f69c636ffa 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-db/mysql
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.420 2007/07/11 17:49:37 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.421 2007/07/15 00:26:35 robbat2 Exp $
+
+*mysql-5.0.44-r1 (15 Jul 2007)
+
+ 15 Jul 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +mysql-5.0.44-r1.ebuild:
+ Cleanup of src_test code so that the enterprise and community ebuilds can be
+ very similar. Note that upstream has changed the testing procedures such
+ that they will always fail if you use FEATURES=-userpriv.
11 Jul 2007; Michael Sterrett <mr_bones_@gentoo.org> mysql-5.0.44.ebuild:
fix inherit order so DESCRIPTION is properly set
diff --git a/dev-db/mysql/files/digest-mysql-5.0.44-r1 b/dev-db/mysql/files/digest-mysql-5.0.44-r1
new file mode 100644
index 000000000000..8b7b41323415
--- /dev/null
+++ b/dev-db/mysql/files/digest-mysql-5.0.44-r1
@@ -0,0 +1,6 @@
+MD5 a6a557758bfb66557a1182db75b46b2f mysql-5.0.44.tar.gz 24388270
+RMD160 7b380cf13d040149e5f0e75b582124ec996e0b03 mysql-5.0.44.tar.gz 24388270
+SHA256 e3cd455da52769cc7c80845992dedc9092745fcf3ea4d4929ae4181418805973 mysql-5.0.44.tar.gz 24388270
+MD5 6619312d9ec44aba9ffbef530fc03cdc mysql-extras-20070710.tar.bz2 52626
+RMD160 e0f39f1fd35012fb3e2a431379d7b15389e05187 mysql-extras-20070710.tar.bz2 52626
+SHA256 980a5fa500f4136e13bf434f167995248b9c8f96a2c42c96e4d7ad60246ad7fc mysql-extras-20070710.tar.bz2 52626
diff --git a/dev-db/mysql/mysql-5.0.44-r1.ebuild b/dev-db/mysql/mysql-5.0.44-r1.ebuild
new file mode 100644
index 000000000000..da67d205a11f
--- /dev/null
+++ b/dev-db/mysql/mysql-5.0.44-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.44-r1.ebuild,v 1.1 2007/07/15 00:26:35 robbat2 Exp $
+
+MY_EXTRAS_VER="20070710"
+
+inherit toolchain-funcs mysql
+
+# REMEMBER: also update eclass/mysql*.eclass before committing!
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+# When MY_EXTRAS is bumped, the index should be revised to exclude these.
+EPATCH_EXCLUDE=''
+
+src_test() {
+ make check || die "make check failed"
+ if ! use "minimal" ; then
+ if ! hasq "userpriv" ${FEATURES} ; then
+ die "Testing with FEATURES=-userpriv is no longer supported by upstream"
+ fi
+ cd "${S}"
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ local retstatus1
+ local retstatus2
+ local t
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ # mysqladmin start before dir creation
+ mkdir -p "${S}"/mysql-test/var{,/log}
+
+ # Ensure that parallel runs don't die
+ export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
+
+ case ${PV} in
+ 5.0.42)
+ mysql_disable_test "archive_gis" "Broken in 5.0.42" ;;
+
+ 5.0.44)
+ [ "$(tc-endian)" == "big" ] && \
+ mysql_disable_test "archive_gis" "Broken in 5.0.4[45] on big-endian boxes only" ;;
+
+ 5.0.45)
+ [ "$(tc-endian)" == "big" ] && \
+ mysql_disable_test "archive_gis" "Broken in 5.0.4[45] on big-endian boxes only" ;;
+ esac
+
+ # We run the test protocols seperately
+ make -j1 test-ns force=--force
+ retstatus1=$?
+ [[ $retstatus1 -eq 0 ]] || eerror "test-ns failed"
+
+ make -j1 test-ps force=--force
+ retstatus2=$?
+ [[ $retstatus2 -eq 0 ]] || eerror "test-ps failed"
+
+ # Cleanup is important for these testcases.
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+ [[ $retstatus1 -eq 0 ]] || die "test-ns failed"
+ [[ $retstatus2 -eq 0 ]] || die "test-ps failed"
+ else
+ einfo "Skipping server tests due to minimal build."
+ fi
+}