summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-05-07 03:59:38 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-05-07 03:59:38 +0000
commit9afc7aa78592abfec7d3d35361f00e5a0f974981 (patch)
tree252a1f8dca3722db7b9100e5782ece506cbb4a9a /dev-db
parentLinux Mint's fork of gnome-menus, needed for Cinnamon-2.x (diff)
downloadgentoo-2-9afc7aa78592abfec7d3d35361f00e5a0f974981.tar.gz
gentoo-2-9afc7aa78592abfec7d3d35361f00e5a0f974981.tar.bz2
gentoo-2-9afc7aa78592abfec7d3d35361f00e5a0f974981.zip
Add -9999 ebuild
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/hyperdex/ChangeLog7
-rw-r--r--dev-db/hyperdex/hyperdex-9999.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-db/hyperdex/ChangeLog b/dev-db/hyperdex/ChangeLog
index eef8732a23e2..a3b5a86c862c 100644
--- a/dev-db/hyperdex/ChangeLog
+++ b/dev-db/hyperdex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/hyperdex
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/ChangeLog,v 1.18 2014/05/07 03:38:14 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/ChangeLog,v 1.19 2014/05/07 03:59:38 patrick Exp $
+
+*hyperdex-9999 (07 May 2014)
+
+ 07 May 2014; Patrick Lauer <patrick@gentoo.org> +hyperdex-9999.ebuild:
+ Add -9999 ebuild
*hyperdex-1.2.0-r1 (07 May 2014)
diff --git a/dev-db/hyperdex/hyperdex-9999.ebuild b/dev-db/hyperdex/hyperdex-9999.ebuild
new file mode 100644
index 000000000000..e0bbc8483b35
--- /dev/null
+++ b/dev-db/hyperdex/hyperdex-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/hyperdex-9999.ebuild,v 1.1 2014/05/07 03:59:38 patrick Exp $
+EAPI=5
+
+PYTHON_COMPAT=( python2_7)
+inherit eutils python-r1 autotools git-r3
+
+DESCRIPTION="A searchable distributed Key-Value Store"
+
+HOMEPAGE="http://hyperdex.org"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+
+EGIT_REPO_URI="https://github.com/rescrv/HyperDex.git"
+
+SRC_URI="http://dev.gentooexperimental.org/~patrick/autotools-java.tar"
+
+IUSE="+python"
+# need to add ruby and java useflags too
+
+DEPEND="dev-cpp/glog
+ dev-cpp/sparsehash
+ dev-libs/cityhash
+ dev-libs/libpo6
+ dev-libs/libe
+ dev-libs/busybee
+ dev-libs/popt
+ dev-libs/replicant
+ dev-libs/json-c"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cd m4; tar xf "${DISTDIR}/autotools-java.tar"
+ cd ..
+ sed -i -e 's~json/json.h~json-c/json.h~' configure.ac common/datatype_document.cc daemon/index_document.cc || die "Blergh!"
+ eautoreconf
+}
+src_configure() {
+ econf --disable-static \
+ $(use_enable python python-bindings)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Failed to install"
+ newinitd "${FILESDIR}/hyperdex.initd" hyperdex || die "Failed to install init script"
+ newconfd "${FILESDIR}/hyperdex.confd" hyperdex || die "Failed to install config file"
+ find "${D}" -name '*.la' -exec rm {} \; # bad buildsystem! bad!
+}