summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-12-28 21:25:23 +0000
committerJustin Lecher <jlec@gentoo.org>2013-12-28 21:25:23 +0000
commitac8d7f42bea1d2f0a04e6aae932666eea9d3ecad (patch)
treea247500ac8afe97b74e9d9805cb709d45f9716f9 /dev-db
parentdev-db/wxsqlite3: Import from sunrise, thanks Cédric Krier for the initial e... (diff)
downloadgentoo-2-ac8d7f42bea1d2f0a04e6aae932666eea9d3ecad.tar.gz
gentoo-2-ac8d7f42bea1d2f0a04e6aae932666eea9d3ecad.tar.bz2
gentoo-2-ac8d7f42bea1d2f0a04e6aae932666eea9d3ecad.zip
dev-db/wxsqlite3: Fix pkgconfig file installation
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/wxsqlite3/ChangeLog5
-rw-r--r--dev-db/wxsqlite3/wxsqlite3-3.0.6.1.ebuild13
2 files changed, 14 insertions, 4 deletions
diff --git a/dev-db/wxsqlite3/ChangeLog b/dev-db/wxsqlite3/ChangeLog
index d02fe7697218..e17916dbd396 100644
--- a/dev-db/wxsqlite3/ChangeLog
+++ b/dev-db/wxsqlite3/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-db/wxsqlite3
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/wxsqlite3/ChangeLog,v 1.1 2013/12/28 21:14:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/wxsqlite3/ChangeLog,v 1.2 2013/12/28 21:25:23 jlec Exp $
+
+ 28 Dec 2013; Justin Lecher <jlec@gentoo.org> wxsqlite3-3.0.6.1.ebuild:
+ Fix pkgconfig file installation
*wxsqlite3-3.0.6.1 (28 Dec 2013)
diff --git a/dev-db/wxsqlite3/wxsqlite3-3.0.6.1.ebuild b/dev-db/wxsqlite3/wxsqlite3-3.0.6.1.ebuild
index 16afaa06e906..f58911bbd981 100644
--- a/dev-db/wxsqlite3/wxsqlite3-3.0.6.1.ebuild
+++ b/dev-db/wxsqlite3/wxsqlite3-3.0.6.1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/wxsqlite3/wxsqlite3-3.0.6.1.ebuild,v 1.1 2013/12/28 21:14:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/wxsqlite3/wxsqlite3-3.0.6.1.ebuild,v 1.2 2013/12/28 21:25:23 jlec Exp $
EAPI=5
WX_GTK_VER="2.8"
-inherit eutils wxwidgets
+inherit eutils multilib wxwidgets
DESCRIPTION="C++ wrapper around the public domain SQLite 3.x database"
HOMEPAGE="http://wxcode.sourceforge.net/components/wxsqlite3/"
@@ -27,7 +27,11 @@ S="${WORKDIR}/${P%.1}"
src_prepare() {
rm -rf sqlite3 || die
cp configure28 configure || die
- cat "${FILESDIR}"/${P}.pc.in > ${PN}.pc.in || die
+ sed \
+ -e "s:@WXVERSION@:${WX_GTK_VER}:g" \
+ -e "s:@LIBDIR@:$(get_libdir):g" \
+ -e "s:@VERSION@:${PV}:g" \
+ "${FILESDIR}"/${P}.pc.in > ${PN}.pc || die
}
src_configure() {
@@ -42,6 +46,9 @@ src_configure() {
src_install() {
default
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins ${PN}.pc
+
dodoc Readme.txt
dohtml -r docs/html/*
docinto samples