summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-04-16 02:36:33 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-04-16 02:36:33 +0000
commitb02f030d692567dd4e0d6083484b800e68190b17 (patch)
tree2f46ffb5c36d488d5fb4f74d9a67311e8ced54d2 /dev-db
parentAdded ~x86 keyword. (diff)
downloadgentoo-2-b02f030d692567dd4e0d6083484b800e68190b17.tar.gz
gentoo-2-b02f030d692567dd4e0d6083484b800e68190b17.tar.bz2
gentoo-2-b02f030d692567dd4e0d6083484b800e68190b17.zip
The cluster tests fail when run as root, so block them when FEATURES=-userpriv.
(Portage version: 2.1.2.3)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/ChangeLog5
-rw-r--r--dev-db/mysql/mysql-5.0.38.ebuild32
2 files changed, 20 insertions, 17 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index e841bb6bc668..d797e7399ee5 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-db/mysql
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.395 2007/04/15 20:53:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.396 2007/04/16 02:36:33 robbat2 Exp $
+
+ 16 Apr 2007; Robin H. Johnson <robbat2@gentoo.org> mysql-5.0.38.ebuild:
+ The cluster tests fail when run as root, so block them when FEATURES=-userpriv.
15 Apr 2007; Raúl Porcel <armin76@gentoo.org> mysql-5.0.38.ebuild:
ia64 stable wrt security bug 171934
diff --git a/dev-db/mysql/mysql-5.0.38.ebuild b/dev-db/mysql/mysql-5.0.38.ebuild
index c3ff369b8a6d..9d63ccad7460 100644
--- a/dev-db/mysql/mysql-5.0.38.ebuild
+++ b/dev-db/mysql/mysql-5.0.38.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.38.ebuild,v 1.5 2007/04/15 20:53:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.38.ebuild,v 1.6 2007/04/16 02:36:33 robbat2 Exp $
MY_EXTRAS_VER="20070415"
SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${PV//_/-}.tar.gz"
@@ -32,23 +32,23 @@ src_test() {
mysql_disable_test "im_options_set" "fails as root"
mysql_disable_test "im_options_unset" "fails as root"
mysql_disable_test "im_utils" "fails as root"
+
+ # As of 5.0.38, these work with the sandbox
+ # but they break if you are root
+ for t in \
+ loaddata_autocom_ndb \
+ ndb_{alter_table{,2},autodiscover{,2,3},basic,bitfield,blob} \
+ ndb_{cache{,2},cache_multi{,2},charset,condition_pushdown,config} \
+ ndb_{database,gis,index,index_ordered,index_unique,insert,limit} \
+ ndb_{loaddatalocal,lock,minmax,multi,read_multi_range,rename,replace} \
+ ndb_{restore,subquery,transaction,trigger,truncate,types,update} \
+ ps_7ndb rpl_ndb_innodb_trans strict_autoinc_5ndb \
+ mysql_upgrade
+ do
+ mysql_disable_test "${t}" "fails as root"
+ done
fi
- # As of 5.0.38, these work with the sandbox
- # Tested by robbat2, on ppc64-32ul and amd64.
- ##for t in \
- ##loaddata_autocom_ndb \
- ##ndb_{alter_table{,2},autodiscover{,2,3},basic,bitfield,blob} \
- ##ndb_{cache{,2},cache_multi{,2},charset,condition_pushdown,config} \
- ##ndb_{database,gis,index,index_ordered,index_unique,insert,limit} \
- ##ndb_{loaddatalocal,lock,minmax,multi,read_multi_range,rename,replace} \
- ##ndb_{restore,subquery,transaction,trigger,truncate,types,update} \
- ##ps_7ndb rpl_ndb_innodb_trans strict_autoinc_5ndb \
- ##mysql_upgrade
- ##do
- ## mysql_disable_test "${t}" "fails with sandbox enabled"
- ##done
-
# Both of these seem to work as of 5.0.38
##use "extraengine" && mysql_disable_test "federated" "fails with extraengine USE"
##use "ssl" && mysql_disable_test "ssl_des" "fails requiring PEM passphrase"