summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-03-24 19:49:09 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-03-24 19:49:09 +0000
commitca0e821a54303c64f22e1195ed5aaa5e683adc7d (patch)
tree3d752cc5ccfdaf4482d534361647175261d22980 /dev-db
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-ca0e821a54303c64f22e1195ed5aaa5e683adc7d.tar.gz
gentoo-2-ca0e821a54303c64f22e1195ed5aaa5e683adc7d.tar.bz2
gentoo-2-ca0e821a54303c64f22e1195ed5aaa5e683adc7d.zip
Bug #254725: IUSE default to ensure always builds.
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql-super-smack/ChangeLog10
-rw-r--r--dev-db/mysql-super-smack/mysql-super-smack-1.3-r2.ebuild55
2 files changed, 63 insertions, 2 deletions
diff --git a/dev-db/mysql-super-smack/ChangeLog b/dev-db/mysql-super-smack/ChangeLog
index 69137441a5ae..103b331934ff 100644
--- a/dev-db/mysql-super-smack/ChangeLog
+++ b/dev-db/mysql-super-smack/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/mysql-super-smack
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-super-smack/ChangeLog,v 1.12 2008/11/14 06:30:20 robbat2 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-super-smack/ChangeLog,v 1.13 2010/03/24 19:49:09 robbat2 Exp $
+
+*mysql-super-smack-1.3-r2 (24 Mar 2010)
+
+ 24 Mar 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +mysql-super-smack-1.3-r2.ebuild:
+ Bug #254725: IUSE default to ensure always builds.
*mysql-super-smack-1.3-r1 (14 Nov 2008)
diff --git a/dev-db/mysql-super-smack/mysql-super-smack-1.3-r2.ebuild b/dev-db/mysql-super-smack/mysql-super-smack-1.3-r2.ebuild
new file mode 100644
index 000000000000..afcf7fd9894e
--- /dev/null
+++ b/dev-db/mysql-super-smack/mysql-super-smack-1.3-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-super-smack/mysql-super-smack-1.3-r2.ebuild,v 1.1 2010/03/24 19:49:09 robbat2 Exp $
+
+WANT_AUTOMAKE="1.4"
+EAPI=2
+
+inherit eutils autotools
+
+MY_PN="super-smack"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="MySQL Super Smack is a benchmarking, stress testing, and load generation tool for MySQL & PostGreSQL."
+HOMEPAGE="http://vegan.net/tony/supersmack/"
+SRC_URI="http://vegan.net/tony/supersmack/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+mysql postgres"
+
+DEPEND="mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-server )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use !mysql && use !postgres && die "You need to use at least one of USE=mysql or USE=postgres for benchmarking!"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.destdir.patch
+ epatch "${FILESDIR}"/${PN}-1.3.amd64.patch
+ epatch "${FILESDIR}"/${PN}-1.3.gcc4.3.patch
+ epatch "${FILESDIR}"/${PN}-1.3-gen-data.patch
+ eautomake || die "automake failed"
+}
+
+src_configure() {
+ local myconf=""
+ use mysql && myconf="${myconf} --with-mysql"
+ use postgres && myconf="${myconf} --with-pgsql"
+ myconf="${myconf} --with-datadir=/var/tmp/${MY_PN}"
+ myconf="${myconf} --with-smacks-dir=/usr/share/${MY_PN}"
+ econf ${myconf} || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc CHANGES INSTALL MANUAL README TUTORIAL
+}
+
+pkg_postinst() {
+ elog "The gen-data binary is now installed as super-smack-gen-data"
+}