summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2014-06-16 11:05:15 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2014-06-16 11:05:15 +0000
commitea0cd895dca93edd9b7aa80148e7d56def9a4bb0 (patch)
tree62a14cd66faef69444392cb2d20832d33fcf0817 /dev-db
parentStable for amd64 wrt bug #510560 (diff)
downloadgentoo-2-ea0cd895dca93edd9b7aa80148e7d56def9a4bb0.tar.gz
gentoo-2-ea0cd895dca93edd9b7aa80148e7d56def9a4bb0.tar.bz2
gentoo-2-ea0cd895dca93edd9b7aa80148e7d56def9a4bb0.zip
fix #513020, drop old
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/redis/ChangeLog9
-rw-r--r--dev-db/redis/redis-2.6.13.ebuild106
-rw-r--r--dev-db/redis/redis-2.6.9.ebuild101
-rw-r--r--dev-db/redis/redis-2.8.11.ebuild (renamed from dev-db/redis/redis-2.8.7.ebuild)4
-rw-r--r--dev-db/redis/redis-2.8.5.ebuild109
-rw-r--r--dev-db/redis/redis-2.8.6.ebuild109
6 files changed, 10 insertions, 428 deletions
diff --git a/dev-db/redis/ChangeLog b/dev-db/redis/ChangeLog
index 48346e6da5d9..39035bed5354 100644
--- a/dev-db/redis/ChangeLog
+++ b/dev-db/redis/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/redis
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/ChangeLog,v 1.80 2014/05/20 10:53:58 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/ChangeLog,v 1.81 2014/06/16 11:05:15 ultrabug Exp $
+
+*redis-2.8.11 (16 Jun 2014)
+
+ 16 Jun 2014; Ultrabug <ultrabug@gentoo.org> -redis-2.6.9.ebuild,
+ -redis-2.6.13.ebuild, -redis-2.8.5.ebuild, -redis-2.8.6.ebuild,
+ -redis-2.8.7.ebuild, +redis-2.8.11.ebuild:
+ version bump fix #513020, drop old
20 May 2014; Jeroen Roovers <jer@gentoo.org> redis-2.8.9.ebuild:
Marked ~hppa (bug #510626).
diff --git a/dev-db/redis/redis-2.6.13.ebuild b/dev-db/redis/redis-2.6.13.ebuild
deleted file mode 100644
index 818c4fd1a87a..000000000000
--- a/dev-db/redis/redis-2.6.13.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/redis-2.6.13.ebuild,v 1.4 2013/07/04 12:23:47 ago Exp $
-
-EAPI=5
-
-inherit autotools eutils flag-o-matic toolchain-funcs user
-
-DESCRIPTION="A persistent caching system, key-value and data structures database."
-HOMEPAGE="http://redis.io/"
-SRC_URI="http://redis.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-KEYWORDS="amd64 x86 ~x86-macos ~x86-solaris"
-IUSE="+jemalloc tcmalloc test"
-SLOT="0"
-
-RDEPEND="tcmalloc? ( dev-util/google-perftools )
- jemalloc? ( >=dev-libs/jemalloc-3.2 )"
-DEPEND=">=sys-devel/autoconf-2.63
- test? ( dev-lang/tcl )
- ${RDEPEND}"
-REQUIRED_USE="tcmalloc? ( !jemalloc )
- jemalloc? ( !tcmalloc )"
-
-S="${WORKDIR}/${PN}-${PV/_/-}"
-
-pkg_setup() {
- enewgroup redis 75
- enewuser redis 75 -1 /var/lib/redis redis
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-2.6.7"-{shared,config}.patch
-
- # bug 467172, 467174
- sed -i -e 's:AR=:AR?=:g' -e 's:RANLIB=:RANLIB?=:g' "${S}/deps/lua/src/Makefile" || die
-
- # now we will rewrite present Makefiles
- local makefiles=""
- for MKF in $(find -name 'Makefile' | cut -b 3-); do
- mv "${MKF}" "${MKF}.in"
- sed -i -e 's:$(CC):@CC@:g' \
- -e 's:$(CFLAGS):@AM_CFLAGS@:g' \
- -e 's: $(DEBUG)::g' \
- -e 's:$(OBJARCH)::g' \
- -e 's:ARCH:TARCH:g' \
- -e '/^CCOPT=/s:$: $(LDFLAGS):g' \
- "${MKF}.in" \
- || die "Sed failed for ${MKF}"
- makefiles+=" ${MKF}"
- done
- # autodetection of compiler and settings; generates the modified Makefiles
- cp "${FILESDIR}"/configure.ac-2.2 configure.ac
- sed -i -e "s:AC_CONFIG_FILES(\[Makefile\]):AC_CONFIG_FILES([${makefiles}]):g" \
- configure.ac || die "Sed failed for configure.ac"
- eautoconf
-}
-
-src_configure() {
- econf
-
- # Linenoise can't be built with -std=c99, see https://bugs.gentoo.org/451164
- # also, don't define ANSI/c99 for lua twice
- sed -i -e "s:-std=c99::g" deps/linenoise/Makefile deps/Makefile || die
-}
-
-src_compile() {
- tc-export CC AR RANLIB
-
- local myconf=""
-
- if use tcmalloc ; then
- myconf="${myconf} USE_TCMALLOC=yes"
- elif use jemalloc ; then
- myconf="${myconf} JEMALLOC_SHARED=yes"
- else
- myconf="${myconf} MALLOC=yes"
- fi
-
- emake ${myconf} V=1 CC="${CC}" AR="${AR} rcu" RANLIB="${RANLIB}"
-}
-
-src_install() {
- insinto /etc/
- doins redis.conf sentinel.conf
- use prefix || fowners redis:redis /etc/{redis,sentinel}.conf
- fperms 0644 /etc/{redis,sentinel}.conf
-
- newconfd "${FILESDIR}/redis.confd" redis
- newinitd "${FILESDIR}/redis.initd-2" redis
-
- nonfatal dodoc 00-RELEASENOTES BUGS CONTRIBUTING MANIFESTO README
-
- dobin src/redis-cli
- dosbin src/redis-benchmark src/redis-server src/redis-check-aof src/redis-check-dump
- fperms 0750 /usr/sbin/redis-benchmark
- dosym /usr/sbin/redis-server /usr/sbin/redis-sentinel
-
- if use prefix; then
- diropts -m0750
- else
- diropts -m0750 -o redis -g redis
- fi
- keepdir /var/{log,lib}/redis
-}
diff --git a/dev-db/redis/redis-2.6.9.ebuild b/dev-db/redis/redis-2.6.9.ebuild
deleted file mode 100644
index d8c74160fe7a..000000000000
--- a/dev-db/redis/redis-2.6.9.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/redis-2.6.9.ebuild,v 1.3 2013/04/25 09:22:08 ago Exp $
-
-EAPI=4
-
-inherit autotools eutils flag-o-matic user
-
-DESCRIPTION="A persistent caching system, key-value and data structures database."
-HOMEPAGE="http://redis.io/"
-SRC_URI="http://redis.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-KEYWORDS="amd64 x86 ~x86-macos ~x86-solaris"
-IUSE="+jemalloc tcmalloc test"
-SLOT="0"
-
-RDEPEND="tcmalloc? ( dev-util/google-perftools )
- jemalloc? ( >=dev-libs/jemalloc-3.2 )"
-DEPEND=">=sys-devel/autoconf-2.63
- test? ( dev-lang/tcl )
- ${RDEPEND}"
-REQUIRED_USE="tcmalloc? ( !jemalloc )
- jemalloc? ( !tcmalloc )"
-
-S="${WORKDIR}/${PN}-${PV/_/-}"
-
-pkg_setup() {
- enewgroup redis 75
- enewuser redis 75 -1 /var/lib/redis redis
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-2.6.7"-{shared,config}.patch
- epatch "${FILESDIR}/${P}"-tclsh86.patch
- # now we will rewrite present Makefiles
- local makefiles=""
- for MKF in $(find -name 'Makefile' | cut -b 3-); do
- mv "${MKF}" "${MKF}.in"
- sed -i -e 's:$(CC):@CC@:g' \
- -e 's:$(CFLAGS):@AM_CFLAGS@:g' \
- -e 's: $(DEBUG)::g' \
- -e 's:$(OBJARCH)::g' \
- -e 's:ARCH:TARCH:g' \
- -e '/^CCOPT=/s:$: $(LDFLAGS):g' \
- "${MKF}.in" \
- || die "Sed failed for ${MKF}"
- makefiles+=" ${MKF}"
- done
- # autodetection of compiler and settings; generates the modified Makefiles
- cp "${FILESDIR}"/configure.ac-2.2 configure.ac
- sed -i -e "s:AC_CONFIG_FILES(\[Makefile\]):AC_CONFIG_FILES([${makefiles}]):g" \
- configure.ac || die "Sed failed for configure.ac"
- eautoconf
-}
-
-src_configure() {
- econf
-
- # Linenoise can't be built with -std=c99, see https://bugs.gentoo.org/451164
- # also, don't define ANSI/c99 for lua twice
- sed -i -e "s:-std=c99::g" deps/linenoise/Makefile deps/Makefile || die
-}
-
-src_compile() {
- local myconf=""
-
- if use tcmalloc ; then
- myconf="${myconf} USE_TCMALLOC=yes"
- elif use jemalloc ; then
- myconf="${myconf} JEMALLOC_SHARED=yes"
- else
- myconf="${myconf} MALLOC=yes"
- fi
-
- emake ${myconf}
-}
-
-src_install() {
- insinto /etc/
- doins redis.conf sentinel.conf
- use prefix || fowners redis:redis /etc/{redis,sentinel}.conf
- fperms 0644 /etc/{redis,sentinel}.conf
-
- newconfd "${FILESDIR}/redis.confd" redis
- newinitd "${FILESDIR}/redis.initd" redis
-
- nonfatal dodoc 00-RELEASENOTES BUGS CONTRIBUTING MANIFESTO README
-
- dobin src/redis-cli
- dosbin src/redis-benchmark src/redis-server src/redis-check-aof src/redis-check-dump
- fperms 0750 /usr/sbin/redis-benchmark
- dosym /usr/sbin/redis-server /usr/sbin/redis-sentinel
-
- if use prefix; then
- diropts -m0750
- else
- diropts -m0750 -o redis -g redis
- fi
- keepdir /var/{log,lib}/redis
-}
diff --git a/dev-db/redis/redis-2.8.7.ebuild b/dev-db/redis/redis-2.8.11.ebuild
index a742a20848b9..1d60cb8950d7 100644
--- a/dev-db/redis/redis-2.8.7.ebuild
+++ b/dev-db/redis/redis-2.8.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/redis-2.8.7.ebuild,v 1.1 2014/03/10 08:36:15 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/redis-2.8.11.ebuild,v 1.1 2014/06/16 11:05:15 ultrabug Exp $
EAPI=5
@@ -11,7 +11,7 @@ HOMEPAGE="http://redis.io/"
SRC_URI="http://download.redis.io/releases/${P}.tar.gz"
LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~x86-macos ~x86-solaris"
+KEYWORDS="~amd64 ~hppa ~x86 ~x86-macos ~x86-solaris"
IUSE="+jemalloc tcmalloc test"
SLOT="0"
diff --git a/dev-db/redis/redis-2.8.5.ebuild b/dev-db/redis/redis-2.8.5.ebuild
deleted file mode 100644
index 20c03e905d8d..000000000000
--- a/dev-db/redis/redis-2.8.5.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/redis-2.8.5.ebuild,v 1.1 2014/02/07 19:44:23 robbat2 Exp $
-
-EAPI=5
-
-inherit autotools eutils flag-o-matic systemd toolchain-funcs user
-
-DESCRIPTION="A persistent caching system, key-value and data structures database."
-HOMEPAGE="http://redis.io/"
-SRC_URI="http://download.redis.io/releases/${P}.tar.gz"
-
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~x86-macos ~x86-solaris"
-IUSE="+jemalloc tcmalloc test"
-SLOT="0"
-
-RDEPEND="tcmalloc? ( dev-util/google-perftools )
- jemalloc? ( >=dev-libs/jemalloc-3.2 )"
-DEPEND=">=sys-devel/autoconf-2.63
- test? ( dev-lang/tcl )
- ${RDEPEND}"
-REQUIRED_USE="tcmalloc? ( !jemalloc )
- jemalloc? ( !tcmalloc )"
-
-S="${WORKDIR}/${PN}-${PV/_/-}"
-
-pkg_setup() {
- enewgroup redis 75
- enewuser redis 75 -1 /var/lib/redis redis
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.8.3-{shared,config}.patch
-
- # bug 467172, 467174
- sed -i -e 's:AR=:AR?=:g' -e 's:RANLIB=:RANLIB?=:g' "${S}/deps/lua/src/Makefile" || die
-
- # now we will rewrite present Makefiles
- local makefiles=""
- for MKF in $(find -name 'Makefile' | cut -b 3-); do
- mv "${MKF}" "${MKF}.in"
- sed -i -e 's:$(CC):@CC@:g' \
- -e 's:$(CFLAGS):@AM_CFLAGS@:g' \
- -e 's: $(DEBUG)::g' \
- -e 's:$(OBJARCH)::g' \
- -e 's:ARCH:TARCH:g' \
- -e '/^CCOPT=/s:$: $(LDFLAGS):g' \
- "${MKF}.in" \
- || die "Sed failed for ${MKF}"
- makefiles+=" ${MKF}"
- done
- # autodetection of compiler and settings; generates the modified Makefiles
- cp "${FILESDIR}"/configure.ac-2.2 configure.ac
- sed -i -e "s:AC_CONFIG_FILES(\[Makefile\]):AC_CONFIG_FILES([${makefiles}]):g" \
- configure.ac || die "Sed failed for configure.ac"
- eautoconf
-}
-
-src_configure() {
- econf
-
- # Linenoise can't be built with -std=c99, see https://bugs.gentoo.org/451164
- # also, don't define ANSI/c99 for lua twice
- sed -i -e "s:-std=c99::g" deps/linenoise/Makefile deps/Makefile || die
-}
-
-src_compile() {
- tc-export CC AR RANLIB
-
- local myconf=""
-
- if use tcmalloc ; then
- myconf="${myconf} USE_TCMALLOC=yes"
- elif use jemalloc ; then
- myconf="${myconf} JEMALLOC_SHARED=yes"
- else
- myconf="${myconf} MALLOC=yes"
- fi
-
- emake ${myconf} V=1 CC="${CC}" AR="${AR} rcu" RANLIB="${RANLIB}"
-}
-
-src_install() {
- insinto /etc/
- doins redis.conf sentinel.conf
- use prefix || fowners redis:redis /etc/{redis,sentinel}.conf
- fperms 0644 /etc/{redis,sentinel}.conf
-
- newconfd "${FILESDIR}/redis.confd" redis
- newinitd "${FILESDIR}/redis.initd-3" redis
-
- systemd_dounit "${FILESDIR}/redis.service"
- systemd_newtmpfilesd "${FILESDIR}/redis.tmpfiles" redis.conf
-
- nonfatal dodoc 00-RELEASENOTES BUGS CONTRIBUTING MANIFESTO README
-
- dobin src/redis-cli
- dosbin src/redis-benchmark src/redis-server src/redis-check-aof src/redis-check-dump
- fperms 0750 /usr/sbin/redis-benchmark
- dosym /usr/sbin/redis-server /usr/sbin/redis-sentinel
-
- if use prefix; then
- diropts -m0750
- else
- diropts -m0750 -o redis -g redis
- fi
- keepdir /var/{log,lib}/redis
-}
diff --git a/dev-db/redis/redis-2.8.6.ebuild b/dev-db/redis/redis-2.8.6.ebuild
deleted file mode 100644
index afe138c8b1c3..000000000000
--- a/dev-db/redis/redis-2.8.6.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/redis-2.8.6.ebuild,v 1.1 2014/02/26 11:07:13 ultrabug Exp $
-
-EAPI=5
-
-inherit autotools eutils flag-o-matic systemd toolchain-funcs user
-
-DESCRIPTION="A persistent caching system, key-value and data structures database."
-HOMEPAGE="http://redis.io/"
-SRC_URI="http://download.redis.io/releases/${P}.tar.gz"
-
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~x86-macos ~x86-solaris"
-IUSE="+jemalloc tcmalloc test"
-SLOT="0"
-
-RDEPEND="tcmalloc? ( dev-util/google-perftools )
- jemalloc? ( >=dev-libs/jemalloc-3.2 )"
-DEPEND=">=sys-devel/autoconf-2.63
- test? ( dev-lang/tcl )
- ${RDEPEND}"
-REQUIRED_USE="tcmalloc? ( !jemalloc )
- jemalloc? ( !tcmalloc )"
-
-S="${WORKDIR}/${PN}-${PV/_/-}"
-
-pkg_setup() {
- enewgroup redis 75
- enewuser redis 75 -1 /var/lib/redis redis
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.8.3-{shared,config}.patch
-
- # bug 467172, 467174
- sed -i -e 's:AR=:AR?=:g' -e 's:RANLIB=:RANLIB?=:g' "${S}/deps/lua/src/Makefile" || die
-
- # now we will rewrite present Makefiles
- local makefiles=""
- for MKF in $(find -name 'Makefile' | cut -b 3-); do
- mv "${MKF}" "${MKF}.in"
- sed -i -e 's:$(CC):@CC@:g' \
- -e 's:$(CFLAGS):@AM_CFLAGS@:g' \
- -e 's: $(DEBUG)::g' \
- -e 's:$(OBJARCH)::g' \
- -e 's:ARCH:TARCH:g' \
- -e '/^CCOPT=/s:$: $(LDFLAGS):g' \
- "${MKF}.in" \
- || die "Sed failed for ${MKF}"
- makefiles+=" ${MKF}"
- done
- # autodetection of compiler and settings; generates the modified Makefiles
- cp "${FILESDIR}"/configure.ac-2.2 configure.ac
- sed -i -e "s:AC_CONFIG_FILES(\[Makefile\]):AC_CONFIG_FILES([${makefiles}]):g" \
- configure.ac || die "Sed failed for configure.ac"
- eautoconf
-}
-
-src_configure() {
- econf
-
- # Linenoise can't be built with -std=c99, see https://bugs.gentoo.org/451164
- # also, don't define ANSI/c99 for lua twice
- sed -i -e "s:-std=c99::g" deps/linenoise/Makefile deps/Makefile || die
-}
-
-src_compile() {
- tc-export CC AR RANLIB
-
- local myconf=""
-
- if use tcmalloc ; then
- myconf="${myconf} USE_TCMALLOC=yes"
- elif use jemalloc ; then
- myconf="${myconf} JEMALLOC_SHARED=yes"
- else
- myconf="${myconf} MALLOC=yes"
- fi
-
- emake ${myconf} V=1 CC="${CC}" AR="${AR} rcu" RANLIB="${RANLIB}"
-}
-
-src_install() {
- insinto /etc/
- doins redis.conf sentinel.conf
- use prefix || fowners redis:redis /etc/{redis,sentinel}.conf
- fperms 0644 /etc/{redis,sentinel}.conf
-
- newconfd "${FILESDIR}/redis.confd" redis
- newinitd "${FILESDIR}/redis.initd-3" redis
-
- systemd_dounit "${FILESDIR}/redis.service"
- systemd_newtmpfilesd "${FILESDIR}/redis.tmpfiles" redis.conf
-
- nonfatal dodoc 00-RELEASENOTES BUGS CONTRIBUTING MANIFESTO README
-
- dobin src/redis-cli
- dosbin src/redis-benchmark src/redis-server src/redis-check-aof src/redis-check-dump
- fperms 0750 /usr/sbin/redis-benchmark
- dosym /usr/sbin/redis-server /usr/sbin/redis-sentinel
-
- if use prefix; then
- diropts -m0750
- else
- diropts -m0750 -o redis -g redis
- fi
- keepdir /var/{log,lib}/redis
-}