summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Groesslinger <scandium@gentoo.org>2005-02-06 16:08:27 +0000
committerRainer Groesslinger <scandium@gentoo.org>2005-02-06 16:08:27 +0000
commitacc7eb5edee5e05f39003183f3bb818332bb5774 (patch)
treeb49dd655546fcf4a793ac6b09177d203a40931e5 /dev-dotnet/ml-pnet/ml-pnet-0.6.12.ebuild
parentfix use of DESTDIR (bug #80941) (diff)
downloadgentoo-2-acc7eb5edee5e05f39003183f3bb818332bb5774.tar.gz
gentoo-2-acc7eb5edee5e05f39003183f3bb818332bb5774.tar.bz2
gentoo-2-acc7eb5edee5e05f39003183f3bb818332bb5774.zip
fix use of DESTDIR (bug #80941) and a patch to fix compilation of System.ServiceProcess
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-dotnet/ml-pnet/ml-pnet-0.6.12.ebuild')
-rw-r--r--dev-dotnet/ml-pnet/ml-pnet-0.6.12.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/dev-dotnet/ml-pnet/ml-pnet-0.6.12.ebuild b/dev-dotnet/ml-pnet/ml-pnet-0.6.12.ebuild
index f7ece7d79b9d..5ed33e7ade20 100644
--- a/dev-dotnet/ml-pnet/ml-pnet-0.6.12.ebuild
+++ b/dev-dotnet/ml-pnet/ml-pnet-0.6.12.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ml-pnet/ml-pnet-0.6.12.ebuild,v 1.2 2005/01/29 21:41:15 scandium Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ml-pnet/ml-pnet-0.6.12.ebuild,v 1.3 2005/02/06 16:08:27 scandium Exp $
+
+inherit eutils
DESCRIPTION="Mono C# libraries for Portable.NET"
HOMEPAGE="http://www.dotgnu.org/"
@@ -13,6 +15,13 @@ IUSE=""
DEPEND="=dev-dotnet/pnetlib-${PV}*"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Fix compilation of ServiceProcess, already fixed upstream
+ epatch ${FILESDIR}/System.ServiceProcess.build.patch
+}
+
src_compile() {
local lib_profile="framework1.1"
einfo "Using profile: ${lib_profile}"
@@ -22,6 +31,6 @@ src_compile() {
}
src_install() {
- einstall || die
+ make DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog INSTALL NEWS README
}