summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2008-05-30 22:38:46 +0000
committerJurek Bartuszek <jurek@gentoo.org>2008-05-30 22:38:46 +0000
commit87037c70f78f8ccdd96a87b9d1ad589c698e9dff (patch)
tree20b423319d62500e5bd3f658560ccd63fbb77288 /dev-dotnet/mono-fuse
parentAdd unzip to DEPEND. Fixes bug #224151. (diff)
downloadgentoo-2-87037c70f78f8ccdd96a87b9d1ad589c698e9dff.tar.gz
gentoo-2-87037c70f78f8ccdd96a87b9d1ad589c698e9dff.tar.bz2
gentoo-2-87037c70f78f8ccdd96a87b9d1ad589c698e9dff.zip
dev-dotnet/mono-fuse-0.4.2: Version bump (bug #213672)
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-dotnet/mono-fuse')
-rw-r--r--dev-dotnet/mono-fuse/ChangeLog9
-rw-r--r--dev-dotnet/mono-fuse/mono-fuse-0.4.2.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/dev-dotnet/mono-fuse/ChangeLog b/dev-dotnet/mono-fuse/ChangeLog
index 5944939c86ee..8ab074bb4d2a 100644
--- a/dev-dotnet/mono-fuse/ChangeLog
+++ b/dev-dotnet/mono-fuse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/mono-fuse
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-fuse/ChangeLog,v 1.9 2007/08/01 03:09:54 metalgod Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-fuse/ChangeLog,v 1.10 2008/05/30 22:38:46 jurek Exp $
+
+*mono-fuse-0.4.2 (30 May 2008)
+
+ 30 May 2008; Jurek Bartuszek <jurek@gentoo.org> +mono-fuse-0.4.2.ebuild:
+ Version bump (bug #213672)
01 Aug 2007; <metalgod@gentoo.org> mono-fuse-0.4.1.ebuild:
Added ~amd64 keyword. Closes bug #186135
diff --git a/dev-dotnet/mono-fuse/mono-fuse-0.4.2.ebuild b/dev-dotnet/mono-fuse/mono-fuse-0.4.2.ebuild
new file mode 100644
index 000000000000..da72a9ee9fda
--- /dev/null
+++ b/dev-dotnet/mono-fuse/mono-fuse-0.4.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-fuse/mono-fuse-0.4.2.ebuild,v 1.1 2008/05/30 22:38:46 jurek Exp $
+
+inherit autotools mono
+
+DESCRIPTION="C# binding for the FUSE library"
+HOMEPAGE="http://www.jprl.com/Projects/mono-fuse/"
+SRC_URI="http://www.jprl.com/Projects/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=">=dev-lang/mono-1.1.13
+ >=dev-util/monodoc-1.1.13
+ >=sys-fs/fuse-2.5.2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e 's#^AC_CHECK_LIB(MonoPosixHelper.*$##' \
+ configure.in || die "sed failed"
+
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_compile()
+{
+ econf || die "configure failed"
+ emake -j1 || die "make failed"
+}
+
+src_install()
+{
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc ChangeLog README
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r example
+ fi
+}
+
+pkg_postinst()
+{
+ elog "Ensure that you have the fuse module loaded"
+ elog "before you start using mono-fuse"
+}