summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-01-30 23:59:38 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-01-30 23:59:38 +0000
commitc81473319f20c9782c5c06f6257a9b6b3ae8d981 (patch)
treec3748cdc99dd489e91a102ed9125a095e98aaeb9 /dev-dotnet/smartirc4net/smartirc4net-0.4.5.1.ebuild
parentAdd kdebase-desktoptheme as dep. Per bug #256942. (diff)
downloadgentoo-2-c81473319f20c9782c5c06f6257a9b6b3ae8d981.tar.gz
gentoo-2-c81473319f20c9782c5c06f6257a9b6b3ae8d981.tar.bz2
gentoo-2-c81473319f20c9782c5c06f6257a9b6b3ae8d981.zip
Add smartirc4net, ebuild by me.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet/smartirc4net/smartirc4net-0.4.5.1.ebuild')
-rw-r--r--dev-dotnet/smartirc4net/smartirc4net-0.4.5.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-dotnet/smartirc4net/smartirc4net-0.4.5.1.ebuild b/dev-dotnet/smartirc4net/smartirc4net-0.4.5.1.ebuild
new file mode 100644
index 000000000000..622862decd49
--- /dev/null
+++ b/dev-dotnet/smartirc4net/smartirc4net-0.4.5.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/smartirc4net/smartirc4net-0.4.5.1.ebuild,v 1.1 2009/01/30 23:59:38 loki_val Exp $
+
+EAPI="2"
+
+inherit mono
+
+HOMEPAGE="http://www.smuxi.org/page/Download"
+SRC_URI="http://smuxi.meebey.net/jaws/data/files/${P}.tar.gz"
+DESCRIPTION="SmartIrc4net is a multi-threaded and thread-safe IRC library written in C#"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+LICENSE="|| ( LGPL-2.1 LGPL-3 )"
+
+
+RDEPEND=">=dev-lang/mono-2.0"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.23"
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc FEATURES TODO API_CHANGE CHANGELOG README || die "dodoc failed"
+}