summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-11-23 20:12:16 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-11-23 20:12:16 +0000
commit111d93c0b08597f571cae94602239da89d7e51d5 (patch)
treeaff1cefb91fe2ba5d457dfddc7b0c1db88d4f719 /dev-dotnet/xsp
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-111d93c0b08597f571cae94602239da89d7e51d5.tar.gz
gentoo-2-111d93c0b08597f571cae94602239da89d7e51d5.tar.bz2
gentoo-2-111d93c0b08597f571cae94602239da89d7e51d5.zip
Add necessary files, tidy up.
(Portage version: 2.2_rc14/cvs/Linux 2.6.28-rc4 x86_64)
Diffstat (limited to 'dev-dotnet/xsp')
-rw-r--r--dev-dotnet/xsp/ChangeLog7
-rw-r--r--dev-dotnet/xsp/files/2.0/mod-mono-server.confd34
-rw-r--r--dev-dotnet/xsp/files/2.0/mod-mono-server.initd81
-rw-r--r--dev-dotnet/xsp/files/2.0/xsp.confd12
-rw-r--r--dev-dotnet/xsp/files/2.0/xsp.initd38
-rw-r--r--dev-dotnet/xsp/xsp-2.0.ebuild27
6 files changed, 176 insertions, 23 deletions
diff --git a/dev-dotnet/xsp/ChangeLog b/dev-dotnet/xsp/ChangeLog
index 7cbca2fd6647..83d5cf9f4b1c 100644
--- a/dev-dotnet/xsp/ChangeLog
+++ b/dev-dotnet/xsp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/xsp
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/ChangeLog,v 1.57 2008/11/19 22:57:41 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/ChangeLog,v 1.58 2008/11/23 20:12:15 loki_val Exp $
+
+ 23 Nov 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/2.0/mod-mono-server.confd, +files/2.0/mod-mono-server.initd,
+ +files/2.0/xsp.confd, +files/2.0/xsp.initd, xsp-2.0.ebuild:
+ Add necessary files, tidy up.
*xsp-2.0 (19 Nov 2008)
diff --git a/dev-dotnet/xsp/files/2.0/mod-mono-server.confd b/dev-dotnet/xsp/files/2.0/mod-mono-server.confd
new file mode 100644
index 000000000000..8b6972a87ff7
--- /dev/null
+++ b/dev-dotnet/xsp/files/2.0/mod-mono-server.confd
@@ -0,0 +1,34 @@
+# Config file for /etc/init.d/mod-mono-server
+# $Id: mod-mono-server.confd,v 1.1 2008/11/23 20:12:16 loki_val Exp $
+
+# Configuration directives for mod-mono-server.exe. For more information on
+# these variables, see the man page for xsp(1).
+
+# This is the document root; trailing slash is not necessary
+#MonoServerRootDir="/usr/lib/xsp/test"
+
+# Directory to search for files with an `.webapp' extension.
+#MonoApplicationsConfigDir="/usr/lib/xsp/test"
+
+# Comma separated list of directories (in the form virtual:real) for all
+# applications managed by the server. For example:
+# /app1:/var/www/localhost/htdocs/app1,/app2:/var/www/localhost/htdocs/app2
+MonoApplications="/mono:/usr/lib/xsp/test"
+
+# The communication channel used between mod-mono-server and mod_mono.
+# unix - A unix socket
+# tcp - A TCP connection
+MonoServerChannel="unix"
+
+# When the comm. channel is "unix", the local filename used by the socket.
+UnixSocketFileName="/tmp/mod_mono_server"
+
+# When the comm. channel is "tcp", IP address for the server to listen on.
+#MonoServerAddress=127.0.0.1
+
+# When the comm. channel is "tcp", port for the server to listen on.
+#MonoServerPort=8080
+
+# If you want to host .NET 2.0 applications you have to set this to 2.
+# Otherwise, leave it unchaged
+MonoServerVersion=1
diff --git a/dev-dotnet/xsp/files/2.0/mod-mono-server.initd b/dev-dotnet/xsp/files/2.0/mod-mono-server.initd
new file mode 100644
index 000000000000..25948c0ca17d
--- /dev/null
+++ b/dev-dotnet/xsp/files/2.0/mod-mono-server.initd
@@ -0,0 +1,81 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: mod-mono-server.initd,v 1.1 2008/11/23 20:12:16 loki_val Exp $
+
+depend() {
+ use net
+ after dotnet
+}
+
+start() {
+ [ -z "$MonoServerRootDir" ] && \
+ MonoServerRootDir="/usr/lib/xsp/test"
+ [ -z "$MonoApplications" ] && \
+ MonoApplications="/mono:/usr/lib/xsp/test,/:."
+ [ -z "$UnixSocketFileName" ] && \
+ UnixSocketFileName="/tmp/mod_mono_server"
+ [ -z "$MonoServerAddress" ] && \
+ MonoServerAddress=127.0.0.1
+ [ -z "$MonoServerPort" ] && \
+ MonoServerPort=8080
+ [ -z "$MonoServerVersion" ] && \
+ MonoServerVersion=1
+
+ MONO_SERVER_OPTS="--root ${MonoServerRootDir} \
+--applications ${MonoApplications} --nonstop"
+
+ [ -n "$MonoApplicationsConfigDir" ] && \
+ MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
+--appconfigdir ${MonoApplicationsConfigDir}"
+
+ case "$MonoServerChannel" in
+ "tcp" )
+ MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
+--address ${MonoServerAddress} --port ${MonoServerPort}"
+ ;;
+
+ "unix" )
+ [ -f "$UnixSocketFileName" ] && rm -f $UnixSocketFileName
+ MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
+--filename ${UnixSocketFileName}"
+ ;;
+
+ * )
+ eerror "Please set a valid value for MonoServerChannel"
+ return 1
+ ;;
+ esac
+
+ if [ ${MonoServerVersion} -eq 1 ]; then
+ modmonoserverpath=1.0/mod-mono-server.exe
+ elif [ ${MonoServerVersion} -eq 2 ]; then
+ modmonoserverpath=2.0/mod-mono-server2.exe
+ else
+ eerror "MonoServerVersion was not properly set. Check your /etc/conf.d/xsp"
+ return 1
+ fi
+
+ export MONO_SHARED_DIR=/tmp
+
+ ebegin "Starting mod-mono-server"
+
+ start-stop-daemon --quiet --start \
+ --background \
+ --make-pidfile \
+ --pidfile /var/run/aspnet/mod-mono-server.pid \
+ --chuid aspnet \
+ --exec /usr/bin/mono /usr/lib/mono/${modmonoserverpath} \
+ -- $MONO_SERVER_OPTS
+
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping mod-mono-server"
+
+ start-stop-daemon -o --quiet --stop \
+ --pidfile /var/run/aspnet/mod-mono-server.pid
+
+ eend $?
+}
diff --git a/dev-dotnet/xsp/files/2.0/xsp.confd b/dev-dotnet/xsp/files/2.0/xsp.confd
new file mode 100644
index 000000000000..3385ec395099
--- /dev/null
+++ b/dev-dotnet/xsp/files/2.0/xsp.confd
@@ -0,0 +1,12 @@
+# Config file for /etc/init.d/xsp
+# $Id: xsp.confd,v 1.1 2008/11/23 20:12:16 loki_val Exp $
+
+# This is the document root; trailing slash is not necessary
+MonoServerRoot=/usr/lib/xsp/test
+
+# Port for the server to run on
+MonoServerPort=8000
+
+# If you want to host .NET 2.0 applications you have to set this to 2.
+# Otherwise, leave it unchanged
+MonoServerVersion=1
diff --git a/dev-dotnet/xsp/files/2.0/xsp.initd b/dev-dotnet/xsp/files/2.0/xsp.initd
new file mode 100644
index 000000000000..06b8db7eaf8d
--- /dev/null
+++ b/dev-dotnet/xsp/files/2.0/xsp.initd
@@ -0,0 +1,38 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: xsp.initd,v 1.1 2008/11/23 20:12:16 loki_val Exp $
+
+depend() {
+ need net
+ after dotnet
+}
+
+start() {
+ ebegin "Starting xsp"
+
+ if [ ${MonoServerVersion} -eq 1 ]; then
+ xsppath=1.0/xsp.exe
+ elif [ ${MonoServerVersion} -eq 2 ]; then
+ xsppath=2.0/xsp2.exe
+ else
+ eerror "MonoServerVersion was not properly set. Check your config file"
+ return 1
+ fi
+
+ start-stop-daemon --quiet --start \
+ --background \
+ --make-pidfile \
+ --pidfile /var/run/aspnet/xsp.pid \
+ --chuid aspnet \
+ --exec /usr/bin/mono /usr/lib/mono/${xsppath} -- --root ${MonoServerRoot} --port ${MonoServerPort} --nonstop
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping xsp"
+ start-stop-daemon -o --quiet --stop \
+ --pidfile /var/run/aspnet/xsp.pid
+ eend $?
+}
+
diff --git a/dev-dotnet/xsp/xsp-2.0.ebuild b/dev-dotnet/xsp/xsp-2.0.ebuild
index b7df8c87b774..7b1b4905f6a0 100644
--- a/dev-dotnet/xsp/xsp-2.0.ebuild
+++ b/dev-dotnet/xsp/xsp-2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/xsp-2.0.ebuild,v 1.1 2008/11/19 22:57:41 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/xsp-2.0.ebuild,v 1.2 2008/11/23 20:12:15 loki_val Exp $
inherit mono multilib autotools eutils
@@ -26,16 +26,6 @@ pkg_preinst() {
enewuser aspnet -1 -1 /tmp aspnet
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- sed -i -e "s:mkinstalldirs) \$(data:mkinstalldirs) \$(DESTDIR)\$(data:" \
- -e "s:gif \$(data:gif \$(DESTDIR)\$(data:" \
- "${S}"/test/2.0/treeview/Makefile.am
- eautoreconf
-}
-
src_compile() {
econf || die "./configure failed!"
emake -j1 || {
@@ -48,17 +38,10 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die
- sed -i -e "s#/usr/lib/#/usr/$(get_libdir)/#" \
- "${D}"/usr/bin/xsp{,2} \
- "${D}"/usr/bin/mod-mono-server{,2} \
- "${D}"/usr/bin/asp-state{,2} \
- "${D}"/usr/bin/dbsessmgr{,2} \
- || die
-
- newinitd "${FILESDIR}"/${PV}/xsp.initd xsp
- newinitd "${FILESDIR}"/${PV}/mod-mono-server.initd mod-mono-server
- newconfd "${FILESDIR}"/${PV}/xsp.confd xsp
- newconfd "${FILESDIR}"/${PV}/mod-mono-server.confd mod-mono-server
+ newinitd "${FILESDIR}"/${PV}/xsp.initd xsp || die
+ newinitd "${FILESDIR}"/${PV}/mod-mono-server.initd mod-mono-server || die
+ newconfd "${FILESDIR}"/${PV}/xsp.confd xsp || die
+ newconfd "${FILESDIR}"/${PV}/mod-mono-server.confd mod-mono-server || die
keepdir /var/run/aspnet