summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-07-28 10:43:54 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-07-28 10:43:54 +0000
commit0561bd11c90a7fdbda61f2fadf2d499a72dd9293 (patch)
tree71a99e4587711a6ec195369e13af77a4086bda90 /dev-dotnet
parentRdepend on krosspython. Per bug #244649. Force due to notfully updated cvs (diff)
downloadgentoo-2-0561bd11c90a7fdbda61f2fadf2d499a72dd9293.tar.gz
gentoo-2-0561bd11c90a7fdbda61f2fadf2d499a72dd9293.tar.bz2
gentoo-2-0561bd11c90a7fdbda61f2fadf2d499a72dd9293.zip
Add new version that properly executes after procfs have been mounted.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/pe-format/ChangeLog8
-rw-r--r--dev-dotnet/pe-format/files/pe-format.init-153
-rw-r--r--dev-dotnet/pe-format/pe-format-1.ebuild35
3 files changed, 95 insertions, 1 deletions
diff --git a/dev-dotnet/pe-format/ChangeLog b/dev-dotnet/pe-format/ChangeLog
index 212807c76ed8..c6f2f14e6ab9 100644
--- a/dev-dotnet/pe-format/ChangeLog
+++ b/dev-dotnet/pe-format/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-dotnet/pe-format
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/ChangeLog,v 1.11 2009/03/20 23:14:50 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/ChangeLog,v 1.12 2009/07/28 10:43:54 flameeyes Exp $
+
+*pe-format-1 (28 Jul 2009)
+
+ 28 Jul 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/pe-format.init-1, +pe-format-1.ebuild:
+ Add new version that properly executes after procfs have been mounted.
20 Mar 2009; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
pe-format-0.ebuild:
diff --git a/dev-dotnet/pe-format/files/pe-format.init-1 b/dev-dotnet/pe-format/files/pe-format.init-1
new file mode 100644
index 000000000000..0816edacde52
--- /dev/null
+++ b/dev-dotnet/pe-format/files/pe-format.init-1
@@ -0,0 +1,53 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/files/pe-format.init-1,v 1.1 2009/07/28 10:43:54 flameeyes Exp $
+
+depend() {
+ after procfs
+}
+
+start() {
+ ebegin "Registering PE binaries with ${CLR}"
+
+ if [[ ! -d /proc/sys/fs/binfmt_misc ]] ; then
+ eerror "You need support for \"misc binaries\" in your kernel!"
+ eend 1
+ fi
+
+ if [[ $(mount | grep -c binfmt_misc) -eq 0 ]] ; then
+ mount -t binfmt_misc binfmt_misc /proc/sys/fs/binfmt_misc &> /dev/null
+ local result=$?
+
+ if [[ $result -ne 0 ]] ; then
+ eend $result
+ fi
+ fi
+
+ case "${CLR}" in
+ mono)
+ echo ':PE:M::MZ::/usr/bin/mono:' > /proc/sys/fs/binfmt_misc/register
+ eend 0
+ ;;
+ ilrun)
+ echo ':PE:M::MZ::/usr/bin/ilrun:' > /proc/sys/fs/binfmt_misc/register
+ eend 0
+ ;;
+ *)
+ eerror 'Please enter a valid option in /etc/conf.d/pe-format'
+ eend 1
+ ;;
+ esac
+}
+
+stop() {
+ ebegin "Unregistering PE binaries"
+
+ if [[ -f /proc/sys/fs/binfmt_misc/PE ]] ; then
+ echo '-1' > /proc/sys/fs/binfmt_misc/PE
+ fi
+
+ eend $?
+}
+
+# vim: ts=4 :
diff --git a/dev-dotnet/pe-format/pe-format-1.ebuild b/dev-dotnet/pe-format/pe-format-1.ebuild
new file mode 100644
index 000000000000..eff5c596a492
--- /dev/null
+++ b/dev-dotnet/pe-format/pe-format-1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/pe-format-1.ebuild,v 1.1 2009/07/28 10:43:54 flameeyes Exp $
+
+inherit eutils
+
+DESCRIPTION="PE Format binfmt_misc entry"
+HOMEPAGE="http://www.kernel.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="|| ( dev-lang/mono dev-dotnet/pnet )"
+
+src_compile() {
+ true;
+}
+
+src_install() {
+ newinitd "${FILESDIR}/pe-format.init-1" pe-format || die "failed to install init script"
+ newconfd "${FILESDIR}/pe-format.conf" pe-format || die "failed to install config"
+}
+
+pkg_postinst() {
+ ebeep 5
+
+ einfo
+ ewarn "Using this script will confuse applications which are designed to use PE"
+ ewarn "applications such as Wine and Cedega."
+ einfo
+
+ epause 5
+}