summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-11-23 12:35:44 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-11-23 12:35:44 +0000
commitd758a3823ad5bbc08630a0d9e80c962affcec77d (patch)
treed34234ccc3cf7586de90dbb4dc3adcbb9855a8ce /dev-dotnet
parentWebkit not keyworded, thus masking webkit keyword of PyQt. (diff)
downloadgentoo-2-d758a3823ad5bbc08630a0d9e80c962affcec77d.tar.gz
gentoo-2-d758a3823ad5bbc08630a0d9e80c962affcec77d.tar.bz2
gentoo-2-d758a3823ad5bbc08630a0d9e80c962affcec77d.zip
Remove libdir fixups, since mono-addins installs no 64-bit code and libdir fixups were causin maintainer mode to be run. Punt 0.2
(Portage version: 2.2_rc14/cvs/Linux 2.6.28-rc4 x86_64)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/mono-addins/ChangeLog7
-rw-r--r--dev-dotnet/mono-addins/mono-addins-0.2.ebuild40
-rw-r--r--dev-dotnet/mono-addins/mono-addins-0.3.1.ebuild17
3 files changed, 7 insertions, 57 deletions
diff --git a/dev-dotnet/mono-addins/ChangeLog b/dev-dotnet/mono-addins/ChangeLog
index 3b53998c7914..708ebe41f274 100644
--- a/dev-dotnet/mono-addins/ChangeLog
+++ b/dev-dotnet/mono-addins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/mono-addins
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-addins/ChangeLog,v 1.11 2008/08/10 19:10:23 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-addins/ChangeLog,v 1.12 2008/11/23 12:35:44 loki_val Exp $
+
+ 23 Nov 2008; Peter Alfredsen <loki_val@gentoo.org>
+ -mono-addins-0.2.ebuild, mono-addins-0.3.1.ebuild:
+ Remove libdir fixups, since mono-addins installs no 64-bit code and libdir
+ fixups were causin maintainer mode to be run. Punt 0.2
10 Aug 2008; Markus Meier <maekke@gentoo.org> mono-addins-0.3.ebuild:
x86 stable, bug #229709
diff --git a/dev-dotnet/mono-addins/mono-addins-0.2.ebuild b/dev-dotnet/mono-addins/mono-addins-0.2.ebuild
deleted file mode 100644
index baa4b2a3402b..000000000000
--- a/dev-dotnet/mono-addins/mono-addins-0.2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-addins/mono-addins-0.2.ebuild,v 1.4 2008/05/31 12:36:07 jurek Exp $
-
-inherit eutils mono
-
-DESCRIPTION="A generic framework for creating extensible applications"
-HOMEPAGE="http://www.mono-project.com/Mono.Addins"
-SRC_URI="http://www.go-mono.com/sources/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-
-IUSE="X"
-
-DEPEND=">=dev-lang/mono-1.2
- X? ( >=dev-dotnet/gtk-sharp-2.0
- >=dev-dotnet/gnome-sharp-2.0
- >=dev-dotnet/glade-sharp-2.0 )"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}-disable-gui.patch"
-}
-
-src_compile() {
- econf \
- --disable-tests \
- $(use_enable X gui) \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-}
diff --git a/dev-dotnet/mono-addins/mono-addins-0.3.1.ebuild b/dev-dotnet/mono-addins/mono-addins-0.3.1.ebuild
index a0670f470901..f096f2d836c5 100644
--- a/dev-dotnet/mono-addins/mono-addins-0.3.1.ebuild
+++ b/dev-dotnet/mono-addins/mono-addins-0.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-addins/mono-addins-0.3.1.ebuild,v 1.3 2008/07/30 23:21:56 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-addins/mono-addins-0.3.1.ebuild,v 1.4 2008/11/23 12:35:44 loki_val Exp $
inherit mono multilib
@@ -18,21 +18,6 @@ RDEPEND=">=dev-lang/mono-1.9
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.19"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- sed -i -e "s:\$(prefix)/lib:\$(prefix)/$(get_libdir):g" \
- -e "s:\${prefix}/lib:\${prefix}/$(get_libdir):g" \
- configure{,.ac} || die "libdir fixup failed"
-
- find "${S}" -name 'Makefile*' -exec \
- sed -i -e "s:\$(prefix)/lib:\$(prefix)/$(get_libdir):g" \
- -e "s:\${prefix}/lib:\${prefix}/$(get_libdir):g" \
- {} \; \
- || die "libdir fixup failed"
-}
-
src_install() {
emake DESTDIR="${D}" install || die "install failed"
}