summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-05-24 18:54:39 +0000
committerPacho Ramos <pacho@gentoo.org>2013-05-24 18:54:39 +0000
commite7163b39c101dcffe04294e27c396ede21da188f (patch)
tree31f46232aea64c554d0e2fa4130a86902d01873c /dev-dotnet
parentFix build with netware or bluetooth enabled, bug #448506. Fix glob(3) relate... (diff)
downloadgentoo-2-e7163b39c101dcffe04294e27c396ede21da188f.tar.gz
gentoo-2-e7163b39c101dcffe04294e27c396ede21da188f.tar.bz2
gentoo-2-e7163b39c101dcffe04294e27c396ede21da188f.zip
Apply fedora patch fixing monodoc location, drop unneeded doc USE flag, stop using deprecated mono.eclass
(Portage version: 2.1.12.1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/gnome-keyring-sharp/ChangeLog13
-rw-r--r--dev-dotnet/gnome-keyring-sharp/files/gnome-keyring-sharp-1.0.2-monodoc-dir.patch10
-rw-r--r--dev-dotnet/gnome-keyring-sharp/gnome-keyring-sharp-1.0.2-r1.ebuild44
3 files changed, 64 insertions, 3 deletions
diff --git a/dev-dotnet/gnome-keyring-sharp/ChangeLog b/dev-dotnet/gnome-keyring-sharp/ChangeLog
index 4ffd89e3148d..497a5de0451a 100644
--- a/dev-dotnet/gnome-keyring-sharp/ChangeLog
+++ b/dev-dotnet/gnome-keyring-sharp/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-dotnet/gnome-keyring-sharp
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gnome-keyring-sharp/ChangeLog,v 1.12 2012/05/04 03:56:55 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gnome-keyring-sharp/ChangeLog,v 1.13 2013/05/24 18:54:39 pacho Exp $
+
+*gnome-keyring-sharp-1.0.2-r1 (24 May 2013)
+
+ 24 May 2013; Pacho Ramos <pacho@gentoo.org>
+ +files/gnome-keyring-sharp-1.0.2-monodoc-dir.patch,
+ +gnome-keyring-sharp-1.0.2-r1.ebuild:
+ Apply fedora patch fixing monodoc location, drop unneeded doc USE flag, stop
+ using deprecated mono.eclass
04 May 2012; Jeff Horelick <jdhore@gentoo.org>
gnome-keyring-sharp-1.0.2.ebuild:
@@ -67,4 +75,3 @@
25 Nov 2008; Peter Alfredsen <loki_val@gentoo.org> +metadata.xml,
+gnome-keyring-sharp-1.0.0.ebuild:
Initial import. Ebuild fetched from ikelos' overlay.
-
diff --git a/dev-dotnet/gnome-keyring-sharp/files/gnome-keyring-sharp-1.0.2-monodoc-dir.patch b/dev-dotnet/gnome-keyring-sharp/files/gnome-keyring-sharp-1.0.2-monodoc-dir.patch
new file mode 100644
index 000000000000..71945c236635
--- /dev/null
+++ b/dev-dotnet/gnome-keyring-sharp/files/gnome-keyring-sharp-1.0.2-monodoc-dir.patch
@@ -0,0 +1,10 @@
+diff -uNr gnome-keyring-sharp-1.0.1.old/docs/Makefile.am gnome-keyring-sharp-1.0.1/docs/Makefile.am
+--- gnome-keyring-sharp-1.0.1.old/docs/Makefile.am 2009-05-07 17:32:19.000000000 +0200
++++ gnome-keyring-sharp-1.0.1/docs/Makefile.am 2011-10-31 17:03:46.648191581 +0100
+@@ -1,5 +1,5 @@
+ if ENABLE_MONODOC
+-SOURCESDIR=$(libdir)/monodoc/sources
++SOURCESDIR=$(prefix)/lib/monodoc/sources
+ TARGETS=Gnome.Keyring.tree Gnome.Keyring.zip Gnome.Keyring.source
+ UPDATER = $(MONODOCER) -path:Gnome.Keyring $(UPDATE_ASSEMBLIES)
+ else
diff --git a/dev-dotnet/gnome-keyring-sharp/gnome-keyring-sharp-1.0.2-r1.ebuild b/dev-dotnet/gnome-keyring-sharp/gnome-keyring-sharp-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..bb2533f1574a
--- /dev/null
+++ b/dev-dotnet/gnome-keyring-sharp/gnome-keyring-sharp-1.0.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gnome-keyring-sharp/gnome-keyring-sharp-1.0.2-r1.ebuild,v 1.1 2013/05/24 18:54:39 pacho Exp $
+
+EAPI=5
+inherit autotools eutils mono-env
+
+DESCRIPTION="C# implementation of gnome-keyring"
+HOMEPAGE="http://www.mono-project.com/ https://github.com/mono/gnome-keyring-sharp"
+SRC_URI="http://www.go-mono.com/archive/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-lang/mono-2.0
+ >=gnome-base/libgnome-keyring-2.30.0
+ dev-dotnet/glib-sharp
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Disable building samples.
+ sed -i -e 's:sample::' "${S}"/Makefile.in || die "sed failed"
+
+ # Apply Fedora patches
+ epatch "${FILESDIR}/${PN}-1.0.2-monodoc-dir.patch"
+ eautoreconf
+}
+
+src_compile() {
+ # This dies without telling in docs with anything not -j1
+ # CSC=gmcs needed for http://bugs.gentoo.org/show_bug.cgi?id=250069
+ emake -j1 CSC=gmcs
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}