summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-01-15 16:44:01 +0000
committerMike Frysinger <vapier@gentoo.org>2009-01-15 16:44:01 +0000
commit88ea66a5f585c0197c52fef29fd11b5fc7fc4674 (patch)
tree1f8938cf2eb6bc75b4a2a6a724f788bc2ab49d56 /dev-embedded/libftdi
parentold (diff)
downloadgentoo-2-88ea66a5f585c0197c52fef29fd11b5fc7fc4674.tar.gz
gentoo-2-88ea66a5f585c0197c52fef29fd11b5fc7fc4674.tar.bz2
gentoo-2-88ea66a5f585c0197c52fef29fd11b5fc7fc4674.zip
Version bump.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'dev-embedded/libftdi')
-rw-r--r--dev-embedded/libftdi/ChangeLog9
-rw-r--r--dev-embedded/libftdi/libftdi-0.15.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-embedded/libftdi/ChangeLog b/dev-embedded/libftdi/ChangeLog
index f3e643bba716..52f72f2ab689 100644
--- a/dev-embedded/libftdi/ChangeLog
+++ b/dev-embedded/libftdi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-embedded/libftdi
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/ChangeLog,v 1.32 2008/10/13 10:34:00 vapier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/ChangeLog,v 1.33 2009/01/15 16:44:01 vapier Exp $
+
+*libftdi-0.15 (15 Jan 2009)
+
+ 15 Jan 2009; Mike Frysinger <vapier@gentoo.org> +libftdi-0.15.ebuild:
+ Version bump.
*libftdi-0.14 (13 Oct 2008)
diff --git a/dev-embedded/libftdi/libftdi-0.15.ebuild b/dev-embedded/libftdi/libftdi-0.15.ebuild
new file mode 100644
index 000000000000..d11b452ea8c1
--- /dev/null
+++ b/dev-embedded/libftdi/libftdi-0.15.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/libftdi-0.15.ebuild,v 1.1 2009/01/15 16:44:01 vapier Exp $
+
+DESCRIPTION="Userspace access to FTDI USB interface chips"
+HOMEPAGE="http://www.intra2net.com/opensource/ftdi/"
+SRC_URI="http://www.intra2net.com/opensource/ftdi/TGZ/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples"
+
+RDEPEND=">=dev-libs/libusb-0.1.7"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # don't bother building examples as we dont want the binaries
+ # installed and the Makefile has broken install targets
+ sed -i '/^SUBDIRS =/s:examples::' Makefile.in
+
+ use doc || export ac_cv_path_DOXYGEN=true
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ dodoc ChangeLog README
+
+ if use doc ; then
+ doman doc/man/man3/*
+ dohtml doc/html/*
+ fi
+ if use examples ; then
+ docinto examples
+ dodoc examples/*.c
+ fi
+}