summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-09-26 18:13:28 +0000
committerMike Frysinger <vapier@gentoo.org>2011-09-26 18:13:28 +0000
commit8a4555bfcf83c984165d67ee16aa3437bb7070f5 (patch)
treeb978ff04cce4ebd4440ddf5d616c50d0ebd38a6a /dev-embedded/libftdi
parentVersion bump, it finally drops RDEPEND on old libgnomeprint stuff and other d... (diff)
downloadgentoo-2-8a4555bfcf83c984165d67ee16aa3437bb7070f5.tar.gz
gentoo-2-8a4555bfcf83c984165d67ee16aa3437bb7070f5.tar.bz2
gentoo-2-8a4555bfcf83c984165d67ee16aa3437bb7070f5.zip
Add support for USE=static-libs.
Diffstat (limited to 'dev-embedded/libftdi')
-rw-r--r--dev-embedded/libftdi/ChangeLog6
-rw-r--r--dev-embedded/libftdi/libftdi-9999.1.0.ebuild8
-rw-r--r--dev-embedded/libftdi/libftdi-9999.ebuild8
3 files changed, 15 insertions, 7 deletions
diff --git a/dev-embedded/libftdi/ChangeLog b/dev-embedded/libftdi/ChangeLog
index 9b46a204a2db..28c2b2faff79 100644
--- a/dev-embedded/libftdi/ChangeLog
+++ b/dev-embedded/libftdi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-embedded/libftdi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/ChangeLog,v 1.54 2011/09/20 22:01:38 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/ChangeLog,v 1.55 2011/09/26 18:13:28 vapier Exp $
+
+ 26 Sep 2011; Mike Frysinger <vapier@gentoo.org> libftdi-9999.ebuild,
+ libftdi-9999.1.0.ebuild:
+ Add support for USE=static-libs.
20 Sep 2011; Michał Górny <mgorny@gentoo.org> libftdi-9999.ebuild,
libftdi-9999.1.0.ebuild:
diff --git a/dev-embedded/libftdi/libftdi-9999.1.0.ebuild b/dev-embedded/libftdi/libftdi-9999.1.0.ebuild
index 47abb64acdf0..bf273ccf967b 100644
--- a/dev-embedded/libftdi/libftdi-9999.1.0.ebuild
+++ b/dev-embedded/libftdi/libftdi-9999.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/libftdi-9999.1.0.ebuild,v 1.3 2011/09/20 22:01:38 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/libftdi-9999.1.0.ebuild,v 1.4 2011/09/26 18:13:28 vapier Exp $
EAPI="2"
@@ -17,7 +17,7 @@ HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"
LICENSE="LGPL-2"
SLOT="0"
-IUSE="cxx doc examples python"
+IUSE="cxx doc examples python static-libs"
RDEPEND="virtual/libusb:1
cxx? ( dev-libs/boost )
@@ -38,11 +38,13 @@ src_configure() {
$(use_enable cxx libftdipp) \
$(use_with doc docs) \
$(use_with examples) \
- $(use_enable python python-binding)
+ $(use_enable python python-binding) \
+ $(use_enable static-libs static)
}
src_install() {
emake DESTDIR="${D}" install || die
+ use static-libs || find "${D}" -name '*.la' -delete
dodoc ChangeLog README
if use doc ; then
diff --git a/dev-embedded/libftdi/libftdi-9999.ebuild b/dev-embedded/libftdi/libftdi-9999.ebuild
index 813441cfc4ab..4fb3777fe257 100644
--- a/dev-embedded/libftdi/libftdi-9999.ebuild
+++ b/dev-embedded/libftdi/libftdi-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/libftdi-9999.ebuild,v 1.3 2011/09/20 22:01:38 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/libftdi-9999.ebuild,v 1.4 2011/09/26 18:13:28 vapier Exp $
EAPI="2"
@@ -17,7 +17,7 @@ HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"
LICENSE="LGPL-2"
SLOT="0"
-IUSE="cxx doc examples python"
+IUSE="cxx doc examples python static-libs"
RDEPEND="virtual/libusb:0
cxx? ( dev-libs/boost )
@@ -37,11 +37,13 @@ src_configure() {
$(use_enable cxx libftdipp) \
$(use_with doc docs) \
$(use_with examples) \
- $(use_enable python python-binding)
+ $(use_enable python python-binding) \
+ $(use_enable static-libs static)
}
src_install() {
emake DESTDIR="${D}" install || die
+ use static-libs || find "${D}" -name '*.la' -delete
dodoc ChangeLog README
if use doc ; then