summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-04-17 20:30:20 +0000
committerMike Frysinger <vapier@gentoo.org>2008-04-17 20:30:20 +0000
commit06c136fc56aa6de16d244df5b50d3c4df9872f4b (patch)
tree3db0a1d5c7cb9aed7d3da55a4e7b3f57ce777119 /dev-embedded
parentold (diff)
downloadgentoo-2-06c136fc56aa6de16d244df5b50d3c4df9872f4b.tar.gz
gentoo-2-06c136fc56aa6de16d244df5b50d3c4df9872f4b.tar.bz2
gentoo-2-06c136fc56aa6de16d244df5b50d3c4df9872f4b.zip
Version bump.
(Portage version: 2.2_pre5)
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/libftdi/ChangeLog7
-rw-r--r--dev-embedded/libftdi/libftdi-0.12.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-embedded/libftdi/ChangeLog b/dev-embedded/libftdi/ChangeLog
index f4fbe3da0bd5..b6c8ad5836d4 100644
--- a/dev-embedded/libftdi/ChangeLog
+++ b/dev-embedded/libftdi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-embedded/libftdi
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/ChangeLog,v 1.23 2008/04/12 20:22:40 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/ChangeLog,v 1.24 2008/04/17 20:30:20 vapier Exp $
+
+*libftdi-0.12 (17 Apr 2008)
+
+ 17 Apr 2008; Mike Frysinger <vapier@gentoo.org> +libftdi-0.12.ebuild:
+ Version bump.
12 Apr 2008; Tobias Scherbaum <dertobi123@gentoo.org> libftdi-0.10.ebuild:
ppc stable, bug #217310
diff --git a/dev-embedded/libftdi/libftdi-0.12.ebuild b/dev-embedded/libftdi/libftdi-0.12.ebuild
new file mode 100644
index 000000000000..a7823b618662
--- /dev/null
+++ b/dev-embedded/libftdi/libftdi-0.12.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/libftdi-0.12.ebuild,v 1.1 2008/04/17 20:30:20 vapier Exp $
+
+DESCRIPTION="Userspace access to FTDI USB interface chips"
+HOMEPAGE="http://www.intra2net.com/opensource/ftdi/"
+SRC_URI="http://www.intra2net.com/opensource/ftdi/TGZ/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc examples"
+
+RDEPEND=">=dev-libs/libusb-0.1.7"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # don't bother building examples as we dont want the binaries
+ # installed and the Makefile has broken install targets
+ sed -i '/^SUBDIRS =/s:examples::' Makefile.in
+
+ use doc || export ac_cv_path_DOXYGEN=true
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ dodoc ChangeLog README
+
+ if use doc ; then
+ doman doc/man/man3/*
+ dohtml doc/html/*
+ fi
+ if use examples ; then
+ docinto examples
+ dodoc examples/*.c || die
+ fi
+}