summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-05 06:45:54 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-05 06:45:54 +0000
commit0fd7ffd3b3e10aa2b38df19a562e679551ad9b70 (patch)
tree5e063173c4528af5761b66a9d9df138c6f7f9eef /dev-embedded
parentStable for HPPA. (diff)
downloadgentoo-2-0fd7ffd3b3e10aa2b38df19a562e679551ad9b70.tar.gz
gentoo-2-0fd7ffd3b3e10aa2b38df19a562e679551ad9b70.tar.bz2
gentoo-2-0fd7ffd3b3e10aa2b38df19a562e679551ad9b70.zip
Fix patch and autotools rebuilding, as reported also by Timothy Redaelli in bug #154280.
(Portage version: 2.1.2_rc4-r5)
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/gpsim/ChangeLog9
-rw-r--r--dev-embedded/gpsim/files/gpsim-0.21.11-eXdbm.patch37
-rw-r--r--dev-embedded/gpsim/gpsim-0.21.11-r1.ebuild15
3 files changed, 42 insertions, 19 deletions
diff --git a/dev-embedded/gpsim/ChangeLog b/dev-embedded/gpsim/ChangeLog
index dac68e3c61e8..534890efdb71 100644
--- a/dev-embedded/gpsim/ChangeLog
+++ b/dev-embedded/gpsim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-embedded/gpsim
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim/ChangeLog,v 1.25 2006/12/23 21:34:35 dertobi123 Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim/ChangeLog,v 1.26 2007/01/05 06:45:54 flameeyes Exp $
+
+ 05 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
+ files/gpsim-0.21.11-eXdbm.patch, gpsim-0.21.11-r1.ebuild:
+ Fix patch and autotools rebuilding, as reported also by Timothy Redaelli in
+ bug #154280.
23 Dec 2006; Tobias Scherbaum <dertobi123@gentoo.org>
gpsim-0.21.11-r1.ebuild:
diff --git a/dev-embedded/gpsim/files/gpsim-0.21.11-eXdbm.patch b/dev-embedded/gpsim/files/gpsim-0.21.11-eXdbm.patch
index a4d19bd35739..dd080f6f5f0d 100644
--- a/dev-embedded/gpsim/files/gpsim-0.21.11-eXdbm.patch
+++ b/dev-embedded/gpsim/files/gpsim-0.21.11-eXdbm.patch
@@ -1,6 +1,8 @@
---- gpsim-0.21.11.orig/cli/Makefile.am 2005-04-27 10:55:13.000000000 +1000
-+++ gpsim-0.21.11/cli/Makefile.am 2006-11-04 14:00:26.000000000 +1100
-@@ -46,6 +46,7 @@
+Index: gpsim-0.21.11/cli/Makefile.am
+===================================================================
+--- gpsim-0.21.11.orig/cli/Makefile.am
++++ gpsim-0.21.11/cli/Makefile.am
+@@ -46,6 +46,7 @@ libgpsimcli_la_SOURCES = \
cmd_version.h misc.h cmd_disasm.h cmd_list.h cmd_quit.h \
cmd_stimulus.h cmd_x.h symbol_t.h cmd_frequency.h cmd_icd.h \
cmd_macro.h ui_gpsim.h
@@ -8,19 +10,23 @@
AM_YFLAGS = -dvt
---- gpsim-0.21.11.orig/gui/Makefile.am 2005-09-19 23:54:21.000000000 +1000
-+++ gpsim-0.21.11/gui/Makefile.am 2006-11-04 14:02:02.000000000 +1100
-@@ -17,6 +17,7 @@
+Index: gpsim-0.21.11/gui/Makefile.am
+===================================================================
+--- gpsim-0.21.11.orig/gui/Makefile.am
++++ gpsim-0.21.11/gui/Makefile.am
+@@ -17,6 +17,7 @@ libgpsimgui_la_SOURCES = gui_break.cc g
preferences.cc preferences.h \
settings.h settings_exdbm.h
-+libgpsimgui_la_LDADD = ../eXdbm/libgpsim_eXdbm.la
++libgpsimgui_la_LIBADD = ../eXdbm/libgpsim_eXdbm.la
libgpsimgui_la_LDFLAGS = @X_LDFLAGS@ @Y_LDFLAGS@
pixmapdir = $(datadir)/gpsim
---- gpsim-0.21.11/gpsim/Makefile.am.orig 2006-11-04 14:57:41.000000000 +1100
-+++ gpsim-0.21.11/gpsim/Makefile.am 2006-11-04 14:58:03.000000000 +1100
-@@ -9,6 +9,6 @@
+Index: gpsim-0.21.11/gpsim/Makefile.am
+===================================================================
+--- gpsim-0.21.11.orig/gpsim/Makefile.am
++++ gpsim-0.21.11/gpsim/Makefile.am
+@@ -9,6 +9,6 @@ bin_PROGRAMS = gpsim
gpsim_SOURCES = main.cc
gpsim_LDFLAGS = $(shell gtk-config --cflags)
@@ -29,3 +35,14 @@
+gpsim_LDADD = ../src/libgpsim.la ../eXdbm/libgpsim_eXdbm.la ../cli/libgpsimcli.la ../gui/libgpsimgui.la \
+ @GTK@ @GDK@ @GLIB@ -lstdc++ -lpopt \
@X_LDFLAGS@ @Y_LDFLAGS@ @LIBREADLINE@
+Index: gpsim-0.21.11/Makefile.am
+===================================================================
+--- gpsim-0.21.11.orig/Makefile.am
++++ gpsim-0.21.11/Makefile.am
+@@ -1,5 +1,5 @@
+
+-SUBDIRS = cli xpms eXdbm gui src gpsim modules examples doc
++SUBDIRS = eXdbm cli xpms gui src gpsim modules examples doc
+
+ dist-hook:
+ cp gpsim.spec $(distdir)
diff --git a/dev-embedded/gpsim/gpsim-0.21.11-r1.ebuild b/dev-embedded/gpsim/gpsim-0.21.11-r1.ebuild
index 2a6c6836a132..8731ef0eda18 100644
--- a/dev-embedded/gpsim/gpsim-0.21.11-r1.ebuild
+++ b/dev-embedded/gpsim/gpsim-0.21.11-r1.ebuild
@@ -1,8 +1,11 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim/gpsim-0.21.11-r1.ebuild,v 1.3 2006/12/23 21:34:35 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim/gpsim-0.21.11-r1.ebuild,v 1.4 2007/01/05 06:45:54 flameeyes Exp $
-inherit gnuconfig eutils autotools
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils autotools
DESCRIPTION="A simulator for the Microchip PIC microcontrollers"
HOMEPAGE="http://www.dattalo.com/gnupic/gpsim.html"
@@ -28,19 +31,17 @@ RDEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
epatch "${FILESDIR}/${P}-gcc41.patch"
epatch "${FILESDIR}/${P}-eXdbm.patch"
-# epatch "${FILESDIR}/${P}-asneeded.patch"
epatch "${FILESDIR}/gpsim-0.21.11-ktechlab.patch"
epatch "${FILESDIR}/gpsim-0.21.11-nogui.patch"
epatch "${FILESDIR}/gpsim-0.21.11-gtk2.diff"
- eautoconf
+ eautoreconf
}
src_compile() {
- gnuconfig_update
econf $(use_enable gtk gui) || die
emake || die
}