summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-18 04:14:05 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-18 04:14:05 +0000
commit43e0e5aa5ed6f3bf1e8539ef814340ed58423ab3 (patch)
tree87700a3cef43d74d397a7e54195f4107b6d15b4f /dev-games/clanlib
parentkernel module rebuilding warning #38462 (diff)
downloadgentoo-2-43e0e5aa5ed6f3bf1e8539ef814340ed58423ab3.tar.gz
gentoo-2-43e0e5aa5ed6f3bf1e8539ef814340ed58423ab3.tar.bz2
gentoo-2-43e0e5aa5ed6f3bf1e8539ef814340ed58423ab3.zip
ver bump #38464
Diffstat (limited to 'dev-games/clanlib')
-rw-r--r--dev-games/clanlib/ChangeLog11
-rw-r--r--dev-games/clanlib/clanlib-0.7.7.ebuild71
-rw-r--r--dev-games/clanlib/files/0.7.7-gl-prototype.patch9
-rw-r--r--dev-games/clanlib/files/0.7.7-port.patch11
-rw-r--r--dev-games/clanlib/files/digest-clanlib-0.7.71
5 files changed, 100 insertions, 3 deletions
diff --git a/dev-games/clanlib/ChangeLog b/dev-games/clanlib/ChangeLog
index 09c023c286b9..c8d753ea7b31 100644
--- a/dev-games/clanlib/ChangeLog
+++ b/dev-games/clanlib/ChangeLog
@@ -1,13 +1,18 @@
# ChangeLog for dev-games/clanlib
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.11 2004/01/10 02:27:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.12 2004/01/18 04:14:05 vapier Exp $
+
+*clanlib-0.7.7 (17 Jan 2004)
+
+ 17 Jan 2004; Mike Frysinger <vapier@gentoo.org> :
+ Version bump + patch #38464.
+
+*clanlib-0.7.6 (11 Nov 2003)
09 Jan 2004; Michael Sterrett <mr_bones_@gentoo.org>
clanlib-0.6.5-r1.ebuild:
call replace-flags in src_compile; more error checking/messages
-*clanlib-0.7.6 (11 Nov 2003)
-
15 Nov 2003; Mike Frysinger <vapier@gentoo.org> :
Add small patch to fix #33453.
diff --git a/dev-games/clanlib/clanlib-0.7.7.ebuild b/dev-games/clanlib/clanlib-0.7.7.ebuild
new file mode 100644
index 000000000000..ecb8023bfe7a
--- /dev/null
+++ b/dev-games/clanlib/clanlib-0.7.7.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-0.7.7.ebuild,v 1.1 2004/01/18 04:14:05 vapier Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="multi-platform game development library"
+HOMEPAGE="http://www.clanlib.org/"
+SRC_URI="http://www.clanlib.org/~sphair/download/ClanLib-${PV}-1.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0.7"
+KEYWORDS="x86"
+IUSE="opengl X sdl oggvorbis doc mikmod clanVoice clanJavaScript ipv6"
+
+DEPEND=">=media-libs/hermes-1.3.2
+ media-libs/libpng
+ media-libs/jpeg
+ opengl? ( virtual/opengl )
+ sdl? ( media-libs/libsdl )
+ X? ( virtual/x11 )
+ mikmod? ( >=media-libs/libmikmod-3.1.9 )
+ oggvorbis? ( media-libs/libvorbis )"
+
+S=${WORKDIR}/ClanLib-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-port.patch
+ epatch ${FILESDIR}/${PV}-gl-prototype.patch
+}
+
+src_compile() {
+ #clanSound only controls mikmod/vorbis so theres
+ # no need to pass --{en,dis}able-clanSound ...
+ #clanDisplay only controls X, SDL, OpenGL plugins
+ # so no need to pass --{en,dis}able-clanDisplay
+ # also same reason why we dont have to use clanGUI
+ [ `use doc` ] || sed -i '/^SUBDIRS/s:Documentation::' Makefile.in
+ econf \
+ --libdir=/usr/lib/${P} \
+ `use_enable x86 asm386` \
+ `use_enable doc docs` \
+ --enable-dyn \
+ `use_enable clanVoice` \
+ `use_enable clanJavaScript` \
+ --enable-clanNetwork \
+ `use_enable opengl clanGL` \
+ `use_enable sdl clanSDL` \
+ `use_enable oggvorbis clanVorbis` \
+ `use_enable mikmod clanMikMod` \
+ `use_enable ipv6 getaddr` \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/clanlib/* ${D}/usr/share/doc/${PF}/html/
+ rm -rf ${D}/usr/share/doc/clanlib
+ mv ${D}/usr/include/{ClanLib-*/ClanLib,${P}}
+ rm -rf ${D}/usr/include/ClanLib-*
+ dobin ${FILESDIR}/clanlib-config
+ dodoc CODING_STYLE CREDITS NEWS PATCHES README* INSTALL.linux
+}
+
+pkg_postinst() {
+ clanlib-config ${PV}
+}
diff --git a/dev-games/clanlib/files/0.7.7-gl-prototype.patch b/dev-games/clanlib/files/0.7.7-gl-prototype.patch
new file mode 100644
index 000000000000..eb6e44f49935
--- /dev/null
+++ b/dev-games/clanlib/files/0.7.7-gl-prototype.patch
@@ -0,0 +1,9 @@
+--- Sources/API/GL/opengl_wrap.h.orig 2004-01-17 22:59:57.862435912 -0500
++++ Sources/API/GL/opengl_wrap.h 2004-01-17 23:00:54.660801248 -0500
+@@ -1887,5 +1887,5 @@
+ typedef void (CL_GLFUNC *ptr_glDrawPixels)(CLsizei width, CLsizei height, CLenum format, CLenum type, const CLvoid *pixels);
+ typedef void (CL_GLFUNC *ptr_glEdgeFlag)(CLboolean flag);
+- typedef void (CL_GLFUNC *ptr_glEdgeFlagPointer)(CLsizei stride, const CLvoid *pointer);
++ typedef void (CL_GLFUNC *ptr_glEdgeFlagPointer)(CLsizei stride, const CLboolean *pointer);
+ typedef void (CL_GLFUNC *ptr_glEdgeFlagv)(const CLboolean *flag);
+ typedef void (CL_GLFUNC *ptr_glEnable)(CLenum cap);
diff --git a/dev-games/clanlib/files/0.7.7-port.patch b/dev-games/clanlib/files/0.7.7-port.patch
new file mode 100644
index 000000000000..a1da63f81147
--- /dev/null
+++ b/dev-games/clanlib/files/0.7.7-port.patch
@@ -0,0 +1,11 @@
+--- Sources/Network/Socket/ip_address_getsock.h.orig 2003-11-15 17:33:34.075094400 -0500
++++ Sources/Network/Socket/ip_address_getsock.h 2003-11-15 17:33:39.688241072 -0500
+@@ -105,7 +105,7 @@
+ unsigned int ip;
+
+ // IP port in host byte order.
+- unsigned short port;
++ unsigned int port;
+ };
+
+ #endif
diff --git a/dev-games/clanlib/files/digest-clanlib-0.7.7 b/dev-games/clanlib/files/digest-clanlib-0.7.7
new file mode 100644
index 000000000000..b58980a45c30
--- /dev/null
+++ b/dev-games/clanlib/files/digest-clanlib-0.7.7
@@ -0,0 +1 @@
+MD5 3f46a681e70e9d8849a572458abae8ca ClanLib-0.7.7-1.tar.bz2 4670490