summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-10-27 15:58:28 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-10-27 15:58:28 +0000
commitdfa52bb253760e2d2009c53d03a59e8d9abb84d5 (patch)
tree21d8c32c93ed5b14452f7ac0a8d28215d4020331 /dev-games/tiled
parentStable for ppc64, wrt bug #521284 (diff)
downloadgentoo-2-dfa52bb253760e2d2009c53d03a59e8d9abb84d5.tar.gz
gentoo-2-dfa52bb253760e2d2009c53d03a59e8d9abb84d5.tar.bz2
gentoo-2-dfa52bb253760e2d2009c53d03a59e8d9abb84d5.zip
Version bump. Remove old.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'dev-games/tiled')
-rw-r--r--dev-games/tiled/ChangeLog8
-rw-r--r--dev-games/tiled/tiled-0.10.2.ebuild52
-rw-r--r--dev-games/tiled/tiled-0.9.1.ebuild48
3 files changed, 59 insertions, 49 deletions
diff --git a/dev-games/tiled/ChangeLog b/dev-games/tiled/ChangeLog
index 367fa48180f1..67dcf2901d95 100644
--- a/dev-games/tiled/ChangeLog
+++ b/dev-games/tiled/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-games/tiled
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/tiled/ChangeLog,v 1.7 2014/09/22 18:37:40 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/tiled/ChangeLog,v 1.8 2014/10/27 15:58:28 kensington Exp $
+
+*tiled-0.10.2 (27 Oct 2014)
+
+ 27 Oct 2014; Michael Palimaka <kensington@gentoo.org> +tiled-0.10.2.ebuild,
+ -tiled-0.9.1.ebuild:
+ Version bump. Remove old.
*tiled-0.10.1 (22 Sep 2014)
diff --git a/dev-games/tiled/tiled-0.10.2.ebuild b/dev-games/tiled/tiled-0.10.2.ebuild
new file mode 100644
index 000000000000..4bc0552dd4b3
--- /dev/null
+++ b/dev-games/tiled/tiled-0.10.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/tiled/tiled-0.10.2.ebuild,v 1.1 2014/10/27 15:58:28 kensington Exp $
+
+EAPI=5
+
+PLOCALES="cs de en es fr he it ja lv nl pt pt_BR ru zh zh_TW"
+PYTHON_COMPAT=( python2_7 )
+inherit multilib l10n python-single-r1 qt4-r2
+
+DESCRIPTION="A general purpose tile map editor"
+HOMEPAGE="http://www.mapeditor.org/"
+SRC_URI="https://github.com/bjorn/tiled/archive/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND=">=dev-qt/qtcore-4.7:4
+ >=dev-qt/qtgui-4.7:4
+ >=dev-qt/qtopengl-4.7:4
+ sys-libs/zlib
+ python? ( ${PYTHON_DEPS} )"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS COPYING NEWS README.md )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ rm -r src/zlib || die
+ sed -e "s/^LANGUAGES =.*/LANGUAGES = $(l10n_get_locales)/" \
+ -i translations/translations.pro || die
+}
+
+src_configure() {
+ eqmake4 LIBDIR="/usr/$(get_libdir)" PREFIX="/usr" DISABLE_PYTHON_PLUGIN="$(usex !python)"
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ if use examples ; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+}
diff --git a/dev-games/tiled/tiled-0.9.1.ebuild b/dev-games/tiled/tiled-0.9.1.ebuild
deleted file mode 100644
index 215c84c89902..000000000000
--- a/dev-games/tiled/tiled-0.9.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/tiled/tiled-0.9.1.ebuild,v 1.2 2014/08/10 20:06:39 slyfox Exp $
-
-EAPI=5
-
-PLOCALES="cs de en es fr he it ja lv nl pt pt_BR ru zh"
-MY_P="${PN}-qt-${PV}"
-
-inherit multilib l10n qt4-r2
-
-DESCRIPTION="A general purpose tile map editor"
-HOMEPAGE="http://www.mapeditor.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="examples"
-
-DEPEND=">=dev-qt/qtcore-4.6:4
- >=dev-qt/qtgui-4.6:4
- >=dev-qt/qtopengl-4.6:4
- sys-libs/zlib"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-DOCS=( AUTHORS COPYING NEWS README.md )
-
-src_prepare() {
- rm -r src/zlib || die
- sed -e "s/^LANGUAGES =.*/LANGUAGES = $(l10n_get_locales)/" \
- -i translations/translations.pro || die
-}
-
-src_configure() {
- eqmake4 LIBDIR="/usr/$(get_libdir)" PREFIX="/usr"
-}
-
-src_install() {
- qt4-r2_src_install
-
- if use examples ; then
- docompress -x /usr/share/doc/${PF}/examples
- dodoc -r examples
- fi
-}