summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2004-06-05 13:05:03 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2004-06-05 13:05:03 +0000
commit0f31fb4dab0af216bf3193792bbf0b8da2522674 (patch)
tree9c005ac54dc4408733cbe16b426e046faf914a60 /dev-games
parentremoved uclibc-buildroot as it has been removed from portage (diff)
downloadgentoo-2-0f31fb4dab0af216bf3193792bbf0b8da2522674.tar.gz
gentoo-2-0f31fb4dab0af216bf3193792bbf0b8da2522674.tar.bz2
gentoo-2-0f31fb4dab0af216bf3193792bbf0b8da2522674.zip
new snapshot version
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/cel/ChangeLog5
-rw-r--r--dev-games/cel/Manifest7
-rw-r--r--dev-games/cel/cel-20040604.ebuild58
-rw-r--r--dev-games/cel/files/digest-cel-200406041
-rw-r--r--dev-games/crystalspace/ChangeLog8
-rw-r--r--dev-games/crystalspace/Manifest5
-rw-r--r--dev-games/crystalspace/crystalspace-20040604.ebuild64
-rw-r--r--dev-games/crystalspace/files/digest-crystalspace-200406041
8 files changed, 145 insertions, 4 deletions
diff --git a/dev-games/cel/ChangeLog b/dev-games/cel/ChangeLog
index bd12855602d5..4cf3ca7c3313 100644
--- a/dev-games/cel/ChangeLog
+++ b/dev-games/cel/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-games/cel
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/cel/ChangeLog,v 1.4 2004/03/26 10:33:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/cel/ChangeLog,v 1.5 2004/06/05 13:05:03 lordvan Exp $
+
+ 05 Jun 2004; Thomas Raschbacher <lordvan@gentoo.org> cel-20040604.ebuild:
+ new snapshot version
26 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> cel-20030413-r2.ebuild:
>=sys-apps/sed-4; IUSE
diff --git a/dev-games/cel/Manifest b/dev-games/cel/Manifest
index 5290bfeb82b0..9c6634a6faa2 100644
--- a/dev-games/cel/Manifest
+++ b/dev-games/cel/Manifest
@@ -1,5 +1,8 @@
-MD5 adc3cc36a3d6741b11510c8058aaf6ea ChangeLog 1432
MD5 be2bd60d042408a2c51e9a98b7179a73 cel-20030413-r2.ebuild 1148
+MD5 27be4cfdf0ed43d67b58ca1925efdd81 cel-20040604.ebuild 1151
+MD5 adc3cc36a3d6741b11510c8058aaf6ea ChangeLog 1432
MD5 78f796f369931ffa9a8cc4b41bca4152 metadata.xml 463
-MD5 94eb2343401fe4897e1f20711cccc080 files/cel-20030413-install.patch 819
+MD5 be2bd60d042408a2c51e9a98b7179a73 cel-20040604.ebuild~ 1148
+MD5 6e1ac2e90396f3d7d2fb178e7861aa39 files/digest-cel-20040604 66
MD5 17683292d3b178749a2b7d93eb6218cb files/digest-cel-20030413-r2 64
+MD5 94eb2343401fe4897e1f20711cccc080 files/cel-20030413-install.patch 819
diff --git a/dev-games/cel/cel-20040604.ebuild b/dev-games/cel/cel-20040604.ebuild
new file mode 100644
index 000000000000..267b49bedf48
--- /dev/null
+++ b/dev-games/cel/cel-20040604.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/cel/cel-20040604.ebuild,v 1.1 2004/06/05 13:05:03 lordvan Exp $
+
+inherit eutils
+
+DESCRIPTION="A game entity layer based on Crystal Space"
+HOMEPAGE="http://cel.sourceforge.net/"
+SRC_URI="mirror://gentoo/distfiles/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+RDEPEND="dev-games/crystalspace
+ dev-util/jam
+ !dev-games/cel-cvs
+ python? ( virtual/python )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${PN}
+
+CEL_PREFIX=/opt/crystal
+CS_PREFIX=/opt/crystal
+
+src_unpack() {
+ unpack ${A}
+# cd ${S}
+# epatch ${FILESDIR}/${P}-install.patch
+}
+
+src_compile() {
+# ./autogen.sh || die
+ MY_CONF=" --prefix=${CEL_PREFIX} --with-cs-prefix=${CS_PREFIX} "
+# if use python; then
+# MY_CONF="${MY_CONF} --with-python"
+# else
+# einfo "compiling without python"
+# MY_CONF="${MY_CONF} --without-python"
+# fi
+ # doesn't compile with python atm (2.3)
+ # FIXME: need to try with other versions of python which might work
+ MY_CONF="${MY_CONF} --without-python"
+
+ env PATH="${CEL_PREFIX}/bin:${PATH}" ./configure ${MY_CONF} || die
+
+ jam || die
+}
+
+src_install() {
+# sed -i -e "s:/usr/local/cel:${CEL_PREFIX}:g" cel.cex
+ # attention don't put a / between ${D} and ${CEL_PREFIX} jam has a bug where
+ # it fails with 3 following slashes.
+ jam -sFILEMODE=0644 -sEXEMODE=0755 -sprefix=${D}${CEL_PREFIX} install || die
+ dobin cel.cex
+}
diff --git a/dev-games/cel/files/digest-cel-20040604 b/dev-games/cel/files/digest-cel-20040604
new file mode 100644
index 000000000000..db61cf67b7fd
--- /dev/null
+++ b/dev-games/cel/files/digest-cel-20040604
@@ -0,0 +1 @@
+MD5 4a3fdf7d74b37c36c4d7d435b85de106 cel-20040604.tar.bz2 1537205
diff --git a/dev-games/crystalspace/ChangeLog b/dev-games/crystalspace/ChangeLog
index 8d61b346a887..78658b6b960a 100644
--- a/dev-games/crystalspace/ChangeLog
+++ b/dev-games/crystalspace/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-games/crystalspace
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.5 2004/06/03 21:46:19 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.6 2004/06/05 13:02:40 lordvan Exp $
+
+*crystalspace-20040604 (05 Jun 2004)
+
+ 05 Jun 2004; Thomas Raschbacher <lordvan@gentoo.org>
+ +crystalspace-20040604.ebuild:
+ new version (cvs snapshot)
03 Jun 2004; Thomas Raschbacher <lordvan@gentoo.org>
crystalspace-20030413-r1.ebuild:
diff --git a/dev-games/crystalspace/Manifest b/dev-games/crystalspace/Manifest
index 4eb8a38c6b12..01902174d486 100644
--- a/dev-games/crystalspace/Manifest
+++ b/dev-games/crystalspace/Manifest
@@ -1,4 +1,9 @@
+MD5 650084c3210a9f61f69dc9a8fb9eed8f crystalspace-20040603.ebuild~ 1660
MD5 9ebf061108b3f2278578987af766c02e crystalspace-20030413-r1.ebuild 1498
+MD5 17e9591a0b0f9b11348d3d57c7419e2d crystalspace-20040604.ebuild~ 2136
MD5 d22b6dee2799869218501ea332685ae0 ChangeLog 1196
MD5 e4c7a49ca08eb200cfa0a9f9246e2257 metadata.xml 959
+MD5 99f4b1b8142dbc3da106600dc6ca4526 crystalspace-20040604.ebuild 2137
MD5 d90edc320c9f4398c1e5c528569f8706 files/digest-crystalspace-20030413-r1 75
+MD5 c51ad111c28517fa48bf129f8e9ed43f files/digest-crystalspace-20040603 75
+MD5 392d20cde72d17f97d8dee0f54041588 files/digest-crystalspace-20040604 76
diff --git a/dev-games/crystalspace/crystalspace-20040604.ebuild b/dev-games/crystalspace/crystalspace-20040604.ebuild
new file mode 100644
index 000000000000..919f690fa738
--- /dev/null
+++ b/dev-games/crystalspace/crystalspace-20040604.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-20040604.ebuild,v 1.1 2004/06/05 13:02:40 lordvan Exp $
+
+DESCRIPTION="portable 3D Game Development Kit written in C++"
+SRC_URI="mirror://gentoo/distfiles/${P}.tar.bz2"
+HOMEPAGE="http://crystal.sourceforge.net/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="oggvorbis mikmod openal truetype 3ds mng zlib"
+
+RDEPEND=">=media-libs/libpng-1.2.1
+ >=media-libs/jpeg-6b
+ mng? ( media-libs/libmng )
+ mikmod? ( media-libs/libmikmod )
+ 3ds? ( media-libs/lib3ds )
+ truetype? ( >=media-libs/freetype-2.0 )
+ openal? ( media-libs/openal )
+ zlib? ( sys-libs/zlib )
+ oggvorbis? (
+ >=media-libs/libogg-1.0
+ >=media-libs/libvorbis-1.0 )
+ dev-games/ode
+ >=dev-lang/perl-5.6.1
+ !dev-games/crystalspace-cvs"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+
+S="${WORKDIR}/CS"
+
+CRYSTAL_PREFIX="/opt/crystal"
+
+src_compile() {
+ ./configure --prefix=${CRYSTAL_PREFIX} || die
+ jam all || die "Cannot compile"
+# emake all || die
+}
+
+src_install() {
+ #mv ${S}/Jamconfig ${S}/Jamconfig_orig
+ #sed s%/opt/crystal%${D}/opt/crystal% ${S}/Jamconfig_orig > ${S}/Jamconfig
+
+ jam -sprefix=${D}${CRYSTAL_PREFIX} install
+
+ # symlink for cs-config
+ dodir /usr/bin
+ dosym ${CRYSTAL_PREFIX}/bin/cs-config /usr/bin/cs-config
+
+ # fix path in cs-config and vfs.cfg
+ mv ${D}/opt/crystal/bin/cs-config ${D}/opt/crystal/bin/cs-config_orig
+# mv ${D}/opt/crystal/etc/crystal/vfs.cfg ${D}/opt/crystal/etc/crystal/vfs.cfg_orig
+ sed s%${D}%% ${D}/opt/crystal/bin/cs-config_orig > ${D}/opt/crystal/bin/cs-config
+# sed s%${D}%% ${D}/opt/crystal/etc/crystal/vfs.cfg_orig > ${D}/opt/crystal/etc/crystal/vfs.cfg
+ # the -sprefix=... fixes cs-config but not vfs.cfg
+
+ find ${D}/${CRYSTAL_PREFIX} -type f -exec chmod a+r '{}' \;
+ find ${D}/${CRYSTAL_PREFIX} -type d -exec chmod a+rx '{}' \;
+ chmod a+rx ${D}/${CRYSTAL_PREFIX}/{bin,lib}/*
+
+ dodir /etc/env.d
+ echo "CRYSTAL=\"${CRYSTAL_PREFIX}\"" > ${D}/etc/env.d/90crystalspace
+}
diff --git a/dev-games/crystalspace/files/digest-crystalspace-20040604 b/dev-games/crystalspace/files/digest-crystalspace-20040604
new file mode 100644
index 000000000000..d93bf816cfb1
--- /dev/null
+++ b/dev-games/crystalspace/files/digest-crystalspace-20040604
@@ -0,0 +1 @@
+MD5 ed2f3dd909ba91e4dda6cac0d9a670f0 crystalspace-20040604.tar.bz2 21122141