summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-02 05:29:14 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-02 05:29:14 +0000
commit67b2c2eeba91c9a9df737a5c4974cfb069d84650 (patch)
tree8f00a852108f0c3628e34cf3c463c5e4d7661d11 /dev-games
parentCleanups for migration to new Java system. (diff)
downloadgentoo-2-67b2c2eeba91c9a9df737a5c4974cfb069d84650.tar.gz
gentoo-2-67b2c2eeba91c9a9df737a5c4974cfb069d84650.tar.bz2
gentoo-2-67b2c2eeba91c9a9df737a5c4974cfb069d84650.zip
old
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/ogre/files/ogre-1.0.1-autotools.patch102
-rw-r--r--dev-games/ogre/files/ogre-1.0.2-autotools.patch20
-rw-r--r--dev-games/ogre/files/ogre-1.0.6-gcc41.patch61
-rw-r--r--dev-games/ogre/files/ogre-1.0.7-gcc34.patch10
-rw-r--r--dev-games/ogre/files/ogre-1.0.7-gcc41.patch61
5 files changed, 0 insertions, 254 deletions
diff --git a/dev-games/ogre/files/ogre-1.0.1-autotools.patch b/dev-games/ogre/files/ogre-1.0.1-autotools.patch
deleted file mode 100644
index 9d759a5b9d86..000000000000
--- a/dev-games/ogre/files/ogre-1.0.1-autotools.patch
+++ /dev/null
@@ -1,102 +0,0 @@
-Autotool code has a bunch of random mistakes, lets fix them.
-
-- crosscompiling should look at $host, not at $build or $target
-- use AC_MSG_RESULT() instead of doing a 'raw' echo
-- AC_ARG_WITH / AC_ARG_ENABLE handles 3rd param incorrectly
-- threading support uses boost but never links it in !?
-
---- acinclude.m4
-+++ acinclude.m4
-@@ -278,3 +278,3 @@
- AC_DEFUN([OGRE_SETUP_FOR_TARGET],
--[case $target in
-+[case $host in
- *-*-cygwin* | *-*-mingw* | *-*-pw32*)
-@@ -324,9 +324,9 @@
- [Build the OpenEXR plugin]),
-- [build_exr=true],
-- [build_exr=false])
-+ [build_exr=$enableval],
-+ [build_exr=no])
-
--if test "x$build_exr" = "xtrue" ; then
-- PKG_CHECK_MODULES(OPENEXR, OpenEXR, [build_exr=true], [build_exr=false])
-+if test "x$build_exr" = "xyes" ; then
-+ PKG_CHECK_MODULES(OPENEXR, OpenEXR, [build_exr=yes], [build_exr=no])
-
-- if test "x$build_exr" = "xtrue" ; then
-+ if test "x$build_exr" = "xyes" ; then
- AC_CONFIG_FILES([ PlugIns/EXRCodec/Makefile \
-@@ -341,3 +341,3 @@
-
--AM_CONDITIONAL(BUILD_EXRPLUGIN, test x$build_exr = xtrue)
-+AM_CONDITIONAL(BUILD_EXRPLUGIN, test x$build_exr = xyes)
-
-@@ -380,6 +380,6 @@
- [Build the DirectX 9 Render System]),
-- [build_dx9=true],
-- [build_dx9=false])
-+ [build_dx9=$enableval],
-+ [build_dx9=no])
-
--AM_CONDITIONAL(BUILD_DX9RENDERSYSTEM, test x$build_dx9 = xtrue)
-+AM_CONDITIONAL(BUILD_DX9RENDERSYSTEM, test x$build_dx9 = xyes)
-
-@@ -391,8 +391,8 @@
- [Don't use DevIL for image loading. This is not recommended unless you provide your own image loading codecs.]),
-- [build_il=false],
-- [build_il=true])
-+ [build_il=$enableval],
-+ [build_il=yes])
-
--AM_CONDITIONAL(USE_DEVIL, test x$build_il = xtrue)
-+AM_CONDITIONAL(USE_DEVIL, test x$build_il = xyes)
-
--if [ test x$build_il = xtrue ]; then
-+if test x$build_il = xyes ; then
- AC_CHECK_LIB(IL, ilInit,,AC_MSG_ERROR([
-@@ -418,9 +418,9 @@
- AC_MSG_CHECKING([whether -fPIC is needed])
-- case $build in
-+ case $host in
- x86_64-*)
- CXXFLAGS="$CXXFLAGS -fPIC"
-- echo "yes"
-+ AC_MSG_RESULT(yes)
- ;;
- *)
-- echo "no"
-+ AC_MSG_RESULT(no)
- ;;
-@@ -459,3 +459,3 @@
- AC_DEFINE([OGRE_DOUBLE_PRECISION], [1], [Build with double precision])
-- echo "yes"
-+ AC_MSG_RESULT(yes)
- ;;
-@@ -463,3 +463,3 @@
- AC_DEFINE([OGRE_DOUBLE_PRECISION], [0], [Build with double precision])
-- echo "no"
-+ AC_MSG_RESULT(no)
- ;;
-@@ -479,3 +479,4 @@
- AC_DEFINE([OGRE_THREAD_SUPPORT], [1], [Build with thread support])
-- echo "yes"
-+ OGRE_THREAD_LIBS="-lboost_thread-mt"
-+ AC_MSG_RESULT(yes)
- ;;
-@@ -483,5 +484,7 @@
- AC_DEFINE([OGRE_THREAD_SUPPORT], [0], [Build with thread support])
-- echo "no"
-+ OGRE_THREAD_LIBS=""
-+ AC_MSG_RESULT(no)
- ;;
- esac
-+AC_SUBST(OGRE_THREAD_LIBS)
- ])
---- OgreMain/src/Makefile.am.orig 2005-05-03 13:33:08.000000000 -0400
-+++ OgreMain/src/Makefile.am 2005-05-03 13:37:12.000000000 -0400
-@@ -156,3 +156,3 @@
-
--libOgreMain_la_LIBADD= $(STLPORT_LIBS) $(FT2_LIBS) $(ZZIPLIB_LIBS)
-+libOgreMain_la_LIBADD= $(STLPORT_LIBS) $(FT2_LIBS) $(ZZIPLIB_LIBS) $(OGRE_THREAD_LIBS)
- libOgreMain_la_LDFLAGS = $(SHARED_FLAGS) -version-info @OGREMAIN_VERSION_INFO@
diff --git a/dev-games/ogre/files/ogre-1.0.2-autotools.patch b/dev-games/ogre/files/ogre-1.0.2-autotools.patch
deleted file mode 100644
index 07324d525dab..000000000000
--- a/dev-games/ogre/files/ogre-1.0.2-autotools.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-The build exr logic is inverted, so un-invert it.
-
-http://bugs.gentoo.org/95396
-https://sourceforge.net/tracker/index.php?func=detail&aid=1216798&group_id=2997&atid=302997
-
---- acinclude.m4
-+++ acinclude.m4
-@@ -325,10 +325,10 @@
- [build_exr=$enableval],
- [build_exr=no])
-
--if test "x$build_exr" = "xno" ; then
-+if test "x$build_exr" = "xyes" ; then
- PKG_CHECK_MODULES(OPENEXR, OpenEXR, [build_exr=yes], [build_exr=no])
-
-- if test "x$build_exr" = "xno" ; then
-+ if test "x$build_exr" = "xyes" ; then
- AC_CONFIG_FILES([ PlugIns/EXRCodec/Makefile \
- PlugIns/EXRCodec/src/Makefile \
- PlugIns/EXRCodec/include/Makefile])
diff --git a/dev-games/ogre/files/ogre-1.0.6-gcc41.patch b/dev-games/ogre/files/ogre-1.0.6-gcc41.patch
deleted file mode 100644
index 91a0357848be..000000000000
--- a/dev-games/ogre/files/ogre-1.0.6-gcc41.patch
+++ /dev/null
@@ -1,61 +0,0 @@
---- ./ogrenew/OgreMain/include/OgreEntity.h.old 2005-11-16 21:39:05.000000000 +0100
-+++ ./ogrenew/OgreMain/include/OgreEntity.h 2006-01-28 15:10:57.000000000 +0100
-@@ -568,7 +568,7 @@
-
- /** Stops sharing the SkeletonInstance with other entities.
- */
-- void Entity::stopSharingSkeletonInstance();
-+ void stopSharingSkeletonInstance();
-
-
- /**
-
---- ./ogrenew/OgreMain/include/OgreHardwareOcclusionQuery.h.old 2005-08-20 01:47:32.000000000 +0200
-+++ ./ogrenew/OgreMain/include/OgreHardwareOcclusionQuery.h 2006-01-28 15:18:38.000000000 +0100
-@@ -113,7 +113,7 @@
- * Lets you know when query is done, or still be processed by the Hardware
- * @return true if query isn't finished.
- */
-- virtual bool HardwareOcclusionQuery::isStillOutstanding(void) = 0;
-+ virtual bool isStillOutstanding(void) = 0;
- /**
- *
- * @Remarks This function allows you to set how often the hardware occlusion really are sent to the driver
-
---- ./ogrenew/OgreMain/include/OgreImage.h.old 2005-04-06 15:30:43.000000000 +0200
-+++ ./ogrenew/OgreMain/include/OgreImage.h 2006-01-28 14:56:54.000000000 +0100
-@@ -136,7 +136,7 @@
- @remarks
- The size of the buffer must be numFaces*PixelUtil::getMemorySize(width, height, depth, format)
- */
-- Image& Image::loadDynamicImage( uchar* pData, size_t uWidth, size_t uHeight,
-+ Image& loadDynamicImage( uchar* pData, size_t uWidth, size_t uHeight,
- size_t depth,
- PixelFormat eFormat, bool autoDelete = false,
- size_t numFaces = 1, size_t numMipMaps = 0);
-
---- ./ogrenew/PlugIns/OctreeSceneManager/include/OgreOctreeSceneManager.h.old 2005-02-04 18:51:24.000000000 +0100
-+++ ./ogrenew/PlugIns/OctreeSceneManager/include/OgreOctreeSceneManager.h 2006-01-28 15:30:05.000000000 +0100
-@@ -193,8 +193,8 @@
- /** Overridden from SceneManager */
- void clearScene(void);
-
-- AxisAlignedBoxSceneQuery* OctreeSceneManager::createAABBQuery(const AxisAlignedBox& box, unsigned long mask);
-- SphereSceneQuery* OctreeSceneManager::createSphereQuery(const Sphere& sphere, unsigned long mask);
-+ AxisAlignedBoxSceneQuery* createAABBQuery(const AxisAlignedBox& box, unsigned long mask);
-+ SphereSceneQuery* createSphereQuery(const Sphere& sphere, unsigned long mask);
- PlaneBoundedVolumeListSceneQuery* createPlaneBoundedVolumeQuery(const PlaneBoundedVolumeList& volumes, unsigned long mask);
- RaySceneQuery* createRayQuery(const Ray& ray, unsigned long mask);
- IntersectionSceneQuery* createIntersectionQuery(unsigned long mask);
-
---- ./ogrenew/Tools/XMLConverter/include/tinyxml.h.old 2003-09-11 00:48:29.000000000 +0200
-+++ ./ogrenew/Tools/XMLConverter/include/tinyxml.h 2006-01-28 15:42:29.000000000 +0100
-@@ -790,7 +790,7 @@
- #endif
-
- /// Construct.
-- TiXmlDeclaration::TiXmlDeclaration( const char * _version,
-+ TiXmlDeclaration( const char * _version,
- const char * _encoding,
- const char * _standalone );
-
diff --git a/dev-games/ogre/files/ogre-1.0.7-gcc34.patch b/dev-games/ogre/files/ogre-1.0.7-gcc34.patch
deleted file mode 100644
index 0503d5a2fafe..000000000000
--- a/dev-games/ogre/files/ogre-1.0.7-gcc34.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- PlatformManagers/SDL/src/OgreSDLConfig_gtk.cpp.original 2006-03-20 22:08:17.000000000 +0100
-+++ PlatformManagers/SDL/src/OgreSDLConfig_gtk.cpp 2006-03-20 22:06:59.000000000 +0100
-@@ -22,6 +22,7 @@
- -----------------------------------------------------------------------------
- */
-
-+#include "OgreLogManager.h"
- #include "OgreSDLConfig.h"
-
- #include <libglademm/xml.h>
diff --git a/dev-games/ogre/files/ogre-1.0.7-gcc41.patch b/dev-games/ogre/files/ogre-1.0.7-gcc41.patch
deleted file mode 100644
index 91a0357848be..000000000000
--- a/dev-games/ogre/files/ogre-1.0.7-gcc41.patch
+++ /dev/null
@@ -1,61 +0,0 @@
---- ./ogrenew/OgreMain/include/OgreEntity.h.old 2005-11-16 21:39:05.000000000 +0100
-+++ ./ogrenew/OgreMain/include/OgreEntity.h 2006-01-28 15:10:57.000000000 +0100
-@@ -568,7 +568,7 @@
-
- /** Stops sharing the SkeletonInstance with other entities.
- */
-- void Entity::stopSharingSkeletonInstance();
-+ void stopSharingSkeletonInstance();
-
-
- /**
-
---- ./ogrenew/OgreMain/include/OgreHardwareOcclusionQuery.h.old 2005-08-20 01:47:32.000000000 +0200
-+++ ./ogrenew/OgreMain/include/OgreHardwareOcclusionQuery.h 2006-01-28 15:18:38.000000000 +0100
-@@ -113,7 +113,7 @@
- * Lets you know when query is done, or still be processed by the Hardware
- * @return true if query isn't finished.
- */
-- virtual bool HardwareOcclusionQuery::isStillOutstanding(void) = 0;
-+ virtual bool isStillOutstanding(void) = 0;
- /**
- *
- * @Remarks This function allows you to set how often the hardware occlusion really are sent to the driver
-
---- ./ogrenew/OgreMain/include/OgreImage.h.old 2005-04-06 15:30:43.000000000 +0200
-+++ ./ogrenew/OgreMain/include/OgreImage.h 2006-01-28 14:56:54.000000000 +0100
-@@ -136,7 +136,7 @@
- @remarks
- The size of the buffer must be numFaces*PixelUtil::getMemorySize(width, height, depth, format)
- */
-- Image& Image::loadDynamicImage( uchar* pData, size_t uWidth, size_t uHeight,
-+ Image& loadDynamicImage( uchar* pData, size_t uWidth, size_t uHeight,
- size_t depth,
- PixelFormat eFormat, bool autoDelete = false,
- size_t numFaces = 1, size_t numMipMaps = 0);
-
---- ./ogrenew/PlugIns/OctreeSceneManager/include/OgreOctreeSceneManager.h.old 2005-02-04 18:51:24.000000000 +0100
-+++ ./ogrenew/PlugIns/OctreeSceneManager/include/OgreOctreeSceneManager.h 2006-01-28 15:30:05.000000000 +0100
-@@ -193,8 +193,8 @@
- /** Overridden from SceneManager */
- void clearScene(void);
-
-- AxisAlignedBoxSceneQuery* OctreeSceneManager::createAABBQuery(const AxisAlignedBox& box, unsigned long mask);
-- SphereSceneQuery* OctreeSceneManager::createSphereQuery(const Sphere& sphere, unsigned long mask);
-+ AxisAlignedBoxSceneQuery* createAABBQuery(const AxisAlignedBox& box, unsigned long mask);
-+ SphereSceneQuery* createSphereQuery(const Sphere& sphere, unsigned long mask);
- PlaneBoundedVolumeListSceneQuery* createPlaneBoundedVolumeQuery(const PlaneBoundedVolumeList& volumes, unsigned long mask);
- RaySceneQuery* createRayQuery(const Ray& ray, unsigned long mask);
- IntersectionSceneQuery* createIntersectionQuery(unsigned long mask);
-
---- ./ogrenew/Tools/XMLConverter/include/tinyxml.h.old 2003-09-11 00:48:29.000000000 +0200
-+++ ./ogrenew/Tools/XMLConverter/include/tinyxml.h 2006-01-28 15:42:29.000000000 +0100
-@@ -790,7 +790,7 @@
- #endif
-
- /// Construct.
-- TiXmlDeclaration::TiXmlDeclaration( const char * _version,
-+ TiXmlDeclaration( const char * _version,
- const char * _encoding,
- const char * _standalone );
-