summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2013-09-06 19:45:00 +0000
committerIan Stakenvicius <axs@gentoo.org>2013-09-06 19:45:00 +0000
commita9be941834bc772c6d2b470ec21e288d09ee4100 (patch)
tree9f396e5cb1293c7194107fc4b0291c35a6b85cdc /dev-games
parentversion bump, close bug #483816 (diff)
downloadgentoo-2-a9be941834bc772c6d2b470ec21e288d09ee4100.tar.gz
gentoo-2-a9be941834bc772c6d2b470ec21e288d09ee4100.tar.bz2
gentoo-2-a9be941834bc772c6d2b470ec21e288d09ee4100.zip
converted to support multilib-build; commit OKd by radhermit
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/physfs/ChangeLog7
-rw-r--r--dev-games/physfs/physfs-2.0.3-r1.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-games/physfs/ChangeLog b/dev-games/physfs/ChangeLog
index 550808e53959..eeff7da7e256 100644
--- a/dev-games/physfs/ChangeLog
+++ b/dev-games/physfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-games/physfs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/physfs/ChangeLog,v 1.55 2013/01/22 18:02:07 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/physfs/ChangeLog,v 1.56 2013/09/06 19:45:00 axs Exp $
+
+*physfs-2.0.3-r1 (06 Sep 2013)
+
+ 06 Sep 2013; Ian Stakenvicius <axs@gentoo.org> +physfs-2.0.3-r1.ebuild:
+ converted to support multilib-build; commit OKd by radhermit
22 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org> -physfs-2.0.1.ebuild,
-physfs-2.0.2-r1.ebuild:
diff --git a/dev-games/physfs/physfs-2.0.3-r1.ebuild b/dev-games/physfs/physfs-2.0.3-r1.ebuild
new file mode 100644
index 000000000000..aeab88c2585b
--- /dev/null
+++ b/dev-games/physfs/physfs-2.0.3-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/physfs/physfs-2.0.3-r1.ebuild,v 1.1 2013/09/06 19:45:00 axs Exp $
+
+EAPI=5
+inherit cmake-multilib
+
+DESCRIPTION="Abstraction layer for filesystem and archive access"
+HOMEPAGE="http://icculus.org/physfs/"
+SRC_URI="http://icculus.org/physfs/downloads/${P}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc grp hog mvl qpak static-libs wad +zip"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ sed -i -e 's:-Werror::' CMakeLists.txt || die
+ # make sure these libs aren't used
+ rm -rf lzma zlib*
+}
+
+src_configure() {
+ local mycmakeargs="
+ -DPHYSFS_ARCHIVE_7Z=OFF
+ -DPHYSFS_BUILD_SHARED=ON
+ -DPHYSFS_BUILD_TEST=OFF
+ -DPHYSFS_BUILD_WX_TEST=OFF
+ -DPHYSFS_INTERNAL_ZLIB=OFF
+ $(cmake-utils_use static-libs PHYSFS_BUILD_STATIC)
+ $(cmake-utils_use grp PHYSFS_ARCHIVE_GRP)
+ $(cmake-utils_use hog PHYSFS_ARCHIVE_HOG)
+ $(cmake-utils_use mvl PHYSFS_ARCHIVE_MVL)
+ $(cmake-utils_use wad PHYSFS_ARCHIVE_WAD)
+ $(cmake-utils_use qpak PHYSFS_ARCHIVE_QPAK)
+ $(cmake-utils_use zip PHYSFS_ARCHIVE_ZIP)"
+
+ cmake-multilib_src_configure
+}
+
+src_compile() {
+ cmake-multilib_src_compile
+
+ if multilib_is_native_abi && use doc ; then
+ doxygen || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ local DOCS="CHANGELOG.txt CREDITS.txt TODO.txt"
+ local HTML_DOCS=$(use doc && echo docs/html/*)
+
+ cmake-multilib_src_install
+}