summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-01-28 10:42:53 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-01-28 10:42:53 +0000
commitd65a8beda98db0952293def3b88aa2047942bd2d (patch)
tree20497bfa948709f9ca4efa32c4dbff93cb2741da /dev-games
parentFix doc building. #442904 (diff)
downloadgentoo-2-d65a8beda98db0952293def3b88aa2047942bd2d.tar.gz
gentoo-2-d65a8beda98db0952293def3b88aa2047942bd2d.tar.bz2
gentoo-2-d65a8beda98db0952293def3b88aa2047942bd2d.zip
Version bump.
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/tiled/ChangeLog9
-rw-r--r--dev-games/tiled/tiled-0.9.0.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-games/tiled/ChangeLog b/dev-games/tiled/ChangeLog
index 75bcf4b393bc..6e79e978fac9 100644
--- a/dev-games/tiled/ChangeLog
+++ b/dev-games/tiled/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-games/tiled
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/tiled/ChangeLog,v 1.1 2012/08/06 14:32:28 kensington Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/tiled/ChangeLog,v 1.2 2013/01/28 10:42:53 kensington Exp $
+
+*tiled-0.9.0 (28 Jan 2013)
+
+ 28 Jan 2013; Michael Palimaka <kensington@gentoo.org> +tiled-0.9.0.ebuild:
+ Version bump.
*tiled-0.8.1 (06 Aug 2012)
diff --git a/dev-games/tiled/tiled-0.9.0.ebuild b/dev-games/tiled/tiled-0.9.0.ebuild
new file mode 100644
index 000000000000..fed2aaa751af
--- /dev/null
+++ b/dev-games/tiled/tiled-0.9.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/tiled/tiled-0.9.0.ebuild,v 1.1 2013/01/28 10:42:53 kensington Exp $
+
+EAPI=5
+
+PLOCALES="cs de en es fr he it ja lv nl pt pt_BR ru zh"
+MY_P="${PN}-qt-${PV}"
+
+inherit multilib l10n qt4-r2
+
+DESCRIPTION="A general purpose tile map editor."
+HOMEPAGE="http://www.mapeditor.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+DEPEND="sys-libs/zlib
+ >=x11-libs/qt-core-4.6:4
+ >=x11-libs/qt-gui-4.6:4
+ >=x11-libs/qt-opengl-4.6:4"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS COPYING NEWS README.md )
+
+src_prepare() {
+ rm -r src/zlib || die
+ sed -e "s/^LANGUAGES =.*/LANGUAGES = $(l10n_get_locales)/" \
+ -i translations/translations.pro || die
+}
+
+src_configure() {
+ eqmake4 LIBDIR="/usr/$(get_libdir)" PREFIX="/usr"
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ if use examples ; then
+ insinto /usr/share/${PN}
+ doins -r examples
+ fi
+}