summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-08-05 20:42:47 +0000
committerWilliam Hubbs <williamh@gentoo.org>2015-08-05 20:42:47 +0000
commit13c56ac4ce380a17c838ceb74f7348f79f79a67c (patch)
tree15cddab72c2e9c7210647c218401878e7abe871a /dev-go
parentadd golang-vcs-snapshot support to the live ebuild (diff)
downloadgentoo-2-13c56ac4ce380a17c838ceb74f7348f79f79a67c.tar.gz
gentoo-2-13c56ac4ce380a17c838ceb74f7348f79f79a67c.tar.bz2
gentoo-2-13c56ac4ce380a17c838ceb74f7348f79f79a67c.zip
add golang-vcs-snapshot support to the live ebuild
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/sarama/ChangeLog5
-rw-r--r--dev-go/sarama/sarama-9999.ebuild33
2 files changed, 6 insertions, 32 deletions
diff --git a/dev-go/sarama/ChangeLog b/dev-go/sarama/ChangeLog
index 1987320e72ba..a7a30bd43617 100644
--- a/dev-go/sarama/ChangeLog
+++ b/dev-go/sarama/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-go/sarama
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/sarama/ChangeLog,v 1.1 2015/07/30 21:17:18 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/sarama/ChangeLog,v 1.2 2015/08/05 20:42:47 williamh Exp $
+
+ 05 Aug 2015; William Hubbs <williamh@gentoo.org> sarama-9999.ebuild:
+ add golang-vcs-snapshot support to the live ebuild
*sarama-9999 (30 Jul 2015)
*sarama-1.4.3 (30 Jul 2015)
diff --git a/dev-go/sarama/sarama-9999.ebuild b/dev-go/sarama/sarama-9999.ebuild
index 09fa74ca2385..82d749e6b164 100644
--- a/dev-go/sarama/sarama-9999.ebuild
+++ b/dev-go/sarama/sarama-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/sarama/sarama-9999.ebuild,v 1.1 2015/07/30 21:17:18 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/sarama/sarama-9999.ebuild,v 1.2 2015/08/05 20:42:47 williamh Exp $
EAPI=5
@@ -12,6 +12,7 @@ if [[ ${PV} = *9999* ]]; then
else
KEYWORDS="~amd64"
SRC_URI="https://${EGO_SRC}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
fi
inherit golang-build
@@ -26,42 +27,12 @@ DEPEND="dev-go/go-eapache-queue
test? ( dev-go/go-spew )"
RDEPEND=""
-if [[ ${PV} != *9999* ]]; then
-src_unpack() {
- local f
-
- for f in ${A}
- do
- case "${f}" in
- *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
- local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
-
- debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
-
- # XXX: check whether the directory structure inside is
- # fine? i.e. if the tarball has actually a parent dir.
- mkdir -p "${destdir}" || die
- tar -C "${destdir}" -x --strip-components 1 \
- -f "${DISTDIR}/${f}" || die
- ;;
- *)
- debug-print "${FUNCNAME}: falling back to unpack for ${f}"
-
- # fall back to the default method
- unpack "${f}"
- ;;
- esac
- done
-}
-fi
-
src_prepare() {
# avoid toxiproxy dependency
rm src/${EGO_SRC}/functional*_test.go || die
}
src_install() {
- rm -rf src/${EGO_SRC}/.git* || die
golang-build_src_install
rm bin/http_server || die
dobin bin/*