summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-08-05 20:38:06 +0000
committerWilliam Hubbs <williamh@gentoo.org>2015-08-05 20:38:06 +0000
commit18b2707fe1493b2217770d7b89435bec4f53f5e6 (patch)
tree5b48c858696e7939d503f4a7224befe64184c822 /dev-go
parentcleaned up old versions as per security bug 550288 (diff)
downloadgentoo-2-18b2707fe1493b2217770d7b89435bec4f53f5e6.tar.gz
gentoo-2-18b2707fe1493b2217770d7b89435bec4f53f5e6.tar.bz2
gentoo-2-18b2707fe1493b2217770d7b89435bec4f53f5e6.zip
add golang-vcs-snapshot support to the live ebuild
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/go-tools/ChangeLog5
-rw-r--r--dev-go/go-tools/go-tools-9999.ebuild32
2 files changed, 6 insertions, 31 deletions
diff --git a/dev-go/go-tools/ChangeLog b/dev-go/go-tools/ChangeLog
index e47df1bd056b..0c8bc0414e57 100644
--- a/dev-go/go-tools/ChangeLog
+++ b/dev-go/go-tools/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-go/go-tools
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-tools/ChangeLog,v 1.13 2015/07/06 23:34:44 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-tools/ChangeLog,v 1.14 2015/08/05 20:38:06 williamh Exp $
+
+ 05 Aug 2015; William Hubbs <williamh@gentoo.org> go-tools-9999.ebuild:
+ add golang-vcs-snapshot support to the live ebuild
06 Jul 2015; William Hubbs <williamh@gentoo.org> go-tools-9999.ebuild:
add slot dependency on go-net
diff --git a/dev-go/go-tools/go-tools-9999.ebuild b/dev-go/go-tools/go-tools-9999.ebuild
index 20069b4f540c..1c18bcb6f193 100644
--- a/dev-go/go-tools/go-tools-9999.ebuild
+++ b/dev-go/go-tools/go-tools-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-tools/go-tools-9999.ebuild,v 1.10 2015/07/06 23:34:44 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-tools/go-tools-9999.ebuild,v 1.11 2015/08/05 20:38:06 williamh Exp $
EAPI=5
EGO_PN="golang.org/x/tools/..."
@@ -12,6 +12,7 @@ else
EGIT_COMMIT="ac303766f5f240c1796eeea3dc9bf34f1261aa35"
ARCHIVE_URI="https://github.com/golang/tools/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
+ inherit golang-vcs-snapshot
fi
inherit golang-build
@@ -25,35 +26,6 @@ IUSE=""
DEPEND="dev-go/go-net:="
RDEPEND=""
-if [[ ${PV} != *9999* ]]; then
-src_unpack() {
- local f
-
- for f in ${A}
- do
- case "${f}" in
- *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
- local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
-
- debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
-
- # XXX: check whether the directory structure inside is
- # fine? i.e. if the tarball has actually a parent dir.
- mkdir -p "${destdir}" || die
- tar -C "${destdir}" -x --strip-components 1 \
- -f "${DISTDIR}/${f}" || die
- ;;
- *)
- debug-print "${FUNCNAME}: falling back to unpack for ${f}"
-
- # fall back to the default method
- unpack "${f}"
- ;;
- esac
- done
-}
-fi
-
src_prepare() {
# disable broken tests
sed -e 's:TestWeb(:_\0:' \