summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-08-05 17:35:38 +0000
committerWilliam Hubbs <williamh@gentoo.org>2015-08-05 17:35:38 +0000
commitca06b4d2f9eaf0af0e5d72fca00e4ea1b37f2189 (patch)
tree01ce1027448fccaa0633ef9cf4681320c233cde2 /dev-go
parentsys-cluster/torque: cleanup old (diff)
downloadgentoo-2-ca06b4d2f9eaf0af0e5d72fca00e4ea1b37f2189.tar.gz
gentoo-2-ca06b4d2f9eaf0af0e5d72fca00e4ea1b37f2189.tar.bz2
gentoo-2-ca06b4d2f9eaf0af0e5d72fca00e4ea1b37f2189.zip
add support for golang-vcs-snapshot to live ebuild
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/go-resiliency/ChangeLog5
-rw-r--r--dev-go/go-resiliency/go-resiliency-9999.ebuild37
2 files changed, 6 insertions, 36 deletions
diff --git a/dev-go/go-resiliency/ChangeLog b/dev-go/go-resiliency/ChangeLog
index fc83ece49dd1..feb37c8ec24a 100644
--- a/dev-go/go-resiliency/ChangeLog
+++ b/dev-go/go-resiliency/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-go/go-resiliency
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-resiliency/ChangeLog,v 1.3 2015/07/30 20:45:07 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-resiliency/ChangeLog,v 1.4 2015/08/05 17:35:38 williamh Exp $
+
+ 05 Aug 2015; William Hubbs <williamh@gentoo.org> go-resiliency-9999.ebuild:
+ add support for golang-vcs-snapshot to live ebuild
30 Jul 2015; Zac Medico <zmedico@gentoo.org> go-resiliency-1.0.0.ebuild,
go-resiliency-9999.ebuild:
diff --git a/dev-go/go-resiliency/go-resiliency-9999.ebuild b/dev-go/go-resiliency/go-resiliency-9999.ebuild
index e40997d0af9f..9106ec4d5678 100644
--- a/dev-go/go-resiliency/go-resiliency-9999.ebuild
+++ b/dev-go/go-resiliency/go-resiliency-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-resiliency/go-resiliency-9999.ebuild,v 1.3 2015/07/30 20:45:07 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-resiliency/go-resiliency-9999.ebuild,v 1.4 2015/08/05 17:35:38 williamh Exp $
EAPI=5
@@ -12,6 +12,7 @@ if [[ ${PV} = *9999* ]]; then
else
KEYWORDS="~amd64"
SRC_URI="https://${EGO_SRC}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
fi
inherit golang-build
@@ -22,37 +23,3 @@ SLOT="0/${PV}"
IUSE=""
DEPEND=""
RDEPEND=""
-
-if [[ ${PV} != *9999* ]]; then
-src_unpack() {
- local f
-
- for f in ${A}
- do
- case "${f}" in
- *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
- local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
-
- debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
-
- # XXX: check whether the directory structure inside is
- # fine? i.e. if the tarball has actually a parent dir.
- mkdir -p "${destdir}" || die
- tar -C "${destdir}" -x --strip-components 1 \
- -f "${DISTDIR}/${f}" || die
- ;;
- *)
- debug-print "${FUNCNAME}: falling back to unpack for ${f}"
-
- # fall back to the default method
- unpack "${f}"
- ;;
- esac
- done
-}
-fi
-
-src_install() {
- rm -rf src/${EGO_SRC}/.git* || die
- golang-build_src_install
-}