summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-11-20 14:16:39 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-11-20 14:16:39 +0000
commit8388e5445eeda0a184a9ad5a27516e472d5884c1 (patch)
treeb0cc4ddb87e6d87373e89e22a957def202b9390e /dev-haskell/aeson-pretty
parentSecurity bump for nss/nspr update (diff)
downloadgentoo-2-8388e5445eeda0a184a9ad5a27516e472d5884c1.tar.gz
gentoo-2-8388e5445eeda0a184a9ad5a27516e472d5884c1.tar.bz2
gentoo-2-8388e5445eeda0a184a9ad5a27516e472d5884c1.zip
Initial commit. JSON pretty-printing library and command-line tool.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell/aeson-pretty')
-rw-r--r--dev-haskell/aeson-pretty/ChangeLog9
-rw-r--r--dev-haskell/aeson-pretty/aeson-pretty-0.7.ebuild36
-rw-r--r--dev-haskell/aeson-pretty/metadata.xml27
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-haskell/aeson-pretty/ChangeLog b/dev-haskell/aeson-pretty/ChangeLog
new file mode 100644
index 000000000000..9799ec01031c
--- /dev/null
+++ b/dev-haskell/aeson-pretty/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/aeson-pretty
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/aeson-pretty/ChangeLog,v 1.1 2013/11/20 14:16:39 slyfox Exp $
+
+*aeson-pretty-0.7 (20 Nov 2013)
+
+ 20 Nov 2013; Sergei Trofimovich <slyfox@gentoo.org> +aeson-pretty-0.7.ebuild,
+ +metadata.xml:
+ Initial commit. JSON pretty-printing library and command-line tool.
diff --git a/dev-haskell/aeson-pretty/aeson-pretty-0.7.ebuild b/dev-haskell/aeson-pretty/aeson-pretty-0.7.ebuild
new file mode 100644
index 000000000000..1a194f21ab4b
--- /dev/null
+++ b/dev-haskell/aeson-pretty/aeson-pretty-0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/aeson-pretty/aeson-pretty-0.7.ebuild,v 1.1 2013/11/20 14:16:39 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="JSON pretty-printing library and command-line tool."
+HOMEPAGE="http://github.com/informatikr/aeson-pretty"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="lib-only"
+
+RDEPEND=">=dev-haskell/aeson-0.6:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/unordered-containers-0.1.3.0:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ !lib-only? ( >=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/cmdargs-0.7:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag lib-only lib-only)
+}
diff --git a/dev-haskell/aeson-pretty/metadata.xml b/dev-haskell/aeson-pretty/metadata.xml
new file mode 100644
index 000000000000..898a7d704880
--- /dev/null
+++ b/dev-haskell/aeson-pretty/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name='lib-only'>don't build 'aeson-pretty' executable.</flag>
+ </use>
+ <longdescription>
+ A JSON pretty-printing library compatible with aeson as well as
+ a command-line tool to improve readabilty of streams of JSON data.
+
+ The /library/ provides the function &quot;encodePretty&quot;. It is a drop-in
+ replacement for aeson&#39;s &quot;encode&quot; function, producing JSON-ByteStrings for
+ human readers.
+
+ The /command-line tool/ reads JSON from stdin and writes prettified JSON
+ to stdout. It also offers a complementary &quot;compact&quot;-mode, essentially the
+ opposite of pretty-printing. If you specify @-flib-only@ like this
+
+ &gt; cabal install -flib-only aeson-pretty
+
+ the command-line tool will NOT be installed.
+ </longdescription>
+</pkgmetadata>