summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-08-25 05:02:39 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-08-25 05:02:39 +0000
commit089035b38887a1b080661432ce212cc48faa1a12 (patch)
tree6f0d69c78761c29cc179ce79d606bac115071a2f /dev-haskell/binary
parent[dev-haskell/aeson] 0.6.1.0 (diff)
downloadgentoo-2-089035b38887a1b080661432ce212cc48faa1a12.tar.gz
gentoo-2-089035b38887a1b080661432ce212cc48faa1a12.tar.bz2
gentoo-2-089035b38887a1b080661432ce212cc48faa1a12.zip
dev-haskell/binary: bump up to 0.7.1.0
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell/binary')
-rw-r--r--dev-haskell/binary/ChangeLog7
-rw-r--r--dev-haskell/binary/binary-0.7.1.0.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-haskell/binary/ChangeLog b/dev-haskell/binary/ChangeLog
index 3ce6914c339d..e6c5cb21b98a 100644
--- a/dev-haskell/binary/ChangeLog
+++ b/dev-haskell/binary/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/binary
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/binary/ChangeLog,v 1.32 2013/03/31 10:02:19 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/binary/ChangeLog,v 1.33 2013/08/25 05:02:39 qnikst Exp $
+
+*binary-0.7.1.0 (25 Aug 2013)
+
+ 25 Aug 2013; Alexander Vershilov <qnikst@gentoo.org> +binary-0.7.1.0.ebuild:
+ dev-haskell/binary: bump up to 0.7.1.0
31 Mar 2013; Agostino Sarubbo <ago@gentoo.org> binary-0.5.1.1.ebuild:
Stable for sparc, wrt bug #456486
diff --git a/dev-haskell/binary/binary-0.7.1.0.ebuild b/dev-haskell/binary/binary-0.7.1.0.ebuild
new file mode 100644
index 000000000000..1758c02d1822
--- /dev/null
+++ b/dev-haskell/binary/binary-0.7.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/binary/binary-0.7.1.0.ebuild,v 1.1 2013/08/25 05:02:39 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Binary serialisation for Haskell values using lazy ByteStrings"
+HOMEPAGE="https://github.com/kolmodin/binary"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.5
+ >=dev-haskell/random-1.0.1.0
+ dev-haskell/test-framework
+ >=dev-haskell/test-framework-quickcheck2-0.3
+ )"
+
+src_prepare() {
+ if has_version ">=dev-lang/ghc-7.7"; then
+ sed -e '/test-suite read-write-file/,/ghc-options: -Wall/d' \
+ -i "${S}/${PN}.cabal" \
+ || die "Could not remove test suite for ghc 7.7"
+ fi
+}