summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2008-10-19 17:42:40 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2008-10-19 17:42:40 +0000
commit48c8cdef9e66b4ec8714cd0f48ac9d1424b47476 (patch)
treefffe7419035c7c2a225be5915a8c199301836244 /dev-haskell/cabal
parentActually commit last change, oops (diff)
downloadgentoo-2-48c8cdef9e66b4ec8714cd0f48ac9d1424b47476.tar.gz
gentoo-2-48c8cdef9e66b4ec8714cd0f48ac9d1424b47476.tar.bz2
gentoo-2-48c8cdef9e66b4ec8714cd0f48ac9d1424b47476.zip
Add dev-haskell/cabal-1.6.0.1, newest version
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-haskell/cabal')
-rw-r--r--dev-haskell/cabal/ChangeLog8
-rw-r--r--dev-haskell/cabal/cabal-1.6.0.1.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-haskell/cabal/ChangeLog b/dev-haskell/cabal/ChangeLog
index 4ac26bf9dda1..3691425dbcbe 100644
--- a/dev-haskell/cabal/ChangeLog
+++ b/dev-haskell/cabal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/cabal
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/ChangeLog,v 1.43 2008/10/18 18:01:34 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/ChangeLog,v 1.44 2008/10/19 17:42:40 kolmodin Exp $
+
+*cabal-1.6.0.1 (19 Oct 2008)
+
+ 19 Oct 2008; Lennart Kolmodin <kolmodin@gentoo.org> +cabal-1.6.0.1.ebuild:
+ Bump to latest available.
+ We still bundle filepath-1.1.0.0 because of the cyclic dep.
18 Oct 2008; nixnut <nixnut@gentoo.org> cabal-1.2.3.0.ebuild:
Stable on ppc wrt bug 239368
diff --git a/dev-haskell/cabal/cabal-1.6.0.1.ebuild b/dev-haskell/cabal/cabal-1.6.0.1.ebuild
new file mode 100644
index 000000000000..a68d424387cd
--- /dev/null
+++ b/dev-haskell/cabal/cabal-1.6.0.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/cabal-1.6.0.1.ebuild,v 1.1 2008/10/19 17:42:40 kolmodin Exp $
+
+CABAL_FEATURES="bootstrap lib profile"
+inherit haskell-cabal eutils
+
+MY_PN="Cabal"
+MY_P="${MY_PN}-${PV}"
+
+# Resolve cyclic dep between filepath and Cabal by using a private copy of
+# filepath when building Cabal.
+FP_PN=filepath
+FP_PV=1.1.0.0
+FP_P=${FP_PN}-${FP_PV}
+
+
+DESCRIPTION="A framework for packaging Haskell software"
+HOMEPAGE="http://www.haskell.org/cabal/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz
+ http://hackage.haskell.org/packages/archive/${FP_PN}/${FP_PV}/${FP_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-lang/ghc-6.4"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+
+ # We're using the private copy of filepath:
+ sed -i -e 's/Build-Depends: filepath >= 1 && < 1.2//' \
+ -e '/Other-Modules:/a \
+ System.FilePath System.FilePath.Posix System.FilePath.Windows' \
+ "${S}/Cabal.cabal"
+ # Note: do not replace spaces with tabs on the line above, it'll break
+ # things. You'll just have to put up with the repoman warning.
+
+ echo " Hs-Source-Dirs: ., ../${FP_P}" >> "${S}/Cabal.cabal"
+}
+
+src_compile() {
+ if ! cabal-is-dummy-lib; then
+ einfo "Bootstrapping Cabal..."
+ $(ghc-getghc) -i -i. -i"${WORKDIR}/${FP_P}" -cpp --make Setup.hs \
+ -o setup || die "compiling Setup.hs failed"
+ cabal-configure
+ cabal-build
+ fi
+}
+
+src_install() {
+ cabal_src_install
+}