summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2007-03-17 11:47:47 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2007-03-17 11:47:47 +0000
commit8d60cf0ced437ae9f53131527e839bf388a6f3ad (patch)
tree3def6924e4ecf90ab2e70decbe35e5ddd4369a93 /dev-haskell/fgl/fgl-5.3.ebuild
parentamd64 stable, bug 166998 (diff)
downloadgentoo-2-8d60cf0ced437ae9f53131527e839bf388a6f3ad.tar.gz
gentoo-2-8d60cf0ced437ae9f53131527e839bf388a6f3ad.tar.bz2
gentoo-2-8d60cf0ced437ae9f53131527e839bf388a6f3ad.zip
Add modular lib to ghc 6.6. See bug 151012
(Portage version: 2.1.2-r5)
Diffstat (limited to 'dev-haskell/fgl/fgl-5.3.ebuild')
-rw-r--r--dev-haskell/fgl/fgl-5.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-haskell/fgl/fgl-5.3.ebuild b/dev-haskell/fgl/fgl-5.3.ebuild
new file mode 100644
index 000000000000..9f4458b92b6b
--- /dev/null
+++ b/dev-haskell/fgl/fgl-5.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/fgl/fgl-5.3.ebuild,v 1.1 2007/03/17 11:47:47 kolmodin Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal
+
+GHC_PV=6.6
+
+DESCRIPTION="A functional graph library for Haskell."
+HOMEPAGE="http://haskell.org/ghc/"
+SRC_URI="http://www.haskell.org/ghc/dist/${GHC_PV}/ghc-${GHC_PV}-src-extralibs.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=virtual/ghc-6.6
+ dev-haskell/mtl"
+
+S="${WORKDIR}/ghc-${GHC_PV}/libraries/${PN}"