summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2010-03-30 22:22:53 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2010-03-30 22:22:53 +0000
commitb0afaf409fd647b0006866a25d8c60bfdf02c836 (patch)
tree939e7d8a57b87fbaf7eca794017ad01e9fae7923 /dev-haskell/haddock
parentWhen using dummy haskell libraries, there is no test suite. (diff)
downloadgentoo-2-b0afaf409fd647b0006866a25d8c60bfdf02c836.tar.gz
gentoo-2-b0afaf409fd647b0006866a25d8c60bfdf02c836.tar.bz2
gentoo-2-b0afaf409fd647b0006866a25d8c60bfdf02c836.zip
Patched dev-haskell/haddock-2.4.2 to work with both dev-haskell/cabal-1.6* and cabal-1.8*.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/haddock')
-rw-r--r--dev-haskell/haddock/ChangeLog10
-rw-r--r--dev-haskell/haddock/files/haddock-2.4.2-Setup.hs12
-rw-r--r--dev-haskell/haddock/haddock-2.4.1.ebuild6
-rw-r--r--dev-haskell/haddock/haddock-2.4.2.ebuild4
4 files changed, 23 insertions, 9 deletions
diff --git a/dev-haskell/haddock/ChangeLog b/dev-haskell/haddock/ChangeLog
index 34d327037c85..83899df4e773 100644
--- a/dev-haskell/haddock/ChangeLog
+++ b/dev-haskell/haddock/ChangeLog
@@ -1,9 +1,15 @@
# ChangeLog for dev-haskell/haddock
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/ChangeLog,v 1.69 2010/03/30 21:46:56 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/ChangeLog,v 1.70 2010/03/30 22:22:52 kolmodin Exp $
+
+ 30 Mar 2010; Lennart Kolmodin <kolmodin@gentoo.org> haddock-2.4.1.ebuild,
+ haddock-2.4.2.ebuild, files/haddock-2.4.2-Setup.hs:
+ Change deps of 2.4.1 to only work with cabal-1.6*.
+ For 2.4.2 we've patched so it workes with both cabal-1.6 and cabal-1.8.
+ See bug #302489.
30 Mar 2010; Lennart Kolmodin <kolmodin@gentoo.org> haddock-2.4.2.ebuild:
- Change deps of 2.4.2, it only builds with cabal-1.6*
+ Change deps of 2.4.2, it only builds with cabal-1.6*. See bug #302489.
28 Mar 2010; Lennart Kolmodin <kolmodin@gentoo.org> haddock-2.6.0.ebuild:
Add dependencies alex and happy, see bug #302397.
diff --git a/dev-haskell/haddock/files/haddock-2.4.2-Setup.hs b/dev-haskell/haddock/files/haddock-2.4.2-Setup.hs
index 31ee04eb8168..19b2c5ba3a5e 100644
--- a/dev-haskell/haddock/files/haddock-2.4.2-Setup.hs
+++ b/dev-haskell/haddock/files/haddock-2.4.2-Setup.hs
@@ -1,6 +1,8 @@
{-
Setup.hs: based on code from ghc-paths of Simon Marlow
Fixed to not use the .buildinfo, and use -Dfoo flags for both libraries and executables
+
+Modified 2010-03-30 to work with both cabal-1.6 and cabal-1.8. See bug #302489.
-}
import Distribution.Simple
import Distribution.Simple.Setup
@@ -20,12 +22,18 @@ main = defaultMainWithHooks simpleUserHooks {
confHook = myCustomConfHook
}
where
+{- With cabal-1.6, myCustomConfHook has this type
myCustomConfHook :: (Either GenericPackageDescription PackageDescription, HookedBuildInfo)
-> ConfigFlags
-> IO LocalBuildInfo
- myCustomConfHook egpdpdhbi flags = do
+ With cabal-1.8, myCustomConfHook has this type
+ myCustomConfHook :: (GenericPackageDescription, HookedBuildInfo)
+
+So, better to not specify the type at all as we're not required to...
+-}
+ myCustomConfHook gpd flags = do
-- get the default LBI
- lbi <- confHook simpleUserHooks egpdpdhbi flags
+ lbi <- confHook simpleUserHooks gpd flags
let programs = withPrograms lbi
libdir_ <- rawSystemProgramStdoutConf (fromFlag (configVerbosity flags))
diff --git a/dev-haskell/haddock/haddock-2.4.1.ebuild b/dev-haskell/haddock/haddock-2.4.1.ebuild
index 99649dc3c452..095e66712d91 100644
--- a/dev-haskell/haddock/haddock-2.4.1.ebuild
+++ b/dev-haskell/haddock/haddock-2.4.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-2.4.1.ebuild,v 1.6 2009/08/30 09:12:54 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-2.4.1.ebuild,v 1.7 2010/03/30 22:22:52 kolmodin Exp $
CABAL_FEATURES="bin lib"
# don't enable profiling as the 'ghc' package is not built with profiling
@@ -33,7 +33,7 @@ IUSE="doc"
RDEPEND=">=dev-lang/ghc-6.8.2"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6
+ =dev-haskell/cabal-1.6*
doc? ( ~app-text/docbook-xml-dtd-4.2
app-text/docbook-xsl-stylesheets
>=dev-libs/libxslt-1.1.2 )"
diff --git a/dev-haskell/haddock/haddock-2.4.2.ebuild b/dev-haskell/haddock/haddock-2.4.2.ebuild
index 6ef9fc69794a..9b2209a54a94 100644
--- a/dev-haskell/haddock/haddock-2.4.2.ebuild
+++ b/dev-haskell/haddock/haddock-2.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-2.4.2.ebuild,v 1.7 2010/03/30 21:46:56 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-2.4.2.ebuild,v 1.8 2010/03/30 22:22:52 kolmodin Exp $
CABAL_FEATURES="bin lib"
# don't enable profiling as the 'ghc' package is not built with profiling
@@ -31,7 +31,7 @@ IUSE="doc"
# doesn't build with ghc-6.10.1, but that has never been in portage
RDEPEND="=dev-lang/ghc-6.10*"
DEPEND="${RDEPEND}
- =dev-haskell/cabal-1.6*
+ >=dev-haskell/cabal-1.6
doc? ( ~app-text/docbook-xml-dtd-4.2
app-text/docbook-xsl-stylesheets
>=dev-libs/libxslt-1.1.2 )"