summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2010-05-23 21:47:18 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2010-05-23 21:47:18 +0000
commitdcbc55a0616908fea0913b5a3fa027b39240fa04 (patch)
treed383d359cf05957b59c16283762cf9643af098c9 /dev-haskell/hashed-storage
parentUpdate i18n to 0.3.7, add (realistic) REE18 and JRuby support. (diff)
downloadgentoo-2-dcbc55a0616908fea0913b5a3fa027b39240fa04.tar.gz
gentoo-2-dcbc55a0616908fea0913b5a3fa027b39240fa04.tar.bz2
gentoo-2-dcbc55a0616908fea0913b5a3fa027b39240fa04.zip
Version bump dev-haskell/hashed-storage to 0.4.13
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/hashed-storage')
-rw-r--r--dev-haskell/hashed-storage/ChangeLog8
-rw-r--r--dev-haskell/hashed-storage/hashed-storage-0.4.13.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-haskell/hashed-storage/ChangeLog b/dev-haskell/hashed-storage/ChangeLog
index 26acbc15552a..d66e4015a38e 100644
--- a/dev-haskell/hashed-storage/ChangeLog
+++ b/dev-haskell/hashed-storage/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/hashed-storage
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashed-storage/ChangeLog,v 1.2 2010/03/28 17:31:50 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashed-storage/ChangeLog,v 1.3 2010/05/23 21:47:18 kolmodin Exp $
+
+*hashed-storage-0.4.13 (23 May 2010)
+
+ 23 May 2010; Lennart Kolmodin <kolmodin@gentoo.org>
+ +hashed-storage-0.4.13.ebuild:
+ Version bump.
*hashed-storage-0.4.10 (28 Mar 2010)
diff --git a/dev-haskell/hashed-storage/hashed-storage-0.4.13.ebuild b/dev-haskell/hashed-storage/hashed-storage-0.4.13.ebuild
new file mode 100644
index 000000000000..b4db4e35fda6
--- /dev/null
+++ b/dev-haskell/hashed-storage/hashed-storage-0.4.13.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashed-storage/hashed-storage-0.4.13.ebuild,v 1.1 2010/05/23 21:47:18 kolmodin Exp $
+
+EAPI=2
+
+CABAL_FEATURES="bin lib profile haddock"
+inherit haskell-cabal
+
+DESCRIPTION="Hashed file storage support code."
+HOMEPAGE="http://hackage.haskell.org/cgi-bin/hackage-scripts/package/hashed-storage"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-lang/ghc-6.10
+ dev-haskell/binary
+ dev-haskell/dataenc
+ =dev-haskell/mmap-0.4*
+ dev-haskell/mtl
+ dev-haskell/zlib"
+DEPEND=">=dev-haskell/cabal-1.6
+ test? (
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2
+ dev-haskell/zip-archive
+ )
+ ${RDEPEND}"
+
+src_configure() {
+ cabal_src_configure $(cabal_flag test)
+}
+
+src_install() {
+ cabal_src_install
+
+ rm "${D}/usr/bin/hashed-storage-test" 2> /dev/null
+ rmdir "${D}/usr/bin" 2> /dev/null # only if empty
+}