summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-06-20 06:14:27 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-06-20 06:14:27 +0000
commitb721007cd98c477b551b0c58cf8297bba3beff24 (patch)
treea2be22d60a6e2927c15d09e9a0e91a7455b0fb97 /dev-haskell/hstringtemplate/hstringtemplate-0.7.1.ebuild
parentadd 0.6.1.4 due to #473858 (diff)
downloadgentoo-2-b721007cd98c477b551b0c58cf8297bba3beff24.tar.gz
gentoo-2-b721007cd98c477b551b0c58cf8297bba3beff24.tar.bz2
gentoo-2-b721007cd98c477b551b0c58cf8297bba3beff24.zip
add 0.7.1 due to #473858
(Portage version: 2.2.0_alpha181/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell/hstringtemplate/hstringtemplate-0.7.1.ebuild')
-rw-r--r--dev-haskell/hstringtemplate/hstringtemplate-0.7.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/hstringtemplate/hstringtemplate-0.7.1.ebuild b/dev-haskell/hstringtemplate/hstringtemplate-0.7.1.ebuild
new file mode 100644
index 000000000000..365fe5c47f6e
--- /dev/null
+++ b/dev-haskell/hstringtemplate/hstringtemplate-0.7.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hstringtemplate/hstringtemplate-0.7.1.ebuild,v 1.1 2013/06/20 06:14:27 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HStringTemplate"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="StringTemplate implementation in Haskell."
+HOMEPAGE="http://hackage.haskell.org/package/HStringTemplate"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+quasi-quotation syb-with-class"
+
+RDEPEND="dev-haskell/blaze-builder:=[profile?]
+ dev-haskell/deepseq:=[profile?]
+ <dev-haskell/parsec-4:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ dev-haskell/void:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ quasi-quotation? ( dev-haskell/mtl:=[profile?]
+ )
+ syb-with-class? ( dev-haskell/syb-with-class:=[profile?]
+ )"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag quasi-quotation quasi-quotation) \
+ $(cabal_flag syb-with-class syb-with-class)
+}