summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-12-23 08:40:56 +0000
committerMark Wright <gienah@gentoo.org>2014-12-23 08:40:56 +0000
commit8c7c73a5649617df589baf7383940052cf0c1637 (patch)
treeb7361fa5bddefe1250188df2a7975c02fc83b2d8 /dev-haskell/juicypixels
parentVersion bump (bug #533366). (diff)
downloadgentoo-2-8c7c73a5649617df589baf7383940052cf0c1637.tar.gz
gentoo-2-8c7c73a5649617df589baf7383940052cf0c1637.tar.bz2
gentoo-2-8c7c73a5649617df589baf7383940052cf0c1637.zip
Bump juicypixels to 3.2
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/juicypixels')
-rw-r--r--dev-haskell/juicypixels/ChangeLog7
-rw-r--r--dev-haskell/juicypixels/juicypixels-3.2.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-haskell/juicypixels/ChangeLog b/dev-haskell/juicypixels/ChangeLog
index 47be1dbd48c4..85d249b6d308 100644
--- a/dev-haskell/juicypixels/ChangeLog
+++ b/dev-haskell/juicypixels/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/juicypixels
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/juicypixels/ChangeLog,v 1.1 2014/12/13 14:09:22 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/juicypixels/ChangeLog,v 1.2 2014/12/23 08:40:56 gienah Exp $
+
+*juicypixels-3.2 (23 Dec 2014)
+
+ 23 Dec 2014; Mark Wright <gienah@gentoo.org> +juicypixels-3.2.ebuild:
+ Bump juicypixels to 3.2
*juicypixels-3.1.7.1 (13 Dec 2014)
diff --git a/dev-haskell/juicypixels/juicypixels-3.2.ebuild b/dev-haskell/juicypixels/juicypixels-3.2.ebuild
new file mode 100644
index 000000000000..c7aa40433471
--- /dev/null
+++ b/dev-haskell/juicypixels/juicypixels-3.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/juicypixels/juicypixels-3.2.ebuild,v 1.1 2014/12/23 08:40:56 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="JuicyPixels"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Picture loading/serialization (in png, jpeg, bitmap, gif, tga, tiff and radiance)"
+HOMEPAGE="https://github.com/Twinside/Juicy.Pixels"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="mmap"
+
+RDEPEND=">=dev-haskell/binary-0.5:=[profile?] <dev-haskell/binary-0.8:=[profile?]
+ >=dev-haskell/mtl-1.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/primitive-0.4:=[profile?] <dev-haskell/primitive-0.6:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?] <dev-haskell/vector-0.11:=[profile?]
+ >=dev-haskell/zlib-0.5.3.1:=[profile?] <dev-haskell/zlib-0.6:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ mmap? ( dev-haskell/mmap:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag mmap mmap)
+}