summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-08-25 06:31:47 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-08-25 06:31:47 +0000
commit539e2c220b753143b78fe8f619220b2dd951c86d (patch)
treed5f72daac8dc2b146130cad481911abdc08f0095 /dev-haskell/language-haskell-extract
parentmanifests (diff)
downloadgentoo-2-539e2c220b753143b78fe8f619220b2dd951c86d.tar.gz
gentoo-2-539e2c220b753143b78fe8f619220b2dd951c86d.tar.bz2
gentoo-2-539e2c220b753143b78fe8f619220b2dd951c86d.zip
dev-haskell/language-haskell-extract: 0.2.4
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell/language-haskell-extract')
-rw-r--r--dev-haskell/language-haskell-extract/ChangeLog9
-rw-r--r--dev-haskell/language-haskell-extract/language-haskell-extract-0.2.4.ebuild24
-rw-r--r--dev-haskell/language-haskell-extract/metadata.xml44
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-haskell/language-haskell-extract/ChangeLog b/dev-haskell/language-haskell-extract/ChangeLog
new file mode 100644
index 000000000000..95a090cf95e9
--- /dev/null
+++ b/dev-haskell/language-haskell-extract/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/language-haskell-extract
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/language-haskell-extract/ChangeLog,v 1.1 2013/08/25 06:31:47 qnikst Exp $
+
+*language-haskell-extract-0.2.4 (25 Aug 2013)
+
+ 25 Aug 2013; Alexander Vershilov <qnikst@gentoo.org>
+ +language-haskell-extract-0.2.4.ebuild, +metadata.xml:
+ dev-haskell/language-haskell-extract: 0.2.4
diff --git a/dev-haskell/language-haskell-extract/language-haskell-extract-0.2.4.ebuild b/dev-haskell/language-haskell-extract/language-haskell-extract-0.2.4.ebuild
new file mode 100644
index 000000000000..5aea3b6fc6b3
--- /dev/null
+++ b/dev-haskell/language-haskell-extract/language-haskell-extract-0.2.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/language-haskell-extract/language-haskell-extract-0.2.4.ebuild,v 1.1 2013/08/25 06:31:47 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Module to automatically extract functions from the local code."
+HOMEPAGE="http://github.com/finnsson/template-helper"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/regex-posix:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
diff --git a/dev-haskell/language-haskell-extract/metadata.xml b/dev-haskell/language-haskell-extract/metadata.xml
new file mode 100644
index 000000000000..d4b569f4f329
--- /dev/null
+++ b/dev-haskell/language-haskell-extract/metadata.xml
@@ -0,0 +1,44 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ @language-haskell-extract@ contains some useful helper functions on top of Template Haskell.
+
+ @functionExtractor@ extracts all functions after a regexp-pattern.
+
+ &gt; foo = &quot;test&quot;
+ &gt; boo = &quot;testing&quot;
+ &gt; bar = $(functionExtractor &quot;oo$&quot;)
+
+ will automagically extract the functions ending with @oo@ such as
+
+ &gt; bar = [(&quot;foo&quot;,foo), (&quot;boo&quot;,boo)]
+
+ This can be useful if you wish to extract all functions beginning with test (for a test-framework)
+ or all functions beginning with wc (for a web service).
+
+ @functionExtractorMap@ works like @functionsExtractor@ but applies a function over all function-pairs.
+
+ This functions is useful if the common return type of the functions is a type class.
+
+ Example:
+
+ &gt; secondTypeclassTest =
+ &gt; do let expected = [&quot;45&quot;, &quot;88.8&quot;, &quot;\&quot;hej\&quot;&quot;]
+ &gt; actual = $(functionExtractorMap &quot;^tc&quot; [|\n f -&gt; show f|] )
+ &gt; expected @=? actual
+ &gt;
+ &gt; tcInt :: Integer
+ &gt; tcInt = 45
+ &gt;
+ &gt; tcDouble :: Double
+ &gt; tcDouble = 88.8
+ &gt;
+ &gt; tcString :: String
+ &gt; tcString = &quot;hej&quot;
+ </longdescription>
+</pkgmetadata>