summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2004-04-13 12:42:14 +0000
committerAndres Loeh <kosmikus@gentoo.org>2004-04-13 12:42:14 +0000
commitbbe04c2e2d398e2eae6459d7fe0fa92e03a76f76 (patch)
tree05140ae2be5c87e6d98919d135ca5871885c3eeb /dev-haskell/lhs2tex/lhs2tex-1.10_pre.ebuild
parentUpdated SRC_URI. (Manifest recommit) (diff)
downloadgentoo-2-bbe04c2e2d398e2eae6459d7fe0fa92e03a76f76.tar.gz
gentoo-2-bbe04c2e2d398e2eae6459d7fe0fa92e03a76f76.tar.bz2
gentoo-2-bbe04c2e2d398e2eae6459d7fe0fa92e03a76f76.zip
new lhs2tex version
Diffstat (limited to 'dev-haskell/lhs2tex/lhs2tex-1.10_pre.ebuild')
-rw-r--r--dev-haskell/lhs2tex/lhs2tex-1.10_pre.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/lhs2tex/lhs2tex-1.10_pre.ebuild b/dev-haskell/lhs2tex/lhs2tex-1.10_pre.ebuild
new file mode 100644
index 000000000000..1903727ef6a2
--- /dev/null
+++ b/dev-haskell/lhs2tex/lhs2tex-1.10_pre.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/lhs2tex/lhs2tex-1.10_pre.ebuild,v 1.1 2004/04/13 12:42:14 kosmikus Exp $
+
+SRC_URI="http://www.cs.uu.nl/~andres/lhs2tex/${PN}-1.10pre.tar.bz2"
+
+IUSE="doc"
+
+DESCRIPTION="Preprocessor for typesetting Haskell sources with LaTeX"
+HOMEPAGE="http://www.cs.uu.nl/~andres/lhs2tex"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+S="${WORKDIR}/${PN}-1.10pre"
+
+DEPEND=">=dev-tex/polytable-0.7.2
+ >=virtual/ghc-5.04
+ doc? ( dev-lang/hugs98 )
+ virtual/tetex"
+
+src_compile() {
+ # polytable is installed separately
+ econf --disable-polytable
+ # if doc is set, we build the documentation instead
+ # of using the prebuilt file
+ use doc && rm doc/Guide2.dontbuild
+ # emake doesn't work because lhs2TeX interactive calls are
+ # broken
+ make || die "make failed"
+}
+
+src_install () {
+ DESTDIR="${D}" make install || die "installation failed"
+ dodoc doc/Guide2.pdf
+ dodoc INSTALL RELEASE
+}