summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-07-09 12:40:29 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-07-09 12:40:29 +0000
commit77527c0952b5fa880149e788aae1d1d139912518 (patch)
treec323a096ea79facdbb07f38c04bc0586755fa810 /dev-haskell/openal/openal-1.2.ebuild
parentInitial versions. (diff)
downloadgentoo-2-77527c0952b5fa880149e788aae1d1d139912518.tar.gz
gentoo-2-77527c0952b5fa880149e788aae1d1d139912518.tar.bz2
gentoo-2-77527c0952b5fa880149e788aae1d1d139912518.zip
Initial versions.
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-haskell/openal/openal-1.2.ebuild')
-rw-r--r--dev-haskell/openal/openal-1.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/openal/openal-1.2.ebuild b/dev-haskell/openal/openal-1.2.ebuild
new file mode 100644
index 000000000000..f9004d0d4b95
--- /dev/null
+++ b/dev-haskell/openal/openal-1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/openal/openal-1.2.ebuild,v 1.1 2007/07/09 12:40:29 dcoutts Exp $
+
+inherit ghc-package flag-o-matic
+
+DESCRIPTION="A Haskell binding to the OpenAL cross-platform 3D audio API"
+HOMEPAGE="http://haskell.org/ghc/"
+SRC_URI=""
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="=dev-lang/ghc-6.4*"
+
+# GHC 6.4.1 provides openal-1.0
+# GHC 6.4.2 provides openal-1.2
+# We treat them as the same version, openal-1.2
+
+pkg_setup () {
+ ghc-package_pkg_setup
+ if ! built_with_use virtual/ghc openal; then
+ eerror "This library has to be provided by ghc."
+ eerror "Please re-emerge ghc with USE=\"openal\""
+ die "dev-haskell/openal requires ghc to be built with USE=\"openal\""
+ fi
+ einfo "This library is already provided by ghc. This ebuild does nothing."
+}
+
+src_install () {
+ dodir "$(ghc-libdir)"
+ touch "${D}/$(ghc-libdir)/.${P}.ghc-updater"
+}