summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-04-03 11:52:33 +0000
committerMark Wright <gienah@gentoo.org>2013-04-03 11:52:33 +0000
commitfdab1416effe11b4fbe15a7bdad9544804fdc0fd (patch)
treeafd620a8f01108c01e0806af2e8b76f7f5b2ebe5 /dev-haskell/opengl
parentBump glut to 2.4.0.0 (diff)
downloadgentoo-2-fdab1416effe11b4fbe15a7bdad9544804fdc0fd.tar.gz
gentoo-2-fdab1416effe11b4fbe15a7bdad9544804fdc0fd.tar.bz2
gentoo-2-fdab1416effe11b4fbe15a7bdad9544804fdc0fd.zip
Bump opengl to 2.8.0.0
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/opengl')
-rw-r--r--dev-haskell/opengl/ChangeLog10
-rw-r--r--dev-haskell/opengl/metadata.xml19
-rw-r--r--dev-haskell/opengl/opengl-2.8.0.0.ebuild30
3 files changed, 53 insertions, 6 deletions
diff --git a/dev-haskell/opengl/ChangeLog b/dev-haskell/opengl/ChangeLog
index e49225da50bf..d3d217d42206 100644
--- a/dev-haskell/opengl/ChangeLog
+++ b/dev-haskell/opengl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/opengl
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/opengl/ChangeLog,v 1.15 2012/11/18 12:53:31 gienah Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/opengl/ChangeLog,v 1.16 2013/04/03 11:52:33 gienah Exp $
+
+*opengl-2.8.0.0 (03 Apr 2013)
+
+ 03 Apr 2013; Mark Wright <gienah@gentoo.org> +opengl-2.8.0.0.ebuild,
+ metadata.xml:
+ Bump opengl to 2.8.0.0
*opengl-2.6.0.1 (18 Nov 2012)
diff --git a/dev-haskell/opengl/metadata.xml b/dev-haskell/opengl/metadata.xml
index 8c66906af531..36560efdd980 100644
--- a/dev-haskell/opengl/metadata.xml
+++ b/dev-haskell/opengl/metadata.xml
@@ -1,8 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>haskell</herd>
-<maintainer>
- <email>haskell@gentoo.org</email>
-</maintainer>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ A Haskell binding for the OpenGL graphics system (GL, version 3.2) and its
+ accompanying utility library (GLU, version 1.3).
+
+ OpenGL is the industry&#39;s most widely used and supported 2D and 3D graphics
+ application programming interface (API), incorporating a broad set of
+ rendering, texture mapping, special effects, and other powerful visualization
+ functions. For more information about OpenGL and its various extensions,
+ please see &lt;http://www.opengl.org/&gt;
+ and &lt;http://www.opengl.org/registry/&gt;.
+ </longdescription>
</pkgmetadata>
diff --git a/dev-haskell/opengl/opengl-2.8.0.0.ebuild b/dev-haskell/opengl/opengl-2.8.0.0.ebuild
new file mode 100644
index 000000000000..0c8cc8402bea
--- /dev/null
+++ b/dev-haskell/opengl/opengl-2.8.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/opengl/opengl-2.8.0.0.ebuild,v 1.1 2013/04/03 11:52:33 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="OpenGL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A binding for the OpenGL graphics system"
+HOMEPAGE="http://www.haskell.org/haskellwiki/Opengl"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/gluraw-1.1.0.0:=[profile?]
+ >=dev-haskell/openglraw-1.3.0.0:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+S="${WORKDIR}/${MY_P}"