summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2010-03-28 15:36:44 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2010-03-28 15:36:44 +0000
commitffa94d645fd3c126bff852e7e50de018037e4160 (patch)
tree22a8d13528ce6f8a15e41593496ce86efe45dbb2 /dev-haskell/quickcheck
parentDisable zlib, bug #311241 (diff)
downloadgentoo-2-ffa94d645fd3c126bff852e7e50de018037e4160.tar.gz
gentoo-2-ffa94d645fd3c126bff852e7e50de018037e4160.tar.bz2
gentoo-2-ffa94d645fd3c126bff852e7e50de018037e4160.zip
Bump dev-haskell/quickcheck to version 2.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/quickcheck')
-rw-r--r--dev-haskell/quickcheck/ChangeLog11
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.1.0.3.ebuild31
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-haskell/quickcheck/ChangeLog b/dev-haskell/quickcheck/ChangeLog
index b18e9e8bc67e..25039db68483 100644
--- a/dev-haskell/quickcheck/ChangeLog
+++ b/dev-haskell/quickcheck/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-haskell/quickcheck
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/ChangeLog,v 1.38 2010/03/14 18:42:10 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/ChangeLog,v 1.39 2010/03/28 15:36:44 kolmodin Exp $
+
+*quickcheck-2.1.0.3 (28 Mar 2010)
+
+ 28 Mar 2010; Lennart Kolmodin <kolmodin@gentoo.org>
+ +quickcheck-2.1.0.3.ebuild:
+ Bump to first version of the 2.x series.
+ This version requires extensible-exceptions, which means we have to depend
+ on >=ghc-6.10 and unfortunately drop some arches until we get proper ghc
+ support :(
14 Mar 2010; Lennart Kolmodin <kolmodin@gentoo.org> quickcheck-1.0.ebuild,
quickcheck-1.0.1.ebuild, quickcheck-1.1.0.0.ebuild,
diff --git a/dev-haskell/quickcheck/quickcheck-2.1.0.3.ebuild b/dev-haskell/quickcheck/quickcheck-2.1.0.3.ebuild
new file mode 100644
index 000000000000..3110203d89e3
--- /dev/null
+++ b/dev-haskell/quickcheck/quickcheck-2.1.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/quickcheck-2.1.0.3.ebuild,v 1.1 2010/03/28 15:36:44 kolmodin Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal
+
+MY_PN="QuickCheck"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Automatic testing of Haskell programs"
+HOMEPAGE="http://www.cs.chalmers.se/~koen"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ghc-6.10
+ >=dev-haskell/cabal-1.2
+ dev-haskell/mtl"
+
+# would work with ghc 6.8 (6.6 too?) too if we added this dep
+# dev-haskell/extensible-exceptions. however, we'd prefer not to add more core
+# packages, as we don't want them upgradeable (leads to trouble).
+#
+# this means that we can only support the architectures which has >=ghc-6.10
+# and unfortunately have to drop the others until we get proper ghc support :(
+
+S="${WORKDIR}/${MY_P}"