summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-09-13 10:04:58 +0000
committerMark Wright <gienah@gentoo.org>2013-09-13 10:04:58 +0000
commit48b5a00352ad45692ad16fb02361b55389f22755 (patch)
tree67de6a1c40a6b6ca66f23766d4c2554e80903e70 /dev-haskell/tasty/tasty-0.2.ebuild
parentAdd smallcheck (diff)
downloadgentoo-2-48b5a00352ad45692ad16fb02361b55389f22755.tar.gz
gentoo-2-48b5a00352ad45692ad16fb02361b55389f22755.tar.bz2
gentoo-2-48b5a00352ad45692ad16fb02361b55389f22755.zip
Add tasty
(Portage version: 2.2.4/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/tasty/tasty-0.2.ebuild')
-rw-r--r--dev-haskell/tasty/tasty-0.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/tasty/tasty-0.2.ebuild b/dev-haskell/tasty/tasty-0.2.ebuild
new file mode 100644
index 000000000000..efb134479c4a
--- /dev/null
+++ b/dev-haskell/tasty/tasty-0.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tasty/tasty-0.2.ebuild,v 1.1 2013/09/13 10:04:58 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Modern and extensible testing framework"
+HOMEPAGE="http://hackage.haskell.org/package/tasty"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+colors"
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-haskell/optparse-applicative-0.5:=[profile?]
+ dev-haskell/regex-posix:=[profile?]
+ dev-haskell/stm:=[profile?]
+ dev-haskell/tagged:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ colors? ( dev-haskell/ansi-terminal:=[profile?]
+ )"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag colors colors)
+}