summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-08-26 11:50:12 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-08-26 11:50:12 +0000
commit078a15a46930e7caa494477ef963658c89b05321 (patch)
tree25133945e2a5791b7e04a0fcf0a9c648d4c4454c /dev-haskell/yesod-routes
parentBump (diff)
downloadgentoo-2-078a15a46930e7caa494477ef963658c89b05321.tar.gz
gentoo-2-078a15a46930e7caa494477ef963658c89b05321.tar.bz2
gentoo-2-078a15a46930e7caa494477ef963658c89b05321.zip
dev-haskell/yesod-routes: initial layout
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell/yesod-routes')
-rw-r--r--dev-haskell/yesod-routes/ChangeLog12
-rw-r--r--dev-haskell/yesod-routes/metadata.xml11
-rw-r--r--dev-haskell/yesod-routes/yesod-routes-1.1.2.ebuild31
-rw-r--r--dev-haskell/yesod-routes/yesod-routes-1.2.0.1.ebuild31
-rw-r--r--dev-haskell/yesod-routes/yesod-routes-1.2.0.ebuild31
5 files changed, 116 insertions, 0 deletions
diff --git a/dev-haskell/yesod-routes/ChangeLog b/dev-haskell/yesod-routes/ChangeLog
new file mode 100644
index 000000000000..41a651566633
--- /dev/null
+++ b/dev-haskell/yesod-routes/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-haskell/yesod-routes
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/yesod-routes/ChangeLog,v 1.1 2013/08/26 11:50:12 qnikst Exp $
+
+*yesod-routes-1.2.0 (26 Aug 2013)
+*yesod-routes-1.1.2 (26 Aug 2013)
+*yesod-routes-1.2.0.1 (26 Aug 2013)
+
+ 26 Aug 2013; Alexander Vershilov <qnikst@gentoo.org> +metadata.xml,
+ +yesod-routes-1.1.2.ebuild, +yesod-routes-1.2.0.1.ebuild,
+ +yesod-routes-1.2.0.ebuild:
+ dev-haskell/yesod-routes: initial layout
diff --git a/dev-haskell/yesod-routes/metadata.xml b/dev-haskell/yesod-routes/metadata.xml
new file mode 100644
index 000000000000..639878471926
--- /dev/null
+++ b/dev-haskell/yesod-routes/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Provides an efficient routing system, a parser and TH code generation.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/yesod-routes/yesod-routes-1.1.2.ebuild b/dev-haskell/yesod-routes/yesod-routes-1.1.2.ebuild
new file mode 100644
index 000000000000..9bdd153a9fff
--- /dev/null
+++ b/dev-haskell/yesod-routes/yesod-routes-1.1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/yesod-routes/yesod-routes-1.1.2.ebuild,v 1.1 2013/08/26 11:50:12 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient routing for Yesod."
+HOMEPAGE="http://www.yesodweb.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="=dev-haskell/path-pieces-0.1*:=[profile?]
+ >=dev-haskell/text-0.5:=[profile?]
+ <dev-haskell/text-0.12:=[profile?]
+ >=dev-haskell/vector-0.8:=[profile?]
+ <dev-haskell/vector-0.11:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ test? ( >=dev-haskell/hspec-1.3
+ =dev-haskell/hunit-1.2*
+ )
+ >=dev-haskell/cabal-1.8"
diff --git a/dev-haskell/yesod-routes/yesod-routes-1.2.0.1.ebuild b/dev-haskell/yesod-routes/yesod-routes-1.2.0.1.ebuild
new file mode 100644
index 000000000000..93021a7523a6
--- /dev/null
+++ b/dev-haskell/yesod-routes/yesod-routes-1.2.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/yesod-routes/yesod-routes-1.2.0.1.ebuild,v 1.1 2013/08/26 11:50:12 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient routing for Yesod."
+HOMEPAGE="http://www.yesodweb.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="=dev-haskell/path-pieces-0.1*:=[profile?]
+ >=dev-haskell/text-0.5:=[profile?]
+ <dev-haskell/text-0.12:=[profile?]
+ >=dev-haskell/vector-0.8:=[profile?]
+ <dev-haskell/vector-0.11:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ =dev-haskell/hunit-1.2*
+ )"
diff --git a/dev-haskell/yesod-routes/yesod-routes-1.2.0.ebuild b/dev-haskell/yesod-routes/yesod-routes-1.2.0.ebuild
new file mode 100644
index 000000000000..7d45129f6626
--- /dev/null
+++ b/dev-haskell/yesod-routes/yesod-routes-1.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/yesod-routes/yesod-routes-1.2.0.ebuild,v 1.1 2013/08/26 11:50:12 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient routing for Yesod."
+HOMEPAGE="http://www.yesodweb.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="=dev-haskell/path-pieces-0.1*:=[profile?]
+ >=dev-haskell/text-0.5:=[profile?]
+ <dev-haskell/text-0.12:=[profile?]
+ >=dev-haskell/vector-0.8:=[profile?]
+ <dev-haskell/vector-0.11:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ =dev-haskell/hunit-1.2*
+ )"