summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-12-22 21:18:10 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-12-22 21:18:10 +0000
commit30e911d2421bdae12f38da8865abe3e763e445ac (patch)
tree85515cd5697302897412210bec4408c9e6b1e6e1 /dev-haskell
parentVersion bump. (diff)
downloadgentoo-2-30e911d2421bdae12f38da8865abe3e763e445ac.tar.gz
gentoo-2-30e911d2421bdae12f38da8865abe3e763e445ac.tar.bz2
gentoo-2-30e911d2421bdae12f38da8865abe3e763e445ac.zip
Version bump.
(Portage version: 2.2.0_alpha149_p1/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/c2hs/ChangeLog8
-rw-r--r--dev-haskell/c2hs/c2hs-0.16.4.ebuild49
-rw-r--r--dev-haskell/c2hs/files/c2hs-0.16.4-ghc-7.6.patch34
-rw-r--r--dev-haskell/c2hs/metadata.xml16
4 files changed, 102 insertions, 5 deletions
diff --git a/dev-haskell/c2hs/ChangeLog b/dev-haskell/c2hs/ChangeLog
index 5296899743c4..5c3b3dca09a7 100644
--- a/dev-haskell/c2hs/ChangeLog
+++ b/dev-haskell/c2hs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/c2hs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/c2hs/ChangeLog,v 1.54 2012/09/18 06:42:39 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/c2hs/ChangeLog,v 1.55 2012/12/22 21:18:10 slyfox Exp $
+
+*c2hs-0.16.4 (22 Dec 2012)
+
+ 22 Dec 2012; Sergei Trofimovich <slyfox@gentoo.org> +c2hs-0.16.4.ebuild,
+ +files/c2hs-0.16.4-ghc-7.6.patch, metadata.xml:
+ Version bump.
18 Sep 2012; Mark Wright <gienah@gentoo.org> +files/c2hs-0.16.3-ghc-7.6.patch,
c2hs-0.16.3-r1.ebuild:
diff --git a/dev-haskell/c2hs/c2hs-0.16.4.ebuild b/dev-haskell/c2hs/c2hs-0.16.4.ebuild
new file mode 100644
index 000000000000..d4c7f4d1f447
--- /dev/null
+++ b/dev-haskell/c2hs/c2hs-0.16.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/c2hs/c2hs-0.16.4.ebuild,v 1.1 2012/12/22 21:18:10 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="bin"
+inherit base haskell-cabal
+
+DESCRIPTION="C->Haskell FFI tool that gives some cross-language type safety"
+HOMEPAGE="http://www.cse.unsw.edu.au/~chak/haskell/c2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-lang/ghc-6.10.4
+ >=dev-haskell/cabal-1.6
+ >=dev-haskell/language-c-0.3.1.1
+ <dev-haskell/language-c-0.5
+ doc? ( ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets
+ >=dev-libs/libxslt-1.1.2 )"
+RDEPEND="dev-libs/gmp"
+
+PATCHES=("${FILESDIR}/${PN}"-0.16.3-language-c-0.4.patch
+ "${FILESDIR}/${PN}"-0.16.4-ghc-7.6.patch)
+
+src_compile() {
+ cabal_src_compile
+
+ if use doc; then
+ emake -C doc
+ fi
+}
+
+src_install() {
+ cabal_src_install
+
+ doman "${S}/doc/man1/c2hs.1"
+
+ if use doc; then
+ dohtml "${S}/doc/users_guide/"*
+ fi
+}
diff --git a/dev-haskell/c2hs/files/c2hs-0.16.4-ghc-7.6.patch b/dev-haskell/c2hs/files/c2hs-0.16.4-ghc-7.6.patch
new file mode 100644
index 000000000000..e6d808bb98a5
--- /dev/null
+++ b/dev-haskell/c2hs/files/c2hs-0.16.4-ghc-7.6.patch
@@ -0,0 +1,34 @@
+--- c2hs-0.16.4-orig/src/C2HS/Config.hs 2012-11-01 08:02:48.000000000 +1100
++++ c2hs-0.16.4/src/C2HS/Config.hs 2012-11-03 12:12:15.754353409 +1100
+@@ -1,3 +1,4 @@
++{-# LANGUAGE CPP #-}
+ -- -*-haskell-*-
+ -- ** @configure_input@ **
+ -- ===========================================================================
+--- c2hs-0.16.4-orig/src/Control/StateTrans.hs 2012-11-01 08:02:48.000000000 +1100
++++ c2hs-0.16.4/src/Control/StateTrans.hs 2012-11-03 12:12:15.755353436 +1100
+@@ -1,3 +1,4 @@
++{-# LANGUAGE CPP, ScopedTypeVariables #-}
+ -- The HiPar Toolkit: state transformer routines
+ --
+ -- Author : Manuel M. T. Chakravarty
+@@ -80,6 +81,10 @@
+ -- Launchbury/Peyton-Jones' texts before entering. Otherwise,
+ -- your mental health my be in danger. You have been warned!
+
++#if !MIN_VERSION_base(4,6,0)
++import Prelude hiding (catch)
++#endif
++import Control.Exception (catch, IOException)
+
+ -- state transformer base and its monad operations
+ -- -----------------------------------------------
+@@ -298,7 +303,7 @@
+ ioError err
+ Right _a -> return state
+ )
+- `catch` (\err -> let
++ `catch` (\(err :: IOException) -> let
+ STB handler' = handler err
+ in
+ handler' bs gs)
diff --git a/dev-haskell/c2hs/metadata.xml b/dev-haskell/c2hs/metadata.xml
index 8c66906af531..fa448cca3bee 100644
--- a/dev-haskell/c2hs/metadata.xml
+++ b/dev-haskell/c2hs/metadata.xml
@@ -1,8 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>haskell</herd>
-<maintainer>
- <email>haskell@gentoo.org</email>
-</maintainer>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ C-&gt;Haskell assists in the development of Haskell bindings to C
+ libraries. It extracts interface information from C header
+ files and generates Haskell code with foreign imports and
+ marshaling. Unlike writing foreign imports by hand (or using
+ hsch2s), this ensures that C functions are imported with the
+ correct Haskell types.
+ </longdescription>
</pkgmetadata>