summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2010-07-17 12:41:26 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2010-07-17 12:41:26 +0000
commit50ec1384d28871f9aebf39f8df09d542a8297865 (patch)
treef26df867a5b311f1abb47a6d846eec1078fcea70 /dev-haskell
parentstable x86, bug 328479 (diff)
downloadgentoo-2-50ec1384d28871f9aebf39f8df09d542a8297865.tar.gz
gentoo-2-50ec1384d28871f9aebf39f8df09d542a8297865.tar.bz2
gentoo-2-50ec1384d28871f9aebf39f8df09d542a8297865.zip
Fixed building against newer Cabal library versions (bug #316613).
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/ghc-paths/ChangeLog7
-rw-r--r--dev-haskell/ghc-paths/ghc-paths-0.1.0.6.ebuild32
2 files changed, 36 insertions, 3 deletions
diff --git a/dev-haskell/ghc-paths/ChangeLog b/dev-haskell/ghc-paths/ChangeLog
index c43d4b701a3d..71ec5bba7370 100644
--- a/dev-haskell/ghc-paths/ChangeLog
+++ b/dev-haskell/ghc-paths/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/ghc-paths
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/ghc-paths/ChangeLog,v 1.2 2010/06/14 17:25:46 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/ghc-paths/ChangeLog,v 1.3 2010/07/17 12:41:26 slyfox Exp $
+
+ 17 Jul 2010; Sergei Trofimovich <slyfox@gentoo.org>
+ ghc-paths-0.1.0.6.ebuild:
+ Fixed building against newer Cabal library versions (bug #316613). Thanks
+ to Diego E. 'Flameeyes' Pettenò <flameeyes@gentoo.org> for the report.
*ghc-paths-0.1.0.6 (14 Jun 2010)
diff --git a/dev-haskell/ghc-paths/ghc-paths-0.1.0.6.ebuild b/dev-haskell/ghc-paths/ghc-paths-0.1.0.6.ebuild
index 8ba8e93c094e..253c18a7ccae 100644
--- a/dev-haskell/ghc-paths/ghc-paths-0.1.0.6.ebuild
+++ b/dev-haskell/ghc-paths/ghc-paths-0.1.0.6.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/ghc-paths/ghc-paths-0.1.0.6.ebuild,v 1.1 2010/06/14 17:25:46 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/ghc-paths/ghc-paths-0.1.0.6.ebuild,v 1.2 2010/07/17 12:41:26 slyfox Exp $
-CABAL_FEATURES="lib profile haddock"
+EAPI=2
+
+# haddock feature is explicitely disabled, as this library can be used as haddock depend
+CABAL_FEATURES="lib profile"
inherit haskell-cabal
DESCRIPTION="Knowledge of GHC's installation directories"
@@ -17,3 +20,28 @@ IUSE=""
RDEPEND=">=dev-lang/ghc-6.8"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ # ghc-patch it has awfully unportable (across cabal versions) ghc detection code
+ # but in gentoo we install it to fixed patch, so remove Setup.hs detection code
+ cabal-mksetup
+
+ # and use gentoo's hardcoded one:
+ # a few things we need to replace, and example values
+ # GHC_PATHS_LIBDIR /usr/lib64/ghc-6.12.0.20091010
+ # GHC_PATHS_DOCDIR /usr/share/doc/ghc-6.12.0.20091010/html
+ # GHC_PATHS_GHC_PKG /usr/bin/ghc-pkg
+ # GHC_PATHS_GHC /usr/bin/ghc (be careful: GHC_PATHS_GHC is a substring of GHC_PATHS_GHC_PKG)
+
+ cat >"${S}/GHC/Paths.hs" <<EOF
+module GHC.Paths ( ghc, ghc_pkg, libdir, docdir ) where
+
+libdir, docdir, ghc, ghc_pkg :: FilePath
+
+libdir = "$(ghc-libdir)"
+docdir = "/usr/share/doc/ghc-$(ghc-version)/html"
+
+ghc = "$(ghc-getghc)"
+ghc_pkg = "$(ghc-getghcpkg)"
+EOF
+}