summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-04-19 09:55:59 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-04-19 09:55:59 +0000
commita6cc773fbeb4bee22d77df4b94ed0c0c00ea1e88 (patch)
tree5711727ae73d83301a9598c05e7684ebf1f1d69a /dev-haskell
parentUpdate sci-mathematics/pari dependency to 2.3.4 (diff)
downloadgentoo-2-a6cc773fbeb4bee22d77df4b94ed0c0c00ea1e88.tar.gz
gentoo-2-a6cc773fbeb4bee22d77df4b94ed0c0c00ea1e88.tar.bz2
gentoo-2-a6cc773fbeb4bee22d77df4b94ed0c0c00ea1e88.zip
Version bump of dev-haskell/hunit
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hunit/ChangeLog9
-rw-r--r--dev-haskell/hunit/hunit-1.2.0.3.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-haskell/hunit/ChangeLog b/dev-haskell/hunit/ChangeLog
index b828fe46be1f..cf467e59a81d 100644
--- a/dev-haskell/hunit/ChangeLog
+++ b/dev-haskell/hunit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hunit
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hunit/ChangeLog,v 1.30 2008/10/03 23:46:30 fmccor Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hunit/ChangeLog,v 1.31 2009/04/19 09:55:59 kolmodin Exp $
+
+*hunit-1.2.0.3 (19 Apr 2009)
+
+ 19 Apr 2009; Lennart Kolmodin <kolmodin@gentoo.org> +hunit-1.2.0.3.ebuild:
+ Version bump.
03 Oct 2008; Ferris McCormick <fmccor@gentoo.org> hunit-1.2.0.0.ebuild:
Sparc stable, Bug #239465.
diff --git a/dev-haskell/hunit/hunit-1.2.0.3.ebuild b/dev-haskell/hunit/hunit-1.2.0.3.ebuild
new file mode 100644
index 000000000000..62f67b368ed3
--- /dev/null
+++ b/dev-haskell/hunit/hunit-1.2.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hunit/hunit-1.2.0.3.ebuild,v 1.1 2009/04/19 09:55:59 kolmodin Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit base haskell-cabal
+
+MY_PN="HUnit"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A unit testing framework for Haskell"
+HOMEPAGE="http://hunit.sourceforge.net/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ghc-6.6.1
+ >=dev-haskell/cabal-1.2"
+
+RDEPEND=">=dev-lang/ghc-6.6.1"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install () {
+ cabal_src_install
+ if use doc; then
+ dohtml -r "${S}/doc/"*
+ fi
+}