summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-02-01 19:50:58 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-02-01 19:50:58 +0000
commitd64f86f4fcb46fa8d4f1454e42c2ecdbddef0560 (patch)
treeae5fc47f7622e8e36ab4a25b711df64b07cc599f /dev-haskell
parentvanilla-3.13.1 + genpatches-3.13-3 + grsecurity-3.0-3.13.1-201401301657 (diff)
downloadgentoo-2-d64f86f4fcb46fa8d4f1454e42c2ecdbddef0560.tar.gz
gentoo-2-d64f86f4fcb46fa8d4f1454e42c2ecdbddef0560.tar.bz2
gentoo-2-d64f86f4fcb46fa8d4f1454e42c2ecdbddef0560.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/highlighting-kate/ChangeLog10
-rw-r--r--dev-haskell/highlighting-kate/highlighting-kate-0.5.6.1.ebuild36
2 files changed, 44 insertions, 2 deletions
diff --git a/dev-haskell/highlighting-kate/ChangeLog b/dev-haskell/highlighting-kate/ChangeLog
index 767a35d7b3fc..125a7a86b52e 100644
--- a/dev-haskell/highlighting-kate/ChangeLog
+++ b/dev-haskell/highlighting-kate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/highlighting-kate
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/ChangeLog,v 1.14 2013/12/11 06:02:01 gienah Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/ChangeLog,v 1.15 2014/02/01 19:50:58 slyfox Exp $
+
+*highlighting-kate-0.5.6.1 (01 Feb 2014)
+
+ 01 Feb 2014; Sergei Trofimovich <slyfox@gentoo.org>
+ +highlighting-kate-0.5.6.1.ebuild:
+ Version bump.
*highlighting-kate-0.5.5.1 (11 Dec 2013)
diff --git a/dev-haskell/highlighting-kate/highlighting-kate-0.5.6.1.ebuild b/dev-haskell/highlighting-kate/highlighting-kate-0.5.6.1.ebuild
new file mode 100644
index 000000000000..1ea2a7e14634
--- /dev/null
+++ b/dev-haskell/highlighting-kate/highlighting-kate-0.5.6.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/highlighting-kate-0.5.6.1.ebuild,v 1.1 2014/02/01 19:50:58 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Syntax highlighting"
+HOMEPAGE="http://github.com/jgm/highlighting-kate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable pcre-light"
+
+RDEPEND=">=dev-haskell/blaze-html-0.4.2:=[profile?] <dev-haskell/blaze-html-0.8:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ pcre-light? ( >=dev-haskell/pcre-light-0.4:=[profile?] <dev-haskell/pcre-light-0.5:=[profile?] )
+ !pcre-light? ( dev-haskell/regex-pcre-builtin:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ $(cabal_flag pcre-light pcre-light)
+}