summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-12-15 23:16:20 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-12-15 23:16:20 +0000
commitd947096be441d78e928089c41e79de1779d9e694 (patch)
tree08c6a8161cab2a15ffc2edd15d3e9e359ef47b2f /dev-haskell
parentAdd ~ppc64 keyword to dev-haskell/html. (diff)
downloadgentoo-2-d947096be441d78e928089c41e79de1779d9e694.tar.gz
gentoo-2-d947096be441d78e928089c41e79de1779d9e694.tar.bz2
gentoo-2-d947096be441d78e928089c41e79de1779d9e694.zip
Version bump dev-haskell/hunit.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hunit/ChangeLog7
-rw-r--r--dev-haskell/hunit/hunit-1.2.2.1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-haskell/hunit/ChangeLog b/dev-haskell/hunit/ChangeLog
index b664f133d44e..22effb6e606c 100644
--- a/dev-haskell/hunit/ChangeLog
+++ b/dev-haskell/hunit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hunit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hunit/ChangeLog,v 1.36 2009/09/12 17:28:41 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hunit/ChangeLog,v 1.37 2009/12/15 23:16:20 kolmodin Exp $
+
+*hunit-1.2.2.1 (15 Dec 2009)
+
+ 15 Dec 2009; <kolmodin@gentoo.org> +hunit-1.2.2.1.ebuild:
+ Version bump.
12 Sep 2009; Raúl Porcel <armin76@gentoo.org> hunit-1.2.0.3.ebuild:
ia64/sparc stable wrt #279736
diff --git a/dev-haskell/hunit/hunit-1.2.2.1.ebuild b/dev-haskell/hunit/hunit-1.2.2.1.ebuild
new file mode 100644
index 000000000000..b3aff3eb04b2
--- /dev/null
+++ b/dev-haskell/hunit/hunit-1.2.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hunit/hunit-1.2.2.1.ebuild,v 1.1 2009/12/15 23:16:20 kolmodin Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal
+
+MY_PN="HUnit"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A unit testing framework for Haskell"
+HOMEPAGE="http://hunit.sourceforge.net/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+
+RDEPEND=">=dev-lang/ghc-6.6.1"
+
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install () {
+ cabal_src_install
+ if use doc; then
+ dohtml -r "${S}/doc/"*
+ fi
+}
+
+src_install() {
+ cabal_src_install
+
+ # remove hunit self-tests, we don't want to install them
+ rm -rf "${D}/usr/bin"
+}