summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2015-03-15 21:09:37 +0000
committerJames Le Cuirot <chewi@gentoo.org>2015-03-15 21:09:37 +0000
commit40476c96de38b724bc5cd2e193da33b668e6db0c (patch)
treefc644bf5ded2f11093e42169797502eed8fcf2ce /dev-java/ant-eclipse-ecj
parentVersion bump plus some clean up. Fixes issue introduced in last (diff)
downloadgentoo-2-40476c96de38b724bc5cd2e193da33b668e6db0c.tar.gz
gentoo-2-40476c96de38b724bc5cd2e193da33b668e6db0c.tar.bz2
gentoo-2-40476c96de38b724bc5cd2e193da33b668e6db0c.zip
Version bump. Fixes issue introduced in last version where the rest of
eclipse-ecj was built and included in the jar. (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 9C6D7DE4)
Diffstat (limited to 'dev-java/ant-eclipse-ecj')
-rw-r--r--dev-java/ant-eclipse-ecj/ChangeLog8
-rw-r--r--dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.4.2.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-java/ant-eclipse-ecj/ChangeLog b/dev-java/ant-eclipse-ecj/ChangeLog
index 5bff0dd8dac1..74919f2271f0 100644
--- a/dev-java/ant-eclipse-ecj/ChangeLog
+++ b/dev-java/ant-eclipse-ecj/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/ant-eclipse-ecj
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-eclipse-ecj/ChangeLog,v 1.47 2015/02/10 18:51:46 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-eclipse-ecj/ChangeLog,v 1.48 2015/03/15 21:09:37 chewi Exp $
+
+*ant-eclipse-ecj-4.4.2 (15 Mar 2015)
+
+ 15 Mar 2015; James Le Cuirot <chewi@gentoo.org> +ant-eclipse-ecj-4.4.2.ebuild:
+ Version bump. Fixes issue introduced in last version where the rest of
+ eclipse-ecj was built and included in the jar.
10 Feb 2015; Miroslav Šulc <fordfrog@gentoo.org>
-ant-eclipse-ecj-4.2.ebuild:
diff --git a/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.4.2.ebuild b/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.4.2.ebuild
new file mode 100644
index 000000000000..f333895b9e8b
--- /dev/null
+++ b/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.4.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.4.2.ebuild,v 1.1 2015/03/15 21:09:37 chewi Exp $
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple prefix
+
+DMF="R-${PV}-201502041700"
+
+DESCRIPTION="Ant Compiler Adapter for Eclipse Java Compiler"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI="http://download.eclipse.org/eclipse/downloads/drops4/${DMF}/ecjsrc-${PV}.jar"
+
+LICENSE="EPL-1.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+SLOT="4.4"
+IUSE=""
+
+CDEPEND="~dev-java/eclipse-ecj-${PV}:${SLOT}
+ >=dev-java/ant-core-1.7"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.6"
+DEPEND="${CDEPEND}
+ app-arch/unzip
+ >=virtual/jdk-1.6"
+
+JAVA_GENTOO_CLASSPATH="ant-core,eclipse-ecj-${SLOT}"
+
+java_prepare() {
+ # Remove everything but the Ant component.
+ find org -type f ! -path "org/eclipse/jdt/internal/antadapter/*" ! -name "JDTCompilerAdapter.java" -delete || die
+
+ rm build.xml || die
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ find org -type f ! -name "*.java" | xargs jar uvf "${PN}.jar" || die "jar update failed"
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ insinto /usr/share/java-config-2/compiler
+ doins "${FILESDIR}/ecj-${SLOT}"
+ eprefixify "${D}"/usr/share/java-config-2/compiler/ecj-${SLOT}
+}