summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2012-02-18 22:13:17 +0000
committerVlastimil Babka <caster@gentoo.org>2012-02-18 22:13:17 +0000
commit27d442b00f3e4856750ec4e1d03bf1f575f498c8 (patch)
tree874096a6a813438b29eab1826a852002d455e362 /dev-java/ant-nodeps/ant-nodeps-1.8.2.ebuild
parentVersion bump, bug #351850. (diff)
downloadgentoo-2-27d442b00f3e4856750ec4e1d03bf1f575f498c8.tar.gz
gentoo-2-27d442b00f3e4856750ec4e1d03bf1f575f498c8.tar.bz2
gentoo-2-27d442b00f3e4856750ec4e1d03bf1f575f498c8.zip
Version bump, bug #351850.
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/ant-nodeps/ant-nodeps-1.8.2.ebuild')
-rw-r--r--dev-java/ant-nodeps/ant-nodeps-1.8.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-java/ant-nodeps/ant-nodeps-1.8.2.ebuild b/dev-java/ant-nodeps/ant-nodeps-1.8.2.ebuild
new file mode 100644
index 000000000000..f38d1616bfb2
--- /dev/null
+++ b/dev-java/ant-nodeps/ant-nodeps-1.8.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-nodeps/ant-nodeps-1.8.2.ebuild,v 1.1 2012/02/18 22:13:17 caster Exp $
+
+EAPI="4"
+
+ANT_TASK_DEPNAME=""
+
+inherit ant-tasks
+
+DESCRIPTION="Apache Ant's optional tasks requiring no external deps"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ # the classes were moved to ant-core in 1.8.2, this is just for compatibility
+ mkdir -p build/lib/empty && cd build/lib/empty || die
+ jar -cf ../${PN}.jar .
+}
+
+src_postinst() {
+ elog "Upstream has removed ant-nodeps.jar as of 1.8.2 and moved the classes to ant.jar"
+ elog "This package thus installs an empty jar for compatibility"
+ elog "and will be removed once reverse dependencies are transitioned."
+}