summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2004-08-30 20:15:11 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2004-08-30 20:15:11 +0000
commite88d15435c6af7ffbf8aff4b6faf64afa34a0b69 (patch)
treebe3c7156a6319d08ae1cd30ec0b95847f3509311 /dev-java/ant
parentVersion bump. Uses python eclass now (Manifest recommit) (diff)
downloadgentoo-2-e88d15435c6af7ffbf8aff4b6faf64afa34a0b69.tar.gz
gentoo-2-e88d15435c6af7ffbf8aff4b6faf64afa34a0b69.tar.bz2
gentoo-2-e88d15435c6af7ffbf8aff4b6faf64afa34a0b69.zip
Fixed parenthesising of date
Diffstat (limited to 'dev-java/ant')
-rw-r--r--dev-java/ant/ChangeLog7
-rw-r--r--dev-java/ant/ant-1.6.2-r4.ebuild85
-rw-r--r--dev-java/ant/files/1.6.2-r4/ant166
-rw-r--r--dev-java/ant/files/digest-ant-1.6.2-r41
4 files changed, 258 insertions, 1 deletions
diff --git a/dev-java/ant/ChangeLog b/dev-java/ant/ChangeLog
index da9a9f110cba..6cca52f4642b 100644
--- a/dev-java/ant/ChangeLog
+++ b/dev-java/ant/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/ant
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ChangeLog,v 1.73 2004/08/27 20:12:04 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ChangeLog,v 1.74 2004/08/30 20:15:10 karltk Exp $
+
+*ant-1.6.2-r4 (30 Aug 2004)
+
+ 30 Aug 2004; Karl Trygve Kalleberg <karltk@gentoo.org>
+ Fixed dependency on ant-optional to ant-tasks.
27 Aug 2004; Thomas Matthijs <axxo@gentoo.org>
-files/1.5.3/1_6_backport-jdk142.patch.gz, -files/1.5.3/ant,
diff --git a/dev-java/ant/ant-1.6.2-r4.ebuild b/dev-java/ant/ant-1.6.2-r4.ebuild
new file mode 100644
index 000000000000..658c760b86cb
--- /dev/null
+++ b/dev-java/ant/ant-1.6.2-r4.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.6.2-r4.ebuild,v 1.1 2004/08/30 20:15:10 karltk Exp $
+
+inherit java-pkg eutils
+
+DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
+HOMEPAGE="http://ant.apache.org/"
+SRC_URI="mirror://apache/ant/source/apache-${PN}-${PV}-src.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="doc"
+
+DEPEND="virtual/libc
+ >=virtual/jdk-1.4
+ >=dev-java/java-config-1.2"
+RDEPEND=">=virtual/jdk-1.4
+ app-shells/bash
+ >=dev-java/java-config-1.2"
+PDEPEND="=dev-java/ant-tasks-1.6.2-r2"
+
+S="${WORKDIR}/apache-ant-${PV}"
+
+pkg_setup() {
+ if [ -n "$JAVA_HOME" ] ; then
+ export CLASSPATH=".:$JAVA_HOME/lib:$JAVA_HOME/lib/tools.jar:$JAVA_HOME/jre/lib/rt.jar:."
+ else
+ einfo "Warning: JAVA_HOME environment variable is not set (or not exported)."
+ einfo " If build fails because sun.* classes could not be found"
+ einfo " you will need to set the JAVA_HOME environment variable"
+ einfo " to the installation directory of java."
+ einfo " Try using java-config script"
+ die
+ fi
+
+ if [ `arch` == "ppc" ] ; then
+ # We're compiling _ON_ PPC
+ export THREADS_FLAG="green"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Patch build.sh to die with non-zero exit code in case of errors.
+ # This patch may be useful for all ant versions.
+ epatch ${FILESDIR}/build.sh-exit-fix.patch.gz
+}
+
+src_compile() {
+ addwrite "/proc/self/maps"
+
+ local myc
+ myc="${myc} -Ddist.dir=${D}/usr/share/ant"
+ myc="${myc} -Djavac.target=1.4"
+
+ echo $CLASSPATH
+ ./build.sh -Ddist.dir=${D}/usr/share/ant || die
+}
+
+src_install() {
+ cp ${FILESDIR}/${PVR}/ant ${S}/src/ant
+
+ exeinto /usr/bin
+ doexe src/ant
+
+ dodir /usr/share/ant/bin
+ for each in antRun runant.pl runant.py complete-ant-cmd.pl ; do
+ dobin ${S}/src/script/${each}
+ dosym /usr/bin/${each} /usr/share/ant/bin/${each}
+ done
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/20ant
+
+ java-pkg_dojar build/lib/ant.jar
+ java-pkg_dojar build/lib/ant-launcher.jar
+
+ dodoc LICENSE LICENSE.* README WHATSNEW KEYS
+ use doc && dohtml welcome.html
+ use doc && dohtml -r docs/*
+}
diff --git a/dev-java/ant/files/1.6.2-r4/ant b/dev-java/ant/files/1.6.2-r4/ant
new file mode 100644
index 000000000000..ba5956c50cd9
--- /dev/null
+++ b/dev-java/ant/files/1.6.2-r4/ant
@@ -0,0 +1,166 @@
+#! /bin/bash
+
+# Copyright 2001-2004 The Apache Software Foundation
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# Edited for Gentoo Linux
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/files/1.6.2-r4/ant,v 1.1 2004/08/30 20:15:11 karltk Exp $
+
+# Extract launch and ant arguments, (see details below).
+ant_exec_args=
+no_config=false
+use_jikes_default=false
+ant_exec_debug=false
+show_help=false
+for arg in "$@" ; do
+ if [ "$arg" = "--noconfig" ] ; then
+ no_config=true
+ elif [ "$arg" = "--usejikes" ] ; then
+ use_jikes_default=true
+ elif [ "$arg" = "--execdebug" ] ; then
+ ant_exec_debug=true
+ elif [ my"$arg" = my"--h" -o my"$arg" = my"--help" ] ; then
+ show_help=true
+ ant_exec_args="$ant_exec_args -h"
+ else
+ if [ my"$arg" = my"-h" -o my"$arg" = my"-help" ] ; then
+ show_help=true
+ fi
+ ant_exec_args="$ant_exec_args \"$arg\""
+ fi
+done
+
+# Source/default ant configuration
+if $no_config ; then
+ rpm_mode=false
+ usejikes=$use_jikes_default
+else
+ # load system-wide ant configuration
+ if [ -f "/etc/ant.conf" ] ; then
+ . /etc/ant.conf
+ fi
+
+ # load user ant configuration
+ if [ -f "$HOME/.ant/ant.conf" ] ; then
+ . $HOME/.ant/ant.conf
+ fi
+ if [ -f "$HOME/.antrc" ] ; then
+ . "$HOME/.antrc"
+ fi
+
+ # provide default configuration values
+ if [ -z "$rpm_mode" ] ; then
+ rpm_mode=false
+ fi
+ if [ -z "$usejikes" ] ; then
+ usejikes=$use_jikes_default
+ fi
+fi
+
+if [ -f $HOME/.gentoo/java-env ] ; then
+ source $HOME/.gentoo/java-env
+else
+ JAVA_HOME=`java-config --jdk-home`
+ CLASSPATH=`java-config --classpath`:${CLASSPATH}
+fi
+
+if [ -z $JAVA_HOME ] ; then
+ echo "Error: No JDK found!"
+ echo "Try using java-config script to set your JDK"
+ echo "Remember that you need a JDK not a JRE"
+ exit 1
+fi
+
+ANT_HOME=/usr/share/ant
+
+# set ANT_LIB location
+ANT_LIB="${ANT_HOME}/lib"
+
+JAVACMD="`java-config --java`"
+
+if [ ! -x "$JAVACMD" ] ; then
+ echo "Error: JAVA_HOME is not defined correctly."
+ echo " We cannot execute $JAVACMD"
+ exit 1
+fi
+
+if [ -z "$LOCALCLASSPATH" ] ; then
+ LOCALCLASSPATH=$ANT_LIB/ant-launcher.jar
+else
+ LOCALCLASSPATH=$ANT_LIB/ant-launcher.jar:$LOCALCLASSPATH
+fi
+
+# add in the dependency .jar files
+LOCALCLASSPATH="${LOCALCLASSPATH}:`java-config --classpath=ant,ant-optional,log4j,xerces-2,xalan,junit,antlr,bcel,bsh,commons-beanutils,commons-logging,commons-net,oro,jdepend,jsch,regexp,rhino,jython,jta,jaf,javamail 2> /dev/null`"
+
+if [ -n "$JAVA_HOME" ] ; then
+ if [ -f "$JAVA_HOME/lib/tools.jar" ] ; then
+ LOCALCLASSPATH="$LOCALCLASSPATH:$JAVA_HOME/lib/tools.jar"
+ fi
+
+ if [ -f "$JAVA_HOME/lib/classes.zip" ] ; then
+ LOCALCLASSPATH="$LOCALCLASSPATH:$JAVA_HOME/lib/classes.zip"
+ fi
+
+else
+ echo "Warning: JAVA_HOME environment variable is not set (or not exported)."
+ echo " If build fails because sun.* classes could not be found"
+ echo " you will need to set the JAVA_HOME environment variable"
+ echo " to the installation directory of java."
+ echo " Try using java-config script"
+fi
+
+# Allow Jikes support (off by default)
+if $usejikes; then
+ ANT_OPTS="$ANT_OPTS -Dbuild.compiler=jikes"
+fi
+
+# Show script help if requested
+if $show_help ; then
+ echo $0 '[script options] [options] [target [target2 [target3] ..]]'
+ echo 'Script Options:'
+ echo ' --help, --h print this message and ant help'
+ echo ' --noconfig suppress sourcing of /etc/ant.conf,'
+ echo ' $HOME/.ant/ant.conf, and $HOME/.antrc'
+ echo ' configuration files'
+ echo ' --usejikes enable use of jikes by default, unless'
+ echo ' set explicitly in configuration files'
+ echo ' --execdebug print ant exec line generated by this'
+ echo ' launch script'
+ echo ' '
+fi
+
+# Execute ant using eval/exec to preserve spaces in paths,
+# java options, and ant args
+ant_sys_opts=
+
+
+if [ -n "$JIKESPATH" ]; then
+ ant_sys_opts="-Djikes.class.path=\"$JIKESPATH\""
+fi
+
+# 2002-11-02, karltk@gentoo.org:
+# The Blackdown JDK on PPC hiccups with native threads
+#
+if [ "`arch`" == "ppc" ] ; then
+ export THREADS_FLAG="green"
+fi
+
+
+ant_exec_command="exec \"$JAVACMD\" $ANT_OPTS -classpath \"$LOCALCLASSPATH\" -Dant.home=\"$ANT_HOME\" -Dant.library.dir=\"$ANT_LIB\" $ant_sys_opts org.apache.tools.ant.launch.Launcher $ANT_ARGS -lib \"$CLASSPATH\" $ant_exec_args"
+
+if $ant_exec_debug ; then
+ echo $ant_exec_command
+fi
+eval $ant_exec_command
diff --git a/dev-java/ant/files/digest-ant-1.6.2-r4 b/dev-java/ant/files/digest-ant-1.6.2-r4
new file mode 100644
index 000000000000..511c4167d672
--- /dev/null
+++ b/dev-java/ant/files/digest-ant-1.6.2-r4
@@ -0,0 +1 @@
+MD5 83c3adefdbf90bcbc4b804d4c55c0778 apache-ant-1.6.2-src.tar.bz2 6282237