summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-05-09 12:19:24 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-05-09 12:19:24 +0000
commit5d20a255c47a93ba5c499faeca968c0fcae17d51 (patch)
treee909890a155dbb3aa30726c4a9473a1873e72b89 /dev-java/antlr
parentadd ~arm, bug #462506 (diff)
downloadgentoo-2-5d20a255c47a93ba5c499faeca968c0fcae17d51.tar.gz
gentoo-2-5d20a255c47a93ba5c499faeca968c0fcae17d51.tar.bz2
gentoo-2-5d20a255c47a93ba5c499faeca968c0fcae17d51.zip
Revert stable ebuilds.
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/antlr')
-rw-r--r--dev-java/antlr/ChangeLog6
-rw-r--r--dev-java/antlr/antlr-2.7.7-r2.ebuild39
-rw-r--r--dev-java/antlr/antlr-2.7.7.ebuild38
3 files changed, 41 insertions, 42 deletions
diff --git a/dev-java/antlr/ChangeLog b/dev-java/antlr/ChangeLog
index c995affa6bdf..ed8b2aed063b 100644
--- a/dev-java/antlr/ChangeLog
+++ b/dev-java/antlr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/antlr
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/ChangeLog,v 1.96 2013/05/09 11:45:47 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/ChangeLog,v 1.97 2013/05/09 12:19:24 tomwij Exp $
+
+ 09 May 2013; Tom Wijsman <TomWij@gentoo.org> antlr-2.7.7-r2.ebuild,
+ antlr-2.7.7.ebuild:
+ Revert stable ebuilds.
09 May 2013; Tom Wijsman <TomWij@gentoo.org> antlr-2.7.7-r1.ebuild,
antlr-2.7.7-r2.ebuild, antlr-2.7.7-r3.ebuild, antlr-2.7.7-r4.ebuild,
diff --git a/dev-java/antlr/antlr-2.7.7-r2.ebuild b/dev-java/antlr/antlr-2.7.7-r2.ebuild
index eebb53a435a0..bb3ac35e746b 100644
--- a/dev-java/antlr/antlr-2.7.7-r2.ebuild
+++ b/dev-java/antlr/antlr-2.7.7-r2.ebuild
@@ -1,16 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.7-r2.ebuild,v 1.7 2013/05/09 11:45:47 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.7-r2.ebuild,v 1.8 2013/05/09 12:19:24 tomwij Exp $
-EAPI="5"
+EAPI="3"
+PYTHON_DEPEND="python? 2"
-PYTHON_COMPAT=( python2_{5,6,7} )
-
-DISTUTILS_OPTIONAL="y"
-DISTUTILS_SINGLE_IMPL="y"
-DISTUTILS_IN_SOURCE_BUILD="y"
-
-inherit base java-pkg-2 mono autotools distutils-r1 multilib toolchain-funcs versionator
+inherit base java-pkg-2 mono distutils multilib toolchain-funcs versionator
DESCRIPTION="A parser generator for C++, C#, Java, and Python"
HOMEPAGE="http://www.antlr2.org/"
@@ -22,8 +17,7 @@ KEYWORDS="amd64 ~arm ppc ppc64 x86 ~x86-fbsd"
IUSE="doc debug examples mono +cxx +java python script source static-libs"
# TODO do we actually need jdk at runtime?
-RDEPEND="python? ( ${PYTHON_DEPS} )
- >=virtual/jdk-1.3
+RDEPEND=">=virtual/jdk-1.3
mono? ( dev-lang/mono )"
DEPEND="${RDEPEND}
script? ( !dev-util/pccts )
@@ -43,21 +37,17 @@ make_shared_lib() {
pkg_setup() {
java-pkg-2_pkg_setup
- if use python ; then
- python-single-r1_pkg_setup
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
fi
}
src_prepare() {
base_src_prepare
-
sed -i \
-e 's/install:.*this-install/install:/' \
lib/cpp/src/Makefile.in || die
-
- # See bug #468540, this can be removed once bug #469150 is fixed.
- sed -i 's/tlib lib ar/ar/' configure.in || die
- eautoreconf
}
src_configure() {
@@ -129,9 +119,8 @@ src_install() {
fi
if use python ; then
- pushd "${S}"/lib/python > /dev/null
- distutils-r1_python_install
- popd > /dev/null
+ cd "${S}"/lib/python
+ distutils_src_install
fi
if use examples ; then
@@ -148,3 +137,11 @@ src_install() {
newdoc "${S}"/README.txt README || die
}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}
diff --git a/dev-java/antlr/antlr-2.7.7.ebuild b/dev-java/antlr/antlr-2.7.7.ebuild
index 13dd5fd2dd7b..495cdca35a2f 100644
--- a/dev-java/antlr/antlr-2.7.7.ebuild
+++ b/dev-java/antlr/antlr-2.7.7.ebuild
@@ -1,16 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.7.ebuild,v 1.19 2013/05/09 11:45:47 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.7.ebuild,v 1.20 2013/05/09 12:19:24 tomwij Exp $
-EAPI="5"
+EAPI="3"
+PYTHON_DEPEND="python? 2"
-PYTHON_COMPAT=( python2_{5,6,7} )
-
-DISTUTILS_OPTIONAL="y"
-DISTUTILS_SINGLE_IMPL="y"
-DISTUTILS_IN_SOURCE_BUILD="y"
-
-inherit base java-pkg-2 mono autotools distutils-r1 multilib
+inherit base java-pkg-2 mono distutils multilib
DESCRIPTION="A parser generator for C++, C#, Java, and Python"
HOMEPAGE="http://www.antlr2.org/"
@@ -22,8 +17,7 @@ KEYWORDS="amd64 ~arm ppc ppc64 x86 ~x86-fbsd"
IUSE="doc debug examples mono +cxx +java python script source"
# TODO do we actually need jdk at runtime?
-RDEPEND="python? ( ${PYTHON_DEPS} )
- >=virtual/jdk-1.3
+RDEPEND=">=virtual/jdk-1.3
mono? ( dev-lang/mono )"
DEPEND="${RDEPEND}
script? ( !dev-util/pccts )
@@ -34,17 +28,14 @@ PATCHES=( "${FILESDIR}/2.7.7-gcc-4.3.patch" "${FILESDIR}/2.7.7-gcc-4.4.patch" "$
pkg_setup() {
java-pkg-2_pkg_setup
- if use python ; then
- python-single-r1_pkg_setup
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
fi
}
src_prepare() {
base_src_prepare
-
- # See bug #468540, this can be removed once bug #469150 is fixed.
- sed -i 's/tlib lib ar/ar/' configure.in || die
- eautoreconf
}
src_configure() {
@@ -105,9 +96,8 @@ src_install() {
fi
if use python ; then
- pushd "${S}"/lib/python > /dev/null
- distutils-r1_python_install
- popd > /dev/null
+ cd "${S}"/lib/python
+ distutils_src_install
fi
if use examples ; then
@@ -124,3 +114,11 @@ src_install() {
newdoc "${S}"/README.txt README || die
}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}